Jump to: navigation, search

Difference between revisions of "Equinox Resource Monitoring Demo"

(Sleak)
Line 60: Line 60:
  
 
===Sleak===
 
===Sleak===
* expand Sleak
+
* In the <em>Contributions View</em> expand the <em>Sleak</em> element.
* TODO why don't these numbers look right??
+
* <em>TODO:</em> This is currently broken and needs to be fixed.
  
 
===VM===
 
===VM===

Revision as of 14:36, 2 March 2007

Server Setup

  • Install the server zip file into an Eclipse SDK (tested with build I0228-0930).
  • Note you can set port and protocol via System properties (but we won't).
  • Start the SDK.
    • The server will start automatically.
  • Create resources in the workspace.
    • File -> Import -> Plug-ins and Fragments -> Import As Projects with source folders
    • Type org.eclipse.equinox.* in the filter to get all the Equinox projects selected and choose Add
    • Finish.
    • Note: The Equinox projects appear in the workspace
  • Look at a preference value.
    • Window -> Preferences -> General -> Workspace -> Build Automatically
    • Note: the auto-build preference is set to be true.
    • Close the Preferences window.

Client

  • Install the client zip file into an Eclipse SDK (tested with build I0228-0930).
  • Start the SDK.
  • Switch perspectives and create a connection to the server.
    • Window -> Open Perspective -> Other -> JMX Resource Management
    • JMX Server -> Open Connection
    • Choose proper host, port and protocol. (default is localhost, 8118, and rmi)
    • OK.
  • Note: The Contributions View will be populated with the available contributions from the server.

Bundles

  • In the Contributions View, expand the Bundles element.
    • Note: These are all the bundles that are installed on the server.
  • Expand org.eclipse.equinox.registry.
    • Note: The imported packages and required bundles are listed as well as the services.
    • Expand the imported packages to show what it requires.
    • Expand the required bundles to show what it requires.
      • Expand org.eclipse.equinox.common to show it is recursive.
    • Expand Services.
      • Note: there are 3 different icons, one each for providing, using, and both.

Extension Registry

  • In the Contributions View expand the Extension Points element.
    • Note: All the extension points are listed.
  • Navigate to the org.eclipse.runtime.applications extension point
    • Note: All of the available applications should be there, including the JMX server application and the IDE application.
  • TODO: Can we hook in Tom's demos here? click on an extension and start it remotely?
  • Future work: add extensions, namespaces, better grouping, and more methods.

Preferences

  • In the Contributions View expand the Preferences element.
  • Expand to Preferences -> instance -> org.eclipse.core.resources.
  • Select the org.eclipse.core.resources node.
  • In the Operations part of the editor, select the put operation.
  • In Invocation View, set the parameters to be the key description.autobuilding and the value false.
  • Select the Invoke button.
  • Look at the preference on the server.
    • On the server choose: Window -> Preferences -> General -> Workspace.
    • Note: The Build Automatically preference is now unchecked.

Services

  • In the Contributions View expand the Services element.
  • Expand the org.eclipse.core.runtime.IExtensionRegistry element.
  • Expand the Bundles element and see who is importing the service, exporting the service, and both.

Sleak

  • In the Contributions View expand the Sleak element.
  • TODO: This is currently broken and needs to be fixed.

VM

  • In the Contributions View expand the VM Stats element.
  • Note: All the VM info is for the VM currently running the server.

Workspace Resources

  • In the Contributions View expand the Workspace Resources element.
  • Note: The Equinox projects that you previously imported into the server's workspace should be in the list.
  • Select the org.eclipse.equinox.launcher.win32.win32.x86 fragment.
  • In the editor, in the Operations part of the form, select the delete method.
  • Make the Navigator View from the server instance visible to the user.
  • In the Invocation View select the Delete button.
  • Note: The launcher fragment project was deleted from the server's workspace.