Jump to: navigation, search

Difference between revisions of "Equinox Resource Monitoring Demo"

(Extension Registry)
(Preferences)
Line 46: Line 46:
  
 
====Preferences====
 
====Preferences====
* Expand Preferences -> instance -> org.eclipse.core.resources
+
* In the <em>Contributions View</em> expand the <em>Preferences</em> element.
* select node
+
* Expand to <em>Preferences -> instance -> org.eclipse.core.resources</em>.
* select operation Put
+
* Select the <code>org.eclipse.core.resources</code> node.
* In Invocation view, make the key "description.autobuilding" and the value "false"
+
* In the <em>Operations</em> part of the editor, select the <code>put</code> operation.
* Invoke
+
* In <em>Invocation View</em>, set the parameters to be the key <code>description.autobuilding</code> and the value <code>false</code>.
* Window -> Preferences -> General -> Workspace
+
* Select the <em>Invoke</em> button.
* Note that the Build Automatically preference is now unchecked
+
* Look at the preference on the server.
 +
** On the server choose: <em>Window -> Preferences -> General -> Workspace</em>.
 +
** <em>Note:</em> The <em>Build Automatically</em> preference is now unchecked.
  
 
====Services====
 
====Services====

Revision as of 10:56, 2 March 2007

Demo - in SDK

Server

  • Install the server zip file into an Eclipse SDK (tested with build I0228-0930).
  • Note you can set port and protocol via System properties (but we won't).
  • Start the SDK.
    • The server will start automatically.
  • Create resources in the workspace.
    • File -> Import -> Plug-ins and Fragments -> Import As Projects with source folders
    • Type org.eclipse.equinox.* in the filter to get all the Equinox projects selected and choose Add
    • Finish.
    • Note: The Equinox projects appear in the workspace
  • Look at a preference value.
    • Window -> Preferences -> General -> Workspace -> Build Automatically
    • Note: the auto-build preference is set to be true.
    • Close the Preferences window.

Client

  • Install the client zip file into an Eclipse SDK (tested with build I0228-0930).
  • Start the SDK.
  • Switch perspectives and create a connection to the server.
    • Window -> Open Perspective -> Other -> JMX Resource Management
    • JMX Server -> Open Connection
    • Choose proper host, port and protocol. (default is localhost, 8118, and rmi)
    • OK.
  • Note: The Contributions View will be populated with the available contributions from the server.

Bundles

  • In the Contributions View, expand the Bundles element.
    • Note: These are all the bundles that are installed on the server.
  • Expand org.eclipse.equinox.registry.
    • Note: The imported packages and required bundles are listed as well as the services.
    • Expand the imported packages to show what it requires.
    • Expand the required bundles to show what it requires.
      • Expand org.eclipse.equinox.common to show it is recursive.
    • Expand Services.
      • Note: there are 3 different icons, one each for providing, using, and both.

Extension Registry

  • In the Contribution View expand the Extension Points element.
    • Note: All the extension points are listed.
  • Navigate to the org.eclipse.runtime.applications extension point
    • Note: All of the available applications should be there, including the JMX server application and the IDE application.
  • TODO: Can we hook in Tom's demos here? click on an extension and start it remotely?
  • Future work: add extensions, namespaces, better grouping, and more methods.

Preferences

  • In the Contributions View expand the Preferences element.
  • Expand to Preferences -> instance -> org.eclipse.core.resources.
  • Select the org.eclipse.core.resources node.
  • In the Operations part of the editor, select the put operation.
  • In Invocation View, set the parameters to be the key description.autobuilding and the value false.
  • Select the Invoke button.
  • Look at the preference on the server.
    • On the server choose: Window -> Preferences -> General -> Workspace.
    • Note: The Build Automatically preference is now unchecked.

Services

  • expand org.eclipse.core.runtime.IExtensionRegistry
  • expand Bundles and see who is importing the service, exporting the service, and both

Sleak

  • expand Sleak
  • TODO why don't these numbers look right??

VM

  • expand VM Stats
  • look at all the VM info

Workspace Resources

  • see the 6 equinox projects in the workspace.
  • select the launcher fragment
  • in the operations part of the form, select delete
  • make the navigator from the server instance visible to the user
  • in the invocation view hit Delete
  • note that the resource was deleted from the server

Demo - standalone application

  • unzip exported product
  • set up ppro VM
  • start the server

End-to-End demo

  • get the osgi.jar from the latest build
  • start OSGi: java -jar osgi.jar -console
  • install the file installer jar
  • drop in the server bundles