Jump to: navigation, search

Difference between revisions of "Equinox Resource Monitoring Demo"

(Extension Registry)
Line 38: Line 38:
  
 
====Extension Registry====
 
====Extension Registry====
* all the extension points are listed
+
* In the <em>Contribution View</em> expand the <em>Extension Points</em> element.
* future work: add extensions, namespaces, better grouping, and more methods
+
** <em>Note:</em> All the extension points are listed.
* navigate to the runtime.applications extension point and see the server application and ide application
+
* Navigate to the <code>org.eclipse.runtime.applications</code> extension point
* Note: can we hook in Tom's demos here? click on an extension and start it remotely?
+
** <em>Note:</em> All of the available applications should be there, including the JMX server application and the IDE application.
 +
* <em>TODO:</em> Can we hook in Tom's demos here? click on an extension and start it remotely?
 +
* <em>Future work:</em> add extensions, namespaces, better grouping, and more methods.
  
 
====Preferences====
 
====Preferences====

Revision as of 11:51, 2 March 2007

Demo - in SDK

Server

  • Install the server zip file into an Eclipse SDK (tested with build I0228-0930).
  • Note you can set port and protocol via System properties (but we won't).
  • Start the SDK.
    • The server will start automatically.
  • Create resources in the workspace.
    • File -> Import -> Plug-ins and Fragments -> Import As Projects with source folders
    • Type org.eclipse.equinox.* in the filter to get all the Equinox projects selected and choose Add
    • Finish.
    • Note: The Equinox projects appear in the workspace
  • Look at a preference value.
    • Window -> Preferences -> General -> Workspace -> Build Automatically
    • Note: the auto-build preference is set to be true.
    • Close the Preferences window.

Client

  • Install the client zip file into an Eclipse SDK (tested with build I0228-0930).
  • Start the SDK.
  • Switch perspectives and create a connection to the server.
    • Window -> Open Perspective -> Other -> JMX Resource Management
    • JMX Server -> Open Connection
    • Choose proper host, port and protocol. (default is localhost, 8118, and rmi)
    • OK.
  • Note: The Contributions View will be populated with the available contributions from the server.

Bundles

  • In the Contributions View, expand the Bundles element.
    • Note: These are all the bundles that are installed on the server.
  • Expand org.eclipse.equinox.registry.
    • Note: The imported packages and required bundles are listed as well as the services.
    • Expand the imported packages to show what it requires.
    • Expand the required bundles to show what it requires.
      • Expand org.eclipse.equinox.common to show it is recursive.
    • Expand Services.
      • Note: there are 3 different icons, one each for providing, using, and both.

Extension Registry

  • In the Contribution View expand the Extension Points element.
    • Note: All the extension points are listed.
  • Navigate to the org.eclipse.runtime.applications extension point
    • Note: All of the available applications should be there, including the JMX server application and the IDE application.
  • TODO: Can we hook in Tom's demos here? click on an extension and start it remotely?
  • Future work: add extensions, namespaces, better grouping, and more methods.

Preferences

  • Expand Preferences -> instance -> org.eclipse.core.resources
  • select node
  • select operation Put
  • In Invocation view, make the key "description.autobuilding" and the value "false"
  • Invoke
  • Window -> Preferences -> General -> Workspace
  • Note that the Build Automatically preference is now unchecked

Services

  • expand org.eclipse.core.runtime.IExtensionRegistry
  • expand Bundles and see who is importing the service, exporting the service, and both

Sleak

  • expand Sleak
  • TODO why don't these numbers look right??

VM

  • expand VM Stats
  • look at all the VM info

Workspace Resources

  • see the 6 equinox projects in the workspace.
  • select the launcher fragment
  • in the operations part of the form, select delete
  • make the navigator from the server instance visible to the user
  • in the invocation view hit Delete
  • note that the resource was deleted from the server

Demo - standalone application

  • unzip exported product
  • set up ppro VM
  • start the server

End-to-End demo

  • get the osgi.jar from the latest build
  • start OSGi: java -jar osgi.jar -console
  • install the file installer jar
  • drop in the server bundles