Jump to: navigation, search

Difference between revisions of "Equinox Resource Monitoring Demo"

Line 2: Line 2:
  
 
===Server===
 
===Server===
* install server zip into SDK
+
* Install the server zip file into an Eclipse SDK (tested with build I0228-0930).
* set port and protocol
+
* Note you can set port and protocol via System properties (but we won't).
* start SDK
+
* Start the SDK.
** server will start automatically
+
** The server will start automatically.
* create some resources in the workspace
+
* Create resources in the workspace.
** File -> Import -> Plug-ins and Fragments -> Import As Projects with source folders
+
** <em>File -> Import -> Plug-ins and Fragments -> Import As Projects with source folders</em>
** type "org.eclipse.equinox.*" in the filter and choose Add
+
** Type <code>org.eclipse.equinox.*</code> in the filter to get all the Equinox projects selected and choose <em>Add</em>
** Finish
+
** Finish.
* set a preference value
+
** <em>Note:</em> The Equinox projects appear in the workspace
** Window -> Preferences -> General -> Workspace -> Build Automatically
+
* Look at a preference value.
** Note that it is checked to be true
+
** <em>Window -> Preferences -> General -> Workspace -> Build Automatically</em>
** close Preferences window
+
** <em>Note:</em> the auto-build preference is set to be true.
 +
** Close the Preferences window.
  
 
===Client===
 
===Client===
* install client zip into SDK
+
* Install the client zip file into an Eclipse SDK (tested with build I0228-0930).
* start SDK
+
* Start the SDK.
* JMX Server -> Open Connection
+
* <em>Window -> Open Perspective -> Other -> JMX Resource Management</em>
* choose proper host, port and protocol
+
* <em>JMX Server -> Open Connection</em>
* OK
+
* Choose proper host, port and protocol. (default is <em>localhost</em>, <em>8118</em>, and <em>rmi</em>)
 +
* OK.
  
 
====Bundles====
 
====Bundles====

Revision as of 10:38, 2 March 2007

Demo - in SDK

Server

  • Install the server zip file into an Eclipse SDK (tested with build I0228-0930).
  • Note you can set port and protocol via System properties (but we won't).
  • Start the SDK.
    • The server will start automatically.
  • Create resources in the workspace.
    • File -> Import -> Plug-ins and Fragments -> Import As Projects with source folders
    • Type org.eclipse.equinox.* in the filter to get all the Equinox projects selected and choose Add
    • Finish.
    • Note: The Equinox projects appear in the workspace
  • Look at a preference value.
    • Window -> Preferences -> General -> Workspace -> Build Automatically
    • Note: the auto-build preference is set to be true.
    • Close the Preferences window.

Client

  • Install the client zip file into an Eclipse SDK (tested with build I0228-0930).
  • Start the SDK.
  • Window -> Open Perspective -> Other -> JMX Resource Management
  • JMX Server -> Open Connection
  • Choose proper host, port and protocol. (default is localhost, 8118, and rmi)
  • OK.

Bundles

  • expand Bundles
    • note these are all the bundles that are installed on the server
  • expand org.eclipse.equinoix.registry
    • note that the imported packages and required bundles are listed as well as the services
    • expand the imported packages to show what it requires
    • expand the required bundles to show what it requires
      • expand org.eclipse.equinox.common to show it is recursive
    • expand Services
      • note the 3 different icons for providing, using, and both

Extension Registry

  • all the extension points are listed
  • future work: add extensions, namespaces, better grouping, and more methods
  • navigate to the runtime.applications extension point and see the server application and ide application
  • Note: can we hook in Tom's demos here? click on an extension and start it remotely?

Preferences

  • Expand Preferences -> instance -> org.eclipse.core.resources
  • select node
  • select operation Put
  • In Invocation view, make the key "description.autobuilding" and the value "false"
  • Invoke
  • Window -> Preferences -> General -> Workspace
  • Note that the Build Automatically preference is now unchecked

Services

  • expand org.eclipse.core.runtime.IExtensionRegistry
  • expand Bundles and see who is importing the service, exporting the service, and both

Sleak

  • expand Sleak
  • TODO why don't these numbers look right??

VM

  • expand VM Stats
  • look at all the VM info

Workspace Resources

  • see the 6 equinox projects in the workspace.
  • select the launcher fragment
  • in the operations part of the form, select delete
  • make the navigator from the server instance visible to the user
  • in the invocation view hit Delete
  • note that the resource was deleted from the server

Demo - standalone application

  • unzip exported product
  • set up ppro VM
  • start the server

End-to-End demo

  • get the osgi.jar from the latest build
  • start OSGi: java -jar osgi.jar -console
  • install the file installer jar
  • drop in the server bundles