Skip to main content
Jump to: navigation, search

Difference between revisions of "Efxclipse/Tutorials/AddingE(fx)clipse to eclipse"

(Configure eclipse to use a JDK not a JRE)
(Configure eclipse to use a JDK not a JRE)
 
Line 46: Line 46:
 
= Configure eclipse to use a JDK not a JRE =
 
= Configure eclipse to use a JDK not a JRE =
 
When doing a '''ant build and run''' from the '''FX Build Configuration''' (file: build.fxbuild) the JRE Library must really be a JDK.  The following step show how to configure a JRE as a JDK so the '''ant build and run''' will work.
 
When doing a '''ant build and run''' from the '''FX Build Configuration''' (file: build.fxbuild) the JRE Library must really be a JDK.  The following step show how to configure a JRE as a JDK so the '''ant build and run''' will work.
[[File:FX_Build_Config.png]]
+
[[File:FX_Build_Config.png|none|900px]]
 
# Window -> Preferences
 
# Window -> Preferences
[[File:Window_Preferences.png|none|900px]]
+
[[File:Window_Preferences.png|none]]
 
# Java -> Installed JREs
 
# Java -> Installed JREs
 
# Press the '''Add...''' button.
 
# Press the '''Add...''' button.

Latest revision as of 11:16, 10 September 2015

Installing e(fx)clipse IDE.

How to install e(fx)clipse on a Mars 4.5.0 version of eclipse. These instructions were written and the screen captures taken with a clean install of the Eclipse for RCP and RAP Developers 64 bit package available here (http://www.eclipse.org/downloads/packages/eclipse-rcp-and-rap-developers/marsr). The Operating system used was Windows 7 SP1. These steps do not include the install of eclipse 4.5.0 (Mars).

Help Install New Software.png
  1. Select the Help menu.
  2. Select the Install New Software... option.
Install Work with All Available Sites Uncheck Group items by category Check e(fx)clipse - IDE.png
  1. Select the --All Available Sites -- option from the Work with: drop down list.
  2. Uncheck the Group items by category check box in the bottom details section.
  3. Check only the e(fx)clipse - IDE Name option. All the other options starting with e(fx)clipse - IDE are subsets of the full e(fx)clipse IDE. The e(fx)clipse - Minimal JavaFX OSGi integration bundles option is out of scope for these instructions.
  4. Press the Next > button.
Install Install Details Next.png
  1. Press the Next > button.
I accept the terms of the license agreement.png
  1. Press the I accept the terms of the license agreement radio button.
  2. Press the Finish button.
Installing Software.png
  1. Wait about 2 minutes for the install to complete.
Software Updates.png
  1. Press the Yes button.

Setup a target platform for your application development

Preferences Plug-in Development Target Platform Add.png
  1. Open Window > Preferences > Plugin-in Development > Target Platform
  2. Click Add ... on the right.
New Target Definition Nothing Start with an empty target definition.png
  1. Select Nothing: Start with an empty target definition.
  2. Press the Next > button.
New Target Definition Name e(fx)eclipse Add.png
  1. Enter e(fx)clipse as the target platform Name:.
  2. Press the Add... button.
Add Content Add Software Site Next.png
  1. Select Software Site. Then press the Next > button.
Add Content Add Software Site FX Target Uncheck Include required software Finish.png
  1. Enter http://download.eclipse.org/efxclipse/runtime-released/2.0.0/site as the site. Press the enter key while in the Work with: text box.
  2. Expand FX Target and check Target Platform for Eclipse
  3. Uncheck Include required software check box.
  4. Press the Finish button.
New Target Definition Name e(fx)eclipse Resolving.png
  1. The resolving will take less then one minute on most systems.
New Target Definition Name e(fx)eclipse Finish.png
  1. Check the e(fx)clipse check box to make the new target platform the (Active) platform.
  2. Press the Apply button.
  3. Press the OK button.

Configure eclipse to use a JDK not a JRE

When doing a ant build and run from the FX Build Configuration (file: build.fxbuild) the JRE Library must really be a JDK. The following step show how to configure a JRE as a JDK so the ant build and run will work.

FX Build Config.png
  1. Window -> Preferences
Window Preferences.png
  1. Java -> Installed JREs
  2. Press the Add... button.
Java Installed JREs.png
  1. Select Standard VM
  2. Press the Next > button.

StandardVM.png

  1. Don't press the Directory... button. The Directory... button will filter out JDKs and only show JREs.
JRE Home.png
  1. Use the Operating System's file system browser get the full path of the target JDK.
  2. In this example
  3. C:\Program Files\Java\jdk1.8.0_25
  4. Copy and paste the full path into the JRE home: text box.
  5. Press the Finish button.
JRE Definition.png
  1. Make the new JDK the default JRE by checking the check box.
  2. Press the OK button.
Installed JREs.png
  1. Navigate to the Execution Environments dialog.
  2. Java -> Installed JREs -> Execution Environments.
  3. Check the check box next the JDK, not the JRE.
  4. Press the OK button.
Execution Environments.png
  1. The steps are now complete. All future new projects will point to a JDK, not a JRE. If you have any existing projects they will still point to the JRE, not the JDK.

A quick peak at what is now installed

New Wizards

Package Explorer Right Click New Project.png

Package Explorer -> (right mouse click) -> New -> Project...


Project Explorer New Other JavaFX.png

New, Wizard, JavaFX


JavaFX HTML Template.png

JavaFX -> JavaFX HTML Template


JavaFX Project Create a Java Project.png

JavaFX -> JavaFX Library Project


Product Configuration.png

JavaFX -> JavaFX Product Configuration


Create a Java Project.png

JavaFX -> JavaFX Create a Java Project


FXGraph File.png

JavaFX -> JavaFXGraph File


FXML File.png

JavaFX -> FXML File


JavaFX 3.x ViewPart.png

JavaFX -> JavaFX 3.x ViewPart


JavaFX Main Class.png

JavaFX -> JavaFX Main Class


JavaFX Preloader Class.png

JavaFX -> JavaFX Preloader Class


New e4 FX application.png

JavaFX -> New e4 FX application


New FX-OSGi Bundle.png

JavaFX -> New FX-OSGi Bundle


New Preferences

Preferences JavaFX.png

Window -> Preferences -> JavaFX


Preferences JavaFX CSS.png

Window -> Preferences -> JavaFX -> CSS


Preferences JavaFX CSS Syntax Coloring.png

Window -> Preferences -> JavaFX -> CSS -> Syntax Coloring


Preferences JavaFX CSS Template.png

Window -> Preferences -> JavaFX -> CSS -> Templates


Preferences JavaFX CSSExtDsl.png

Window -> Preferences -> JavaFX -> CSSEXTDSL


Preferences JavaFX CSSExtDsl Compiler.png

Window -> Preferences -> JavaFX -> CSSEXTDSL -> Syntax Compiler


Preferences JavaFX CSSExtDsl Syntax Coloring.png

Window -> Preferences -> JavaFX -> CSSEXTDSL -> Syntax Coloring


Preferences JavaFX CSSExtDsl Template.png

Window -> Preferences -> JavaFX -> CSSEXTDSL -> Templates


Preferences FXGraph.png

Window -> Preferences -> JavaFX -> FXGraph


Preferences FXGraph Compiler.png

Window -> Preferences -> JavaFX -> FXGraph-> Compiler


Preferences FXGraph Syntax Coloring.png

Window -> Preferences -> JavaFX -> FXGraph-> Syntax Coloring


Preferences JavaFX FXGraph Templates.png

Window -> Preferences -> JavaFX -> FXGraph-> Templates


New View

Show View JavaFX JavaFX Preview.png
JavaFX Preview.png

Back to the top