Skip to main content
Jump to: navigation, search

Difference between revisions of "Efxclipse/Tutorials/AddingE(fx)clipse to eclipse"

(Created page with "File:Under_Construction_Go_somewhere_else.jpg How to install e(fx)clipse on a Mars 4.5.0 version of eclipse These instructions were written and the screen captures taken...")
 
Line 6: Line 6:
 
= Installing e(fx)clipse IDE.=
 
= Installing e(fx)clipse IDE.=
  
 +
[[File:Help_Install_New_Software.png]]
 
# Select the "Help" menu.
 
# Select the "Help" menu.
 
# Select the "Install New Software..." option.
 
# Select the "Install New Software..." option.
 +
[[File:Install_Work_with_All_Available_Sites_Uncheck_Group_items_by_category_Check_e(fx)clipse_-_IDE.png]]
 
# Select the "--All Available Sites --" option from the "Work with:" drop down list.
 
# Select the "--All Available Sites --" option from the "Work with:" drop down list.
 
# Uncheck the "Group items by category" check box in the bottom details section.
 
# Uncheck the "Group items by category" check box in the bottom details section.
 
# Check only the "e(fx)clipse - IDE" Name option.  All the other options starting with "e(fx)clipse - IDE" are subsets of the full e(fx)clipse IDE.  The "e(fx)clipse - Minimal JavaFX OSGi integration bundles" option is out of scope for these instructions.
 
# Check only the "e(fx)clipse - IDE" Name option.  All the other options starting with "e(fx)clipse - IDE" are subsets of the full e(fx)clipse IDE.  The "e(fx)clipse - Minimal JavaFX OSGi integration bundles" option is out of scope for these instructions.
 
# Press the "Next >" button.
 
# Press the "Next >" button.
 +
[[File:Install_Install_Details_Next.png]]
 
# Press the "Next >" button.
 
# Press the "Next >" button.
 +
[[File:I_accept_the_terms_of_the_license_agreement.png]]
 
# Press the "I accept the terms of the license agreement" radio button.
 
# Press the "I accept the terms of the license agreement" radio button.
 
# Press the "Finish" button.
 
# Press the "Finish" button.
 +
[[File:Installing_Software.png]]
 
# Wait about 2 minutes for the install to complete.
 
# Wait about 2 minutes for the install to complete.
 
# Press the "Yes" button.
 
# Press the "Yes" button.
 +
[[File:Software_Updates.png]]
  
 
= Setup a target platform for your application development =
 
= Setup a target platform for your application development =
 +
[[File:Preferences_Plug-in_Development_Target_Platform_Add.png]]
 
# Open Window > Preferences > Plugin-in Development > Target Platform  
 
# Open Window > Preferences > Plugin-in Development > Target Platform  
 
# Click Add ...  
 
# Click Add ...  
 +
[[File:New_Target_Definition_Nothing_Start_with_an_empty_target_definition.png]]
 
# Select "Nothing: Start with an empty target definition".  
 
# Select "Nothing: Start with an empty target definition".  
 +
[[File:Preferences_Plug-in_Development_Target_Platform.png]]
 
# Enter "e(fx)clipse" as the target platform name.
 
# Enter "e(fx)clipse" as the target platform name.
 
# Press the "Add..." button.   
 
# Press the "Add..." button.   
 +
[[File:Add_Content_Add_Software_Site_Next.png]]
 
# Select Software Site.  Then press the "Next >" button.
 
# Select Software Site.  Then press the "Next >" button.
 +
[[File:Add_Content_Add_Software_Site__FX_Target_Uncheck_Include_required_software_Finish.png]]
 
# Enter http://download.eclipse.org/efxclipse/runtime-released/2.0.0/site as the site.  Press the enter key while in the "Work with:" text box.
 
# Enter http://download.eclipse.org/efxclipse/runtime-released/2.0.0/site as the site.  Press the enter key while in the "Work with:" text box.
 
# Expand "FX Target" and check "Target Platform for Eclipse"  
 
# Expand "FX Target" and check "Target Platform for Eclipse"  
 
# Uncheck "Include required software" check box.
 
# Uncheck "Include required software" check box.
 
# Finish and activate the new target.   
 
# Finish and activate the new target.   
 +
# <<TODO: find screen capture>>
 +
[[File:New_Target_Definition_Name_e(fx)eclipse.png]]
 
# The resolving will take less then one minute on most systems.
 
# The resolving will take less then one minute on most systems.
 +
[[File:New_Target_Definition_Name_e(fx)eclipse_Add_Finish.png]]
 
# Press the "Finish" button.
 
# Press the "Finish" button.
 
# Make the new "e(fx)elipse" Target definition the default.
 
# Make the new "e(fx)elipse" Target definition the default.
Line 37: Line 51:
 
= A quick peak at what is now installed =
 
= A quick peak at what is now installed =
 
== New Wizards ==
 
== New Wizards ==
# screen capture
+
[[File:Package_Explorer_Right_Click_New_Project.png]]
# screen capture
+
[[File:Project_Explorer_New_Other_JavaFX.png]]
# screen capture
+
[[File:JavaFX_Preview.png]]
# screen capture
+
[[File:JavaFX_HTML_Template.png]]
# screen capture
+
[[File:JavaFX_Project_Create_a_Java_Project.png]]
# screen capture
+
[[File:Product_Configuration.png]]
# screen capture
+
[[File:Create_a_Java_Project.png]]
# screen capture
+
[[File:FXGraph_File.png]]
# screen capture
+
[[File:FXML_File.png]]
# screen capture
+
[[File:JavaFX_3.x_ViewPart.png]]
# screen capture
+
[[File:JavaFX_Main_Class.png]]
# screen capture
+
[[File:JavaFX_Preloader_Class.png]]
# screen capture
+
[[File:New_FX-OSGi_application.png]]
# screen capture
+
[[File:New_FX-OSGi_Bundle.png]]
# screen capture
+
[[File:New_e4_FX_application.png]]
  
 
== New Preferences ==
 
== New Preferences ==
# screen capture
 
# screen capture
 
# screen capture
 
# screen capture
 
# screen capture
 
# screen capture
 
# screen capture
 
# screen capture
 
# screen capture
 
# screen capture
 
# screen capture
 
# screen capture
 
== New View ==
 
# screen capture
 
 
 
[[File:Preferences_Plug-in_Development_Target_Platform_Add.png]]
 
[[File:New_Target_Definition_Nothing_Start_with_an_empty_target_definition.png]]
 
[[File:Add_Content_Add_Software_Site_Next.png]]
 
[[File:Add_Content_Add_Software_Site__FX_Target_Uncheck_Include_required_software_Finish.png]]
 
[[File:New_Target_Definition_Name_e(fx)eclipse_Add_Finish.png]]
 
[[File:New_Target_Definition_Name_e(fx)eclipse.png]]
 
[[File:Preferences_Plug-in_Development_Target_Platform.png]]
 
[[File:Install_Install_Details_Next.png]]
 
[[File:Install_Work_with_All_Available_Sites_Uncheck_Group_items_by_category_Check_e(fx)clipse_-_IDE.png]]
 
[[File:Help_Install_New_Software.png]]
 
[[File:Package_Explorer_Right_Click_New_Project.png]]
 
[[File:I_accept_the_terms_of_the_license_agreement.png]]
 
[[File:Installing_Software.png]]
 
[[File:Software_Updates.png]]
 
[[File:Project_Explorer_New_Other_JavaFX.png]]
 
 
[[File:Preferences_JavaFX.png]]
 
[[File:Preferences_JavaFX.png]]
 
[[File:Preferences_JavaFX_CSS.png]]
 
[[File:Preferences_JavaFX_CSS.png]]
Line 97: Line 80:
 
[[File:Preferences_FXGraph_Syntax_Coloring.png]]
 
[[File:Preferences_FXGraph_Syntax_Coloring.png]]
 
[[File:Preferences_Templates.png]]
 
[[File:Preferences_Templates.png]]
 +
== New View ==
 
[[File:Show_View_JavaFX_JavaFX_Preview.png]]
 
[[File:Show_View_JavaFX_JavaFX_Preview.png]]
[[File:JavaFX_Preview.png]]
 
[[File:JavaFX_HTML_Template.png]]
 
[[File:JavaFX_Project_Create_a_Java_Project.png]]
 
[[File:Product_Configuration.png]]
 
[[File:Create_a_Java_Project.png]]
 
[[File:FXGraph_File.png]]
 
[[File:FXML_File.png]]
 
[[File:JavaFX_3.x_ViewPart.png]]
 
[[File:JavaFX_Main_Class.png]]
 
[[File:JavaFX_Preloader_Class.png]]
 
[[File:New_FX-OSGi_application.png]]
 
[[File:New_FX-OSGi_Bundle.png]]
 
[[File:New_e4_FX_application.png]]
 

Revision as of 15:19, 29 August 2015

Under Construction Go somewhere else.jpg

How to install e(fx)clipse on a Mars 4.5.0 version of eclipse These instructions were written and the screen captures taken with a clean install of the Eclipse for RCP and RAP Developers 64 bit package available here (http://www.eclipse.org/downloads/packages/eclipse-rcp-and-rap-developers/marsr). The Operating system used was Windows 7 SP1. These steps do not include the install of eclipse 4.5.0 (Mars).

Installing e(fx)clipse IDE.

Help Install New Software.png

  1. Select the "Help" menu.
  2. Select the "Install New Software..." option.

Install Work with All Available Sites Uncheck Group items by category Check e(fx)clipse - IDE.png

  1. Select the "--All Available Sites --" option from the "Work with:" drop down list.
  2. Uncheck the "Group items by category" check box in the bottom details section.
  3. Check only the "e(fx)clipse - IDE" Name option. All the other options starting with "e(fx)clipse - IDE" are subsets of the full e(fx)clipse IDE. The "e(fx)clipse - Minimal JavaFX OSGi integration bundles" option is out of scope for these instructions.
  4. Press the "Next >" button.

Install Install Details Next.png

  1. Press the "Next >" button.

I accept the terms of the license agreement.png

  1. Press the "I accept the terms of the license agreement" radio button.
  2. Press the "Finish" button.

Installing Software.png

  1. Wait about 2 minutes for the install to complete.
  2. Press the "Yes" button.

Software Updates.png

Setup a target platform for your application development

Preferences Plug-in Development Target Platform Add.png

  1. Open Window > Preferences > Plugin-in Development > Target Platform
  2. Click Add ...

New Target Definition Nothing Start with an empty target definition.png

  1. Select "Nothing: Start with an empty target definition".

Preferences Plug-in Development Target Platform.png

  1. Enter "e(fx)clipse" as the target platform name.
  2. Press the "Add..." button.

Add Content Add Software Site Next.png

  1. Select Software Site. Then press the "Next >" button.

Add Content Add Software Site FX Target Uncheck Include required software Finish.png

  1. Enter http://download.eclipse.org/efxclipse/runtime-released/2.0.0/site as the site. Press the enter key while in the "Work with:" text box.
  2. Expand "FX Target" and check "Target Platform for Eclipse"
  3. Uncheck "Include required software" check box.
  4. Finish and activate the new target.
  5. <<TODO: find screen capture>>

New Target Definition Name e(fx)eclipse.png

  1. The resolving will take less then one minute on most systems.

New Target Definition Name e(fx)eclipse Add Finish.png

  1. Press the "Finish" button.
  2. Make the new "e(fx)elipse" Target definition the default.
  3. Press the "Apply" button.
  4. Press the "OK" button.

A quick peak at what is now installed

New Wizards

Package Explorer Right Click New Project.png Project Explorer New Other JavaFX.png JavaFX Preview.png JavaFX HTML Template.png JavaFX Project Create a Java Project.png Product Configuration.png Create a Java Project.png FXGraph File.png FXML File.png JavaFX 3.x ViewPart.png JavaFX Main Class.png JavaFX Preloader Class.png New FX-OSGi application.png New FX-OSGi Bundle.png New e4 FX application.png

New Preferences

Preferences JavaFX.png Preferences JavaFX CSS.png Preferences JavaFX CSS Syntax Coloring.png Preferences JavaFX CSS Template.png Preferences JavaFX CSSExtDsl.png Preferences JavaFX CSSExtDsl Compiler.png Preferences CSSExtDsl Template.png Preferences FXGraph.png Preferences FXGraph Compiler.png Preferences FXGraph Syntax Coloring.png Preferences FXGraph Syntax Coloring.png File:Preferences Templates.png

New View

Show View JavaFX JavaFX Preview.png

Back to the top