Difference between revisions of "Efxclipse"

From Eclipsepedia

Jump to: navigation, search
(Running the JavaFX bundles without installing the runtime bundles)
(Replacing page with '= e(fx)clipse = == Development ==')
Line 1: Line 1:
 
= e(fx)clipse =
 
= e(fx)clipse =
  
== Running the JavaFX bundles without installing the runtime bundles ==
+
== Development ==
 
+
# Install the Java 8 SDK Build 88 or newer
+
# From the Plug-ins view import org.eclipse.osgi as a source project into the workspace
+
[[Image:fx-import-source-project.png]]
+
# Move the project next to org.eclipse.fx.osgi bundle (i.e. org.eclipse.efxclipse/bundles/runtime if you've checked out the projects from Git). It is important that the two projects are located next to each other. To get rid of the compiler errors you have to set the execution environment for J2SE-1.5 to Java 7.n You can change the setting in the Eclipse preferences under Java -> Installed JREs -> Execution Environment
+
[[Image:fx-execution-environments.png]]
+
# In the run-configuration select the org.eclipse.fx.osgi bundle from the Workspace and de-select it from the Target Platform
+
[[Image:fx-run-configuration.png]]
+

Revision as of 09:59, 24 June 2013

e(fx)clipse

Development