Skip to main content
Jump to: navigation, search

Difference between revisions of "Ecore Tools/New and Noteworthy"

m (Update new functionalities to be decribed as part of 0.8.0M5)
(Add N&N initial contents)
Line 2: Line 2:
  
 
=== Share same Editing Domain ===
 
=== Share same Editing Domain ===
 +
All the diagrams associated with a same diagram file that can be open into separate editors are sharing the same editing domain : this means that they will be synchronized and when you will save an diagram, it will then save all other diagrams that may be open into separate editors.
 +
 +
For further details see: [https://bugs.eclipse.org/bugs/show_bug.cgi?id=215017 Bugzilla 215017]
  
 
=== Synchronisation only on removal ===
 
=== Synchronisation only on removal ===
  
 
=== Delete from diagram ===
 
=== Delete from diagram ===
 +
 +
For further details see: [https://bugs.eclipse.org/bugs/show_bug.cgi?id=211852 Bugzilla 211852]
  
 
=== Filtering capabilities ===
 
=== Filtering capabilities ===
 +
Filtering graphical elements may be useful to hide a given part of the diagram. You can access it from the action bar menu [[Image:EcoreTools_iconFilter.gif]] or directly from the popup menu in the editor area :
 +
 +
[[Image:EcoreTools_FilteringActionBar.png]]
 +
 +
[[Image:EcoreTools_FilteringPopupMenu.png]]
 +
 +
There are a few filters already defined :
 +
* [[Image:EcoreTools_iconApplyFilter.gif]] '''Hide selection''' : hide all the selected elements
 +
* [[Image:EcoreTools_iconApplyFilter.gif]] '''Hide VisualType''' :  hide all the elements selected and those associated with the same visual ID. For example, if you select only one EDataType, this will hide all the other EDataType elements in the current diagram.
 +
* [[Image:EcoreTools_iconApplyFilter.gif]] '''Hide SemanticModel''' : hide all the selected elements and those associated with the same semantic element. For example, if you have several graphical representation of the same semantic model in your diagram, this will hide all the graphical occurences, but not only the selected one.
 +
* [[Image:EcoreTools_iconApplyFilter.gif]] '''Show All Hidden Parts''' : used to show again all the hidden elements in the current diagram
 +
* [[Image:EcoreTools_iconApplyFilter.gif]] '''Hide Inheritance Relations''' : hide all the Inheritance links in the current diagram
 +
* [[Image:EcoreTools_iconApplyFilter.gif]] '''Hide Reference Relations''' : hide all the References (containment or not, eopposite or not) links in the current diagram
 +
 +
For further details see: [https://bugs.eclipse.org/bugs/show_bug.cgi?id=210772 Bugzilla 210772]
  
 
=== Diagram management through outline ===
 
=== Diagram management through outline ===
 +
New actions are available in the outline so that you can manage easily the diagrams associated with your domain model :
 +
* [[Image:EcoreTools_iconAdd.gif]] Create diagram : you can add new diagrams when selecting an EPackage and then give it a name
 +
* [[Image:EcoreTools_iconDelete.gif]] Delete diagram : you can delete an existing diagram '''except the active diagram''' (in this case, the action will not be present)
 +
* [[Image:EcoreTools_iconRename.gif]] Rename diagram : you can also rename an existing diagram
 +
 +
[[Image:EcoreTools_ManageDiagCreation.png]]
 +
 +
[[Image:EcoreTools_ManageDiagDeleteRename.png]]
 +
 +
For further details see: [https://bugs.eclipse.org/bugs/show_bug.cgi?id=210768 Bugzilla 210768] and [https://bugs.eclipse.org/bugs/show_bug.cgi?id=215666 Bugzilla 215666] and [https://bugs.eclipse.org/bugs/show_bug.cgi?id=215698 Bugzilla 215698] and [https://bugs.eclipse.org/bugs/show_bug.cgi?id=216109 Bugzilla 216109] and [https://bugs.eclipse.org/bugs/show_bug.cgi?id=218921 Bugzilla 218921]
  
 
=== Validation markers shown in the outline ===
 
=== Validation markers shown in the outline ===
 +
When validating your model from the graphical editor (you can use the validation action [[Image:EcoreTools_iconValidate.gif]] available in the action bar menu), validation markers are now shown in the outline :
 +
 +
[[Image:EcoreTools_OutlineValidationMarkers.png]]
 +
 +
For further details see: [https://bugs.eclipse.org/bugs/show_bug.cgi?id=215574 Bugzilla 215574] and [https://bugs.eclipse.org/bugs/show_bug.cgi?id=215665 Bugzilla 215665] and [https://bugs.eclipse.org/bugs/show_bug.cgi?id=216093 Bugzilla 216093]
  
 
=== Documentation tab in the Properties View ===
 
=== Documentation tab in the Properties View ===
 +
A new tab appears in the Properties View : this is mainly used to edit an already defined EAnnotation and might probably give you some ideas about new utilities sections we could add in this view !
 +
 +
[[Image:EcoreTools_GenModelDocInPropertiesView.png]]
 +
 +
For further details see: [https://bugs.eclipse.org/bugs/show_bug.cgi?id=215696 Bugzilla 215696]
  
 
=== EOpposite references display  ===
 
=== EOpposite references display  ===
 +
When two references are set each other as EOpposite, there is only one graphical connection with two labels, as if the two connections were merged. You can still select each of the two references by selecting the corresponding label, but selecting the link will only select one of the two references.
 +
 +
For further details see: [https://bugs.eclipse.org/bugs/show_bug.cgi?id=210774 Bugzilla 210774]
  
 
== 0.8 M4 ==
 
== 0.8 M4 ==

Revision as of 07:20, 20 February 2008

0.8 M5

Share same Editing Domain

All the diagrams associated with a same diagram file that can be open into separate editors are sharing the same editing domain : this means that they will be synchronized and when you will save an diagram, it will then save all other diagrams that may be open into separate editors.

For further details see: Bugzilla 215017

Synchronisation only on removal

Delete from diagram

For further details see: Bugzilla 211852

Filtering capabilities

Filtering graphical elements may be useful to hide a given part of the diagram. You can access it from the action bar menu EcoreTools iconFilter.gif or directly from the popup menu in the editor area :

EcoreTools FilteringActionBar.png

EcoreTools FilteringPopupMenu.png

There are a few filters already defined :

  • EcoreTools iconApplyFilter.gif Hide selection : hide all the selected elements
  • EcoreTools iconApplyFilter.gif Hide VisualType : hide all the elements selected and those associated with the same visual ID. For example, if you select only one EDataType, this will hide all the other EDataType elements in the current diagram.
  • EcoreTools iconApplyFilter.gif Hide SemanticModel : hide all the selected elements and those associated with the same semantic element. For example, if you have several graphical representation of the same semantic model in your diagram, this will hide all the graphical occurences, but not only the selected one.
  • EcoreTools iconApplyFilter.gif Show All Hidden Parts : used to show again all the hidden elements in the current diagram
  • EcoreTools iconApplyFilter.gif Hide Inheritance Relations : hide all the Inheritance links in the current diagram
  • EcoreTools iconApplyFilter.gif Hide Reference Relations : hide all the References (containment or not, eopposite or not) links in the current diagram

For further details see: Bugzilla 210772

Diagram management through outline

New actions are available in the outline so that you can manage easily the diagrams associated with your domain model :

  • EcoreTools iconAdd.gif Create diagram : you can add new diagrams when selecting an EPackage and then give it a name
  • EcoreTools iconDelete.gif Delete diagram : you can delete an existing diagram except the active diagram (in this case, the action will not be present)
  • EcoreTools iconRename.gif Rename diagram : you can also rename an existing diagram

EcoreTools ManageDiagCreation.png

EcoreTools ManageDiagDeleteRename.png

For further details see: Bugzilla 210768 and Bugzilla 215666 and Bugzilla 215698 and Bugzilla 216109 and Bugzilla 218921

Validation markers shown in the outline

When validating your model from the graphical editor (you can use the validation action EcoreTools iconValidate.gif available in the action bar menu), validation markers are now shown in the outline :

EcoreTools OutlineValidationMarkers.png

For further details see: Bugzilla 215574 and Bugzilla 215665 and Bugzilla 216093

Documentation tab in the Properties View

A new tab appears in the Properties View : this is mainly used to edit an already defined EAnnotation and might probably give you some ideas about new utilities sections we could add in this view !

EcoreTools GenModelDocInPropertiesView.png

For further details see: Bugzilla 215696

EOpposite references display

When two references are set each other as EOpposite, there is only one graphical connection with two labels, as if the two connections were merged. You can still select each of the two references by selecting the corresponding label, but selecting the link will only select one of the two references.

For further details see: Bugzilla 210774

0.8 M4

Ecore Tools Perspective

Ecore Tools Perspective could be used to activate useful views and arrange them in a default way. You can activate it through "Window > Open Perspective > Other..." and then select the corresponding perspective.

EcoreTools selectEcorePerspective.png

Here is an example of screenshot you can get using the Ecore Tools perspective :

EcoreTools ecorePerspective.png

For further details see: Bugzilla 212407

Ecore project nature

You can create a new Ecore project (this is simply a Project with an Ecore nature). This is not yet currently needed to create such projects for handling ecore model/diagrams, but this might be a basis for implementing further refactoring capabilities ... TBC

EcoreTools newEcoreProject.png

For further details see: Bugzilla 212407

Ecore Tools new Creation wizard

You have the possibility to create a new Ecore diagram from scratch or from an existing Ecore model. In both cases, you can start using the creation wizard that will help you to create and initialize your diagram contents. To start the wizard, select the project where you want to create your model, "Right Click > New > Other..." and then select the corresponding kind of diagram : "Ecore Tools > Ecore Diagram"

EcoreTools newEcoreDiagram.png

Once you have selected the corresponding wizard, click on the "Next" button to open the wizard :

EcoreTools NewEcoreDiagramWizard.png EcoreTools EcoreDiagramFromModelWizard.png

All the informations are grouped into that single wizard page. You have the possibility between

  • creating a new Ecore diagram from scratch : in this case, select the "Create a new Model" option. You have then to select the output directory and specify the name for the domain model. The diagram model will be named using the same name, but using *.ecorediag as the file extension.
  • create a new Ecore diagram from an existing domain file : in this case, select the "Create from an existing model" option. You have then to select the domain model (Note that if you have initially selected the domain model before opening the creation wizard, it is correctly initialized), and then select the EPackage (the root EPackage generally) to be associated with your diagram. Finally you can choose to initialize or not the diagram : it aims at populated or not initial contents into your diagram depending on the existing domain model structure.

For further details see: Bugzilla 210796

Properties View

The Properties View have been improved to propose a "Model" category used to simplify the way of editing properties. You can also modify several features at the same time.

File:EcoreTools propertiesView.png

EClass Hierarchy View

The view is activated by default using the Ecore Tools perspective, but you can activate it using the magic "Ctrl+3" shortcut and then starting to type "EClass" :

EcoreTools searchHierarchyView.png

The EClass Hierarchy View helps to better understand your ecore model hierarchy from the ESuperType features. You can synchronize EcoreTools SynchronizedIcon.gif that view with the current selection or refresh it explicitly EcoreTools refreshIcon.gif. You also have the possibility to show the hierarchy into a descending way EcoreTools subHierarchyIcon.gif or ascending way EcoreTools superHierarchyIcon.gif :

EcoreTools hierarchyView.png

For further details see: Bugzilla 212405

EClass References View

This view is useful to show all the EReference elements that are referencing the EClass currently selected. You can synchronize EcoreTools SynchronizedIcon.gif that view with the current selection or refresh it explicitly EcoreTools refreshIcon.gif. Those references are categorized depending on their parent EClass. This view is also available from the Ecore Tree structure editor or from any other editor which can provide a selection from an EClass :

EcoreTools referencesView.png

For further details see: Bugzilla 212406

Outline View

The Outline View is composed of two parts :

  • an Overview : birdview of the diagram canvas
  • a Navigator : model-oriented tree view of the model which is currently edited.

You can choose to display both parts or just one using toogle buttons EcoreTools TreeIcon.gif EcoreTools OverviewIcon.gif EcoreTools AllIcon.gif :

Ecoretools outline1.PNG Ecoretools outline3.PNG Ecoretools outline2.PNG

The Outline Navigator can be synchronized with the editor EcoreTools SynchronizedIcon.gif : when selecting one or several element in the outline, all the graphical occurences are also selected in the current diagram, and while the diagram selction changes, associated domain elements are selected in the outline navigator.

EcoreTools SynchronizedOutline.png

DND capabilities from outline

Drag and drop from the outline view is enabled with restoration of connections for elements not yet displayed in the current diagram canvas.

Ecoretools dnd.jpg

For further details see: Bugzilla 212768 and Bugzilla 214090

Label customizations

An additional label is displayed inside the EPackage, EClass, EDataType, EEnum or EAnnotation figure when the corresponding semantic element is represented in another diagram canvas, ie when the graphical occurence is considered as an external element : the label (from package_name) appears under the element name.

Ecoretools label.PNG

For further details see : Bugzilla 211850

Back to the top