Skip to main content
Jump to: navigation, search

Eclipse b3/contributing/Setting Up Development Environment

< Eclipse b3
Revision as of 07:15, 31 December 2009 by Michal.ruzicka.cloudsmith.com (Talk | contribs) (New page: If you intend to hack B3, here is how to get started.<br /><br /> Eclipse<br /> First install Eclipse 3.5.1 for your platform. Here is a pointer (if you don't get it by heart yet) to the d...)

(diff) ← Older revision | Latest revision (diff) | Newer revision → (diff)

If you intend to hack B3, here is how to get started.

Eclipse
First install Eclipse 3.5.1 for your platform. Here is a pointer (if you don't get it by heart yet) to the download page: http://www.eclipse.org/downloads/
Grab the Classic version at the very bottom and unpack the archive into a convenient path.

Subversion support
Subversion support is needed simply because the B3 sources are kept in an SVN repository.
There are two projects providing the needed support:

If you already use one of these then stick with it, otherwise follow these steps to install subclipse:

  • run your freshly installed Eclipse
  • open the Help / Install New Software wizard
  • browse the subclipse 1.6.x repository: http://subclipse.tigris.org/update_1.6.x
  • select the following components:
    • Core SVNKit Library / SVNKit Library
    • Optional JNA Library (recommended) / JNA Library
    • Subclipse / Subclipse (Required)
    • Subclipse / SVNKit Client Adapter (Not required)
  • click through the other pages of the install wizard to finish the installation (you will need to acknowledge installation of unsigned software as the subclipse components are not signed)

You may want to skip the otherwise recommended restart of the workbench at this point as there will be more installations and after each of them a restart will be recommended, so it will save you some time if you restart only after the very last installation.
(But don't blame me if anything goes wrong - the restart was recommended after all!)

EMF
EMF is the first of prerequisites of B3.

  • open the Help / Install New Software wizard
  • browse the EMF releases repository: http://download.eclipse.org/modeling/emf/updates/releases
  • expand the EMF SDK 2.5.0 (EMF + XSD) category (you may experiment with later releases if available)
  • select all entries in the expanded category which names start with EMF, except EMF/XSD All-In-One SDK (you may also omit Examples)
  • click through the other pages of the install wizard to finish the installation

Again you may want to skip the recommended workbench restart.

Ecore Tools
B3 would work without this, but the tools include, among others, graphical editors for certain B3 language definitions which would otherwise have to be edited in plain text, which would be a pain. Installation instructions follow:

  • open the Help / Install New Software wizard
  • browse the EMFT releases repository: http://download.eclipse.org/modeling/emft/updates/releases
  • expand the EMFT ECORETOOLS SDK (Incubation) 0.9.0 category (you may experiment with later releases if available)
  • select all entries in the expanded category, except Ecore Tools All-In-One Feature (Incubation) (you may also omit Examples)
  • click through the other pages of the install wizard to finish the installation

Again you may want to skip the recommended workbench restart.

Xtext
Xtext is the next prerequisite of B3. Installation instructions follow:

  • open the Help / Install New Software wizard
  • browse the Xtext milestones repository (latest release won't do as of writing of this document): http://download.itemis.com/updates/milestones
  • select entire following categories:
    • tmf-xtext 0.8.0M4 S200912151450 (you may experiment with later milestones if available)
    • xtext-antlr 0.8.0M4 S200912152232 (you may experiment with later milestones if available)
  • click through the other pages of the install wizard to finish the installation (you will need to acknowledge installation of unsigned software as some of the installed components are not signed)

The Xtext completes the installations so please restart the workbench as recommended this time!

Back to the top