Difference between revisions of "EclipseLink/Development/ServerPlatform/NetweaverPlatform"

From Eclipsepedia

Jump to: navigation, search
m
Line 33: Line 33:
 
* SAP NetWeaver AS Java (version 7.1 to 7.3) is a Java EE 5 server, hence supporting only JPA 1.0.
 
* SAP NetWeaver AS Java (version 7.1 to 7.3) is a Java EE 5 server, hence supporting only JPA 1.0.
 
* Dynamic weaving cannot be used inside SAP NetWeaver AS Java. Applications should use static weaving instead.
 
* Dynamic weaving cannot be used inside SAP NetWeaver AS Java. Applications should use static weaving instead.
 +
 +
==Level of Testing==
 +
See [[EclipseLink/Development/ServerPlatform/NetweaverPlatform/Testing]] for details on the level of testing.

Revision as of 04:51, 7 April 2010

Contents

Documentation

Description

The NetWeaver server platform is a subclass of the ServerPlatform class that can be used by customers using SAP NetWeaver Application Server Java:

org.eclipse.persistence.platform.server.sap.SAPNetWeaver_7_1_Platform

Starting with release 2.1 it is contained in the standard EclipseLink repository:
svn+ssh://dev.eclipse.org/svnroot/rt/org.eclipse.persistence/trunk/foundation/org.eclipse.persistence.core/src/org/eclipse/persistence/platform/server/sap/SAPNetWeaver_7_1_Platform.java

Supported Versions

The NetWeaver server platform allows using EclipseLink within SAP NetWeaver Application Server Java. The following versions are supported:

  • SAP NetWeaver 7.1 including EHP 1
  • SAP NetWeaver 7.2
  • SAP NetWeaver 7.3 (not yet publicly available)

Using the NetWeaver Platform

The recommended deployment option is to create a separate deployable application (i.e. an SDA file) containing the eclipselink.jar file and to reference that application from your Java EE application. See the NetWeaver Help Portal for a description how to do this using SAP NetWeaver Developer Studio.

In order to use EclipseLink in your application, the persistence.xml file must contain the following entries:

  • Add a <provider> tag to each of the defined persistence units (must be the first line after the <persistence-unit> tag) so that EclipseLink will be used as the JPA provider for the respective persistence unit:
<provider>org.eclipse.persistence.jpa.PersistenceProvider</provider>
  • Include the following property at the end of each persistence unit so that EclipseLink will make use of the NetWeaver platform:
<properties>
  <property name="eclipselink.target-server" value="NetWeaver_7_1"/>   
</properties>
Note that NetWeaver_7_1 is a short name that refers to the NetWeaver platform class. You can also specify the fully qualified class name here.

Limitations

  • SAP NetWeaver AS Java (version 7.1 to 7.3) is a Java EE 5 server, hence supporting only JPA 1.0.
  • Dynamic weaving cannot be used inside SAP NetWeaver AS Java. Applications should use static weaving instead.

Level of Testing

See EclipseLink/Development/ServerPlatform/NetweaverPlatform/Testing for details on the level of testing.