Jump to: navigation, search

Difference between revisions of "EclipseLink/Development/OSGi"

(Requirements)
(Current Status)
Line 9: Line 9:
  
 
== Current Status ==
 
== Current Status ==
 +
 +
As of 1.0M2 EclipseLink does not make OSGi/Equinox bundles available. This page is tracking the requirements, proposals, and discussion as to how EclipseLink can most effectively be bundled.
  
 
== Proposals ==
 
== Proposals ==

Revision as of 16:25, 15 December 2007

This page is focussed on capturing how EclipseLink will be developed and used for an OSGi (Equinox) environment.

The goal of this effort is to produce OSGi bundles for use in other Eclipse projects and RCP applications. While the focus is on OSGi it is understood that Equinox extensions will be required.

Requirements

  1. Make EclipseLink bundles easy to use within other Eclipse projects and RCP applications without hindering the Java (SE/EE) usage
  2. Ensure that the bundles offer flexibility in their independent usage. The usage of EclipseLink JPA should not force the usage of EclipseLink's JAXB

Current Status

As of 1.0M2 EclipseLink does not make OSGi/Equinox bundles available. This page is tracking the requirements, proposals, and discussion as to how EclipseLink can most effectively be bundled.

Proposals

Bundles:

  • org.eclipse.persistence.foundation
  • org.eclipse.persistence.jpa
  • org.eclipse.persistence.moxy
  • org.eclipse.persistence.sdo

Bundle Components

Use PDE for Component Projects

Dependent Bundles

JPA

JAXB

SDO