Difference between revisions of "EclipseLink/Development/Java6"

From Eclipsepedia

Jump to: navigation, search
(Java SE 6 Integration)
(What is not working)
Line 4: Line 4:
  
 
==What is not working==
 
==What is not working==
The following changes between Java5 and Java6 are causing issues
+
*eclipselink.jpa test - UnsupportedClassVersionError when running using 1.6 compiled classes in core - running in 1.6 with 1.5 compile classes in ok.
*eclipselink.jpa test - UnsupportedClassVersionError when classloading the 1.6 compiled classes in core
+
*eclipselink.sdo.test - Class generation fails using 1.6 tools.jar.
*eclipselink.sdo.test - class generation failing using 1.6 tools.jar
+

Revision as of 16:49, 2 January 2008

Java SE 6 Integration

(This page is under construction as of 20080102) This section describes current issues and resolutions for compiling and running EclipseLink on a Sun Java 6 JRE (currently 1.6.0_03-b05).

What is not working

  • eclipselink.jpa test - UnsupportedClassVersionError when running using 1.6 compiled classes in core - running in 1.6 with 1.5 compile classes in ok.
  • eclipselink.sdo.test - Class generation fails using 1.6 tools.jar.