Jump to: navigation, search

Difference between revisions of "EclipseLink/Dependencies"

Line 42: Line 42:
 
|-
 
|-
 
| [https://saaj.dev.java.net SOAP with Attachments API for Java] || 1.3 || saaj-api-1.3.jar || [https://glassfish.dev.java.net/public/CDDL+GPL.html dual licensed GPL 2.0 and CDDL 1.0] || [https://dev.eclipse.org/ipzilla/show_bug.cgi?id=2291 PARALLEL_IP/APPROVED_FOR_CHECKIN-2291] || Required by DBWS
 
| [https://saaj.dev.java.net SOAP with Attachments API for Java] || 1.3 || saaj-api-1.3.jar || [https://glassfish.dev.java.net/public/CDDL+GPL.html dual licensed GPL 2.0 and CDDL 1.0] || [https://dev.eclipse.org/ipzilla/show_bug.cgi?id=2291 PARALLEL_IP/APPROVED_FOR_CHECKIN-2291] || Required by DBWS
 +
|-
 +
|-
 +
| [http://xerces.apache.org/ Xerces] || 2.9.0 || xercesImpl.jar || [http://www.apache.org/licenses/LICENSE-2.0.html Apache Software License Version 2.0] || [https://dev.eclipse.org/ipzilla/show_bug.cgi?id=2046 APPROVED-2046] || Only required by Workbench Utility.
 
|-
 
|-
 
|}
 
|}

Revision as of 15:17, 9 June 2008

The following is a list of Dependencies that EclipseLink requires to compile all components.

Library Name Version Files License IP Bug Notes
ASM 1.5.3 + ojc patch none License APPROVED-1605 Internalized into org.eclipse.persistence.internal.libraries.asm. Used for byte-code weaving of persistent classes
ANTLR 3.0 none License APPROVED-1695 Internalized into org.eclipse.persistence.internal.libraries.antlr.
Required for parsing JPQL.
JTA 1.1 jta.jar CDDL 1.0 APPROVED-1613 Only required when using JTA. Generally provided by host container.
JMS 1.1 jms.jar CDDL 1.0 APPROVED-1614 Only required when using JMS cache coordination. Typically provided by host container.
JPA (EJB 3.0) 1.0 persistence.jar CDDL 1.0 APPROVED-1616 Only required when using JPA. Required in JavaSE but always included in JavaEE5 containers..
EJB 3.0 ejb.jar CDDL 1.0 APPROVED-1794 Only required for compilation of MessageDrivenBean code. Included in JavaEE5 containers.
JavaEE Connector Architecture (JCA) 1.5 connector.jar CDDL 1.0 APPROVED-1621 Only required when using EIS data source support through JCA.
JAXB API 2.0.3 jaxb-api.jar CDDL 1.0 APPROVED-1617 Only required when using JAXB 2.0 (Not required for native OXM usage). Always included in JavaEE5 containers.
JAXB XJC 2.0.3 jaxb-xjc.jar CDDL 1.0 APPROVED-1787 Only required when using JAXB 2.0 Schema Compiler (Not required for native OXM usage). Always included in JavaEE5 containers.
JAXB RI 2.0.3 jaxb-impl.jar CDDL 1.0 APPROVED-1788 Only required when using JAXB 2.0 Schema Compiler (Not required for native OXM usage). Always included in JavaEE5 containers.
StAX
(Included in JAXB 2.0)
1.0 jsr173_1.0_api.jar CDDL 1.0 APPROVED-1618 Optional processing style in MOXy.
Always included in JavaEE5 containers.
Java Activation Framework
(Included in JAXB 2.0)
1.1 activation.jar CDDL 1.0 APPROVED-1620 Required for Web Service attachment handling in MOXy.
Always included in JavaEE5 containers.
Available from Orbit
JavaMail 1.4 mail.jar CDDL 1.0 APPROVED-1619 Required for Web Service attachment handling in MOXy.
Always included in JavaEE5 containers.
Available from Orbit
Service Data Objects (SDO) 2.1 commonj-sdo.jar Custom License APPROVED-1622 Only required when using SDO functionality.
WSDL4J 1.6.2 wsdl4j.jar Common Public License 1.0 APPROVED-1701 Required by DBWS
SOAP with Attachments API for Java 1.3 saaj-api-1.3.jar dual licensed GPL 2.0 and CDDL 1.0 PARALLEL_IP/APPROVED_FOR_CHECKIN-2291 Required by DBWS
Xerces 2.9.0 xercesImpl.jar Apache Software License Version 2.0 APPROVED-2046 Only required by Workbench Utility.

Third Party Dependencies

As per the Policy and Procedure for 3rd Party Dependencies the EclipseLink project has the following works-with dependencies.

Library Jars License Notes
Oracle JDBC ojdbc*.jar OTN org.eclipse.persistence.platform.database.oracle.Oracle8Platform
org.eclipse.persistence.platform.database.oracle.Oracle9Platform
org.eclipse.persistence.internal.platform.database.oracle.XMLTypeFactory
org.eclipse.persistence.platform.database.oracle.converters.JGeometryConverter
Oracle Spatial Java Class Library sdoapi.jar OTN org.eclipse.persistence.platform.database.oracle.converters.JGeometryConverter
Note: This version is for use with Oracle 10g Spatial 10.1.0.2, 10.1.0.1, 9iR2, 9iR1, and with JDK 1.4.2 or higher.
Oracle XDK xml.jar
xmlparserv2.jar
xdb.jar
OTN XMLTypeBindCallCustomParameter & XMLTypeFactoryImpl (org.eclipse.persistence.internal.platform.database.oracle.xdb)
DirectToXMLTypeMapping(org.eclipse.persistence.mappings.xdb)
org.eclipse.persistence.platform.xml.xdk.* (5 classes)
Oracle AQ aqapi.jar OTN org.eclipse.persistence.internal.eis.adapters.aq.* (5 classes)
Note: Seems to only be available from the database distribution.