Difference between revisions of "ETrice/Development/Repository"

From Eclipsepedia

Jump to: navigation, search
m
(Gerrit workflow)
(7 intermediate revisions by 2 users not shown)
Line 15: Line 15:
 
== Installations on your computer  ==
 
== Installations on your computer  ==
  
*download git: http://git-scm.com/download  
+
* command line tool (not necessary but convenient)
**e.g. for Windows: Git-1.7.3.1-preview20101002.exe  
+
**download git: http://git-scm.com/download  
**Line Endings:
+
***e.g. for Windows: Git-1.7.3.1-preview20101002.exe  
***Windows: check out Windows-style, commit Unix-style line endings
+
*EGit is already contained in the Kepler modeling package
***Linux: Checkout as is, commit Unix-style line endings
+
*install EGit (update site): http://download.eclipse.org/egit/updates
+
 
**Line Endings for EGit in Eclipse: Be aware that the global settings of the command line version of git might be different from the global EGit settings: (Perspective Git Repository Exploring -> <Context Menu on Repo Location> Open Properties View -> Global Configuration -> Edit ):  
 
**Line Endings for EGit in Eclipse: Be aware that the global settings of the command line version of git might be different from the global EGit settings: (Perspective Git Repository Exploring -> <Context Menu on Repo Location> Open Properties View -> Global Configuration -> Edit ):  
***Windows: core.autocrlf = true  
+
*** core.autocrlf = true  
***Linux: core.autocrlf = input
+
 
*Encoding in Eclipse (Window -> Preferences -> Workspace -> Text File Encoding)  
 
*Encoding in Eclipse (Window -> Preferences -> Workspace -> Text File Encoding)  
 
**Windows: Default (Cp1252)  
 
**Windows: Default (Cp1252)  
Line 36: Line 33:
 
*git config --global user.email <your email address>  
 
*git config --global user.email <your email address>  
 
*git config --global user.name "<your user name>"
 
*git config --global user.name "<your user name>"
 +
*git config --global core.autocrlf true
  
 
=== pull/push (only for committers)  ===
 
=== pull/push (only for committers)  ===
Line 153: Line 151:
 
*Use branches when working with Gerrit ([http://wiki.eclipse.org/ETrice/Development/Repository#Use_branches_when_working_with_Gerrit see how])<br> Consider to create a new branch for each independent piece of work.<br>  
 
*Use branches when working with Gerrit ([http://wiki.eclipse.org/ETrice/Development/Repository#Use_branches_when_working_with_Gerrit see how])<br> Consider to create a new branch for each independent piece of work.<br>  
 
*Reduce the number of reviews <br> Remember, that each commit with a new change-id spawns a new review/change. Before pushing to Gerrit, you should squash your local commits into 1 commit ([http://wiki.eclipse.org/ETrice/Development/Repository#Squashing_Changes see how]). The first time it gets a new change-id, otherwise amend this commit. If you want to push a new change, consider that it will be difficult to alter previous changes (see below).<br>  
 
*Reduce the number of reviews <br> Remember, that each commit with a new change-id spawns a new review/change. Before pushing to Gerrit, you should squash your local commits into 1 commit ([http://wiki.eclipse.org/ETrice/Development/Repository#Squashing_Changes see how]). The first time it gets a new change-id, otherwise amend this commit. If you want to push a new change, consider that it will be difficult to alter previous changes (see below).<br>  
*Fast forward only <br> If you push a commit on a previous change, you have to rebase all succeeding changes. This often goes with a great deal of work. Therefore it is recommended to use a fast forward only approach.  
+
*Push on HEAD only <br> If you push a commit on a previous change, you have to rebase all succeeding changes. This often goes with a great deal of work. Therefore it is recommended to continue the lastest change only.<br>
*Rebase on final submit <br> In case Gerrit's auto merges fails, you have to rebase your change(s) on master. <br> At the same time you can reorganize your changes (history and messages) to be suitable for the public repository.
+
*Rebase on final submit <br> In case Gerrit's auto merges fails, you have to rebase your change(s) on master.&nbsp;
 
**If there is only 1 commit to submit, rebase it and just amend this modifications.  
 
**If there is only 1 commit to submit, rebase it and just amend this modifications.  
**else you have to walk through the commit history and decide for each commit to a) take it over to the public repo by recommitting it (with a new change-id) or to omit it and squash it into the next one. After that abandon your old obsolete changes. Use an interactive rebase and ensure for each commit manually that you don't commit a duplicate change-id. Note: This cannot be done effectively in EGit (version 2.1) yet, squash all commits instead.
+
**else you have to walk through your commit history and resolve the conflicts using interactive rebase (but do not alter the history of your commits). In EGit see [http://wiki.eclipse.org/EGit/User_Guide#Starting_Rebase EGit/User_Guide#Starting_Rebase] and [http://wiki.eclipse.org/EGit/User_Guide#Rebase_Conflicts EGit/User_Guide#Rebase_Conflicts] (choose only: Action to perform -&gt; "Start Merge Tool to resolve conflicts", then resolve conflicts and continue with next commit)<br>
 +
 
 +
See also the [http://source.android.com/source/life-of-a-patch.html workflow] the Android project uses:
 +
 
 +
=== Create a new patch for a change on Gerrit ===
 +
 
 +
Assume some contributor provided a patch using Gerrit. You checked out this into your local clone (Fetch from Gerrit > Create and checkout a local branch). Then you modified the code. Now you want to provide your changes as new patch for the existing change.
 +
* commit your work and check 'amend'
 +
* if the commit message doesn't contain a ChangeId then copy it from Gerrit and paste it into the message
 +
* push your change to Gerrit (usualy refs/for/master)
  
 
== Create a Patch via Git Gui  ==
 
== Create a Patch via Git Gui  ==
Line 271: Line 278:
 
<br>  
 
<br>  
  
= Steps to change to Indigo =
+
= Steps to change to Indigo =
  
 
*download and install eclipse Modeling for Win32
 
*download and install eclipse Modeling for Win32

Revision as of 07:38, 12 September 2013

Contents

Git and eTrice

For eTrice we are using the Git-Repository from eclipse. For those people, who are not so familiar with Git, this chapter will give a step by step introduction.

Git in general and Git at Eclipse

After installation of EGit in Eclipse, you can look up "Git for Eclipse Users" in the EGit Documentation.

Installations on your computer

  • command line tool (not necessary but convenient)
  • EGit is already contained in the Kepler modeling package
    • Line Endings for EGit in Eclipse: Be aware that the global settings of the command line version of git might be different from the global EGit settings: (Perspective Git Repository Exploring -> <Context Menu on Repo Location> Open Properties View -> Global Configuration -> Edit ):
      • core.autocrlf = true
  • Encoding in Eclipse (Window -> Preferences -> Workspace -> Text File Encoding)
    • Windows: Default (Cp1252)
    • Linux: Other -> ISO-8859-1

Clone eTrice Repository

Configuration

IMPORTANT: execute in shell or git shell:

  • git config --global user.email <your email address>
  • git config --global user.name "<your user name>"
  • git config --global core.autocrlf true

pull/push (only for committers)

  • ssh: git clone ssh://<your commiter name>@git.eclipse.org/gitroot/etrice/org.eclipse.etrice.git
  • https: git clone https://<your commiter name>@git.eclipse.org/gitroot/etrice/org.eclipse.etrice.git

only pull

Use EGit

  • create empty workspace
  • open view "Git Repositories" or perspective "Git Repository Exploring"
  • add repository path of your local git repository you cloned before
  • contextmenu on repository: "Import Projects..."
  • Next >
  • Select All + Finish

Gerrit

Gerrit is a Code Review system for Git. Such a system is hosted by Eclipse.

The eTrice project enabled their Git repository for Gerrit. Committers can bypass Gerrit while Contributers have to use the reviewing system of Gerrit for their contributions.

Here is a selection of useful links that everybody should read:

Steps to get up and running with Gerrit

  • get an Eclipse Bugzilla account
  • get your user name from Gerrit (check the Gerrit settings)
  • upload an ssh key to Gerrit (see how)
    • make sure your ssh key resides in ~/.ssh (on Windows 7 this is typically /c/Users/<user name>/.ssh)
    • check in the ssh2 preferences of Eclipse the correct directory is set (e.g. /c/Users/<user name>/.ssh)
    • to avoid problems you should use the standard names for your key files (id_rsa and id_rsa.pub)
  • if you do not already have a clone of the eTrice repository
    • use EGit or the command line client to clone from ssh://<your Gerrit user name>@git.eclipse.org:29418/etrice/org.eclipse.etrice.git
  • if you have problems authenticating with Gerrit over Git it may help to ssh -p 29418 <your Gerrit user name>@git.eclipse.org once
    • you can use the Git Bash that comes with the commandline GIT
    • make sure the working directory (~) is the same as for eclipse (/c/Users/<user name>)
  • configure a remote for Gerrit reviews in your repository
    • use the context menu of the Git Repositories View to Open Properties View
    • in the Properties View push the Edit icon in the upper right corner
    • create new entries:
      • create a new entry remote.review.url with value ssh://<your Gerrit user name>@git.eclipse.org:29418/etrice/org.eclipse.etrice.git
      • create a new entry remote.review.push with value HEAD:refs/for/master
    • Note for committers: to bypass the review and push directly to the repository you can add another two entries in the properties of your repository:
      • create a new entry remote.bypass.url with value ssh://<your Gerrit user name>@git.eclipse.org:29418/etrice/org.eclipse.etrice.git
      • create a new entry remote.bypass.push with value HEAD:refs/heads/master
    • note :- for juno entry remote.review.push should have value HEAD:refs/for/juno (Only if you are working on juno branch)
    • set the property gerrit.createchangeid to true either in your repository or globally (details can be found here)
      • Note: the Change-Id will be 0 and only be set to the real value on submit

Now you can commit your changes as usual to your local Git repository.

When everything is ready to push you can use EGit to push to the reviewing system (use the review remote). Gerrit will create a new change which can be reviewed and verified by a committer. Gerrit allows the committer to leave comments in the source code diff which will help to improve the code.

When everything is alright the committer may submit the changes to the eTrice Git repository.

Use branches when working with Gerrit

  • switch to a newly created (local) branch in your Git repository with an appropriate name, say 'mywork. (It is recommended to turn off any auto merge/rebase function on pull)
  • as long as you work on your local branch you are shielded against changes on the remote master branch.
  • when you are ready to push you push your branch to Gerrit with ref HEAD:refs/for/master/mywork (this will create a so called topic branch in Gerrit)

Proper handling of Gerrit's Change Id

  • Create a new change
    • If this is the first time it has seen the Change-Id mentioned in the commit message, Gerrit will create a new change for review.
  • Update an existing change
    • If Gerrit has seen this Change-Id before, but has not yet seen this new commit object, Gerrit will add the new commit as a new patch set on the existing change.

Squashing Changes

Here is an article how Git can merge several commits into one using (interactive) rebase: (cannot be done in EGit (version 2.1) yet)

http://gitready.com/advanced/2009/02/10/squashing-commits-with-rebase.html

If you want to squash your lastest local commits with EGit (e.g. before pushing to Gerrit), you can use following method:

  1. In Git Repository Exploring: Right click on repository -> Show In -> History
  2. In History view: To squash your lastest m commits into m (which is first in chronological order), right click on m -> Reset -> Soft (HEAD Only)
  3. Amend commit to save changes from the m-1 commits and to edit the commit message

Note: The m commits have to be (a) continous, (b) lastest in repository and if you want to push to Gerrit (c) local

Integrating a contribution

The patch has to be IP clean and it should be checked if a CQ is necessary!

If Gerrit isn't able to merge the patch (e.g. if prerequisites lead to conflicts) a committer can merge the patch locally to his master branch (make sure to have branch.master.rebase=true) and check that in. The history will show all the commits of the contributor. Since also the bypass uses Gerrit's interface Gerrit will mark the corresponding patches as merged.

Create a patch

For the CQ diff files of the patches have to be created and attached.

This can be done as follows:

  • git log --author=.*contributor_name.* --parents --oneline
    • creates a compact list of the contributor's commits with two IDs (commit+parent) for regular commits or three IDs (commit+2 parents) for merges
  • git format-patch --stdout 28fda9c..537d59a > patch_1.txt
    • as IDs use the parent ID as first and the parent ID as second ID of the range

Gerrit workflow

The typical workflow is illustrated in the flow chart on the right side. Further details:

Gerrit workflow
  • Use branches when working with Gerrit (see how)
    Consider to create a new branch for each independent piece of work.
  • Reduce the number of reviews
    Remember, that each commit with a new change-id spawns a new review/change. Before pushing to Gerrit, you should squash your local commits into 1 commit (see how). The first time it gets a new change-id, otherwise amend this commit. If you want to push a new change, consider that it will be difficult to alter previous changes (see below).
  • Push on HEAD only
    If you push a commit on a previous change, you have to rebase all succeeding changes. This often goes with a great deal of work. Therefore it is recommended to continue the lastest change only.
  • Rebase on final submit
    In case Gerrit's auto merges fails, you have to rebase your change(s) on master. 
    • If there is only 1 commit to submit, rebase it and just amend this modifications.
    • else you have to walk through your commit history and resolve the conflicts using interactive rebase (but do not alter the history of your commits). In EGit see EGit/User_Guide#Starting_Rebase and EGit/User_Guide#Rebase_Conflicts (choose only: Action to perform -> "Start Merge Tool to resolve conflicts", then resolve conflicts and continue with next commit)

See also the workflow the Android project uses:

Create a new patch for a change on Gerrit

Assume some contributor provided a patch using Gerrit. You checked out this into your local clone (Fetch from Gerrit > Create and checkout a local branch). Then you modified the code. Now you want to provide your changes as new patch for the existing change.

  • commit your work and check 'amend'
  • if the commit message doesn't contain a ChangeId then copy it from Gerrit and paste it into the message
  • push your change to Gerrit (usualy refs/for/master)

Create a Patch via Git Gui

  • open the Git Gui from your windows menu
  • open your "local Git Repositoriy"
  • from the main menu select "Projektarchiv" => "Historie von >>master<< darstellen"
  • in the new window the latest master version must be selected (blue)
  • right click on "lokale Änderungen"
  • in the contextmenu select "Patch erstellen"

Apply a Patch

We assume the patch was created as described above.

  • in the context menu of the Package Explorer go to Team > Apply patch...
  • in the wizard select File and locate the patch file
  • select 'Apply the patch to the workspace root'
  • set leading path segments to 2
  • check the result and Finish

Checkout a previous revision

Inspect the log and determine the commit id you want to change to. Then git checkout this:

 $ git checkout 2eb90f4643fd425f77de2b88753a86416cda0166
Note: checking out '2eb90f4643fd425f77de2b88753a86416cda0166'.


You are in 'detached HEAD' state. You can look around, make experimental
changes and commit them, and you can discard any commits you make in this
state without impacting any branches by performing another checkout.


If you want to create a new branch to retain commits you create, you may
do so (now or later) by using -b with the checkout command again. Example:


git checkout -b new_branch_name


HEAD is now at 2eb90f4... ui.structure: during creation take position as midpoint of new interface item. Adjusted PopulateDiagramCommand accordingly.

working with branches

creating a local branch

pushing a local branch

creating a remote tracking branch

pulling for remote tracking branches

If you often merge with the same branch, you may want to use something like the following in your configuration file:

   [branch "before_indigo"]
remote = <nickname>
merge = <remote-ref>
   [remote "<nickname>"]
url = <url>
fetch = <refspec>

With EGit the configuration can be accesses from the Git Repositories View context menu > Open Properties View The Properties View displays the current configuration and offers an Edit button in the upper left corner.

Here is an example of a pull configuration for a remote tracking branch:
GitConfig.jpg

Using the eTrice github clone

According to https://bugs.eclipse.org/bugs/show_bug.cgi?id=332970 Eclipse projects with git repositories (and correct metadata set) are mirrored to github.

And so is eTrice: https://github.com/eclipse/etrice

Here are some slides explaining how github is accessed using EGit: http://www.slideshare.net/loianeg/using-the-egit-eclipse-plugin-with-git-hub-2578587

Any github user can fork an existing github repository. This facilitates collaborating with contributors which have no commit rights.

See also the Wiki page on Git contributions.

TODO: typical workflow...

Some hints to create Documentation

Location of Documentation

- ETrice Documentation will be put to org.eclipse.etrice.doc

- numbering of chapters is 000-xxx, 005-yyy, 010-zzz, 015... to have room for inject some chapters

- images (put to the folder images) should have the same numbering according to the chapters

- within the etrice-index.txt document the ordering of the chapters will be done. This file will be used from the build prozess to collect all single .textile files to produce the complete Doku.

- build prozess will be started from the external tool menu => "build-etrice-doc". (you must have internet access during production of the docu)


Within the .textile file

- with F1 you can get a list of the formating strings

- some formating options does not work well for all document types e.g. __italic__ does not work in the pdf file if the string contains "_". => therefore, for names which reference a concrete model name (shown in a picture or code block) use: "??This_is_my_name??" == citation

Images

- use IrfanView to create screen shots (everything on board what you need)

- use the png format to save pictures (i had never problems with that)

- pictures should not be larger than 640*480 pixels. Otherwise they will cause problems in the PDF file. IrfanView: Ctrl+r => resize image

- to sharpen the images, use IrfanView: Image=>sharpen to create perfect screen shots.


Steps to change to Indigo

  • download and install eclipse Modeling for Win32

"http://www.eclipse.org/downloads/download.php?file=/technology/epp/downloads/release/indigo/R/eclipse-modeling-indigo-win32.zip"

  • install Xtext from

http://www.eclipse.org/Xtext/download/ (drag and drop the install icon to your eclipse toolbar)

  • install Egit, Subversive and Graphiti via the update site from indogo

http://download.eclipse.org/releases/indigo (for Subversive use the Connector Native JavaHL 1.6.12)

  • download the target configuration "target-indigo-2011-06-29" from ftp.protos.de and copy it to your target path. To get the credits for the protos ftp server, please contact ts@protos.de.
  • in preferences=>Run/Debug=>String Substitution make sure that the variable "eTriceTargetInstallationPath" is set to your target path. (create the variable if not existing)
  • in the preferences=>plug in development=>target configuration, make sure that the "eTrice development" target is selected
  • sometimes it is necessary to update the plug in list (IOExtensions cannot be resolved)

=> windows=>preferences=>pulg in development=> target configuration (select the "running configuration" and apply it, select the "eTrice development" target again and apply it) (if somebody knows a smarter way to update the plug in list, please change this wiki)