Skip to main content
Jump to: navigation, search

Difference between revisions of "ETrice/Development/GettingStartedWithEtrice"

(update for Luna SR2)
Line 1: Line 1:
= Prepare Eclipse and build eTrice =
+
= Quick Start Development =
 +
# Download [http://www.eclipse.org/downloads/packages/eclipse-modeling-tools/lunasr2 Eclipse Modeling Tools Luna SR2]
 +
# Install plugins from Luna release repository (Help -> Install New Software)
 +
#* Graphiti (Incubation)
 +
#* Xtext Complete SDK
 +
#* C/C++ Development Tools
 +
# Clone eTrice sources into workspace (see [[ETrice/Development/Repository |Git and eTrice]])
 +
 
 +
= Prepare Eclipse and build eTrice with all features =
 
# get the sources ([[ETrice/Development/Repository |see how]])  
 
# get the sources ([[ETrice/Development/Repository |see how]])  
 
# download the [http://www.eclipse.org/downloads/packages/eclipse-modeling-tools/lunasr2 Eclipse Modeling Tools package] from Luna SR2
 
# download the [http://www.eclipse.org/downloads/packages/eclipse-modeling-tools/lunasr2 Eclipse Modeling Tools package] from Luna SR2

Revision as of 11:00, 7 June 2015

Quick Start Development

  1. Download Eclipse Modeling Tools Luna SR2
  2. Install plugins from Luna release repository (Help -> Install New Software)
    • Graphiti (Incubation)
    • Xtext Complete SDK
    • C/C++ Development Tools
  3. Clone eTrice sources into workspace (see Git and eTrice)

Prepare Eclipse and build eTrice with all features

  1. get the sources (see how)
  2. download the Eclipse Modeling Tools package from Luna SR2
  3. start Eclipse
  4. Install additional Plugins (if not already installed)
    1. might be already there: Apache Commons IO for file operations (e.g. for incremental code generator)
      1. Help -> Install New Software : http://download.eclipse.org/tools/orbit/downloads/drops/R20130118183705/repository/ (the link is a p2 update site of Orbit)
      2. Apache Commons IO 2.0.1
    2. Google Guava (needed for Kieler Plugins)
      1. Help -> Install New Software : Guava - http://guava-osgi.googlecode.com/svn/trunk/repository/
      2. deselect "show only the latest versions of available software", because we need an older version
      3. select Guava 8.0.0
    3. Kieler for automatic layout of graphical editors
      1. Help -> Install New Software : http://download.eclipse.org/etrice/KIELER/kieler-0.7.1
      2. if "there are no categorized items" in the list, de-select "Group items by category" -> do not forget to -> select after installation
      3. select all Kieler Plugins
  5. import all projects from your local GIT clone to your Workspace (with EGit plugin)
    1. Git Repositories View
    2. Add Repository (local GIT clone)
    3. Context Menu of Working Directory -> Import Projects
    4. Import all Projects
  6. make sure you are using a JDK (in Eclipse: Window->Preferences->Java->Installed JREs->e.g. jdk1.6.0_24), attention: do not use jdk1.6.0_18 or jdk1.6.0_22!

Working in the Runtime Workspace

  • start the runtime workspace: org.eclipse.etrice.core.room.ui -> eTrice-rt.launch (contextmenu -> Run As)
  • follow the steps in the Tutorials chapter of the eTrice online help (use Eclipse: Help > Help Contents or view the 0.3 documentation in HTML or as PDF)

Deriving from an Existing Generator

There is a minimal example that shows how a generator can be derived from the existing eTrice Java generator. The example shows how the derived DetailCodeTranslator handles an additional tag.

The example consist of two plugins:

  • examples/my.etrice.generator
  • examples/my.etrice.generator.launch

You will find the examples in the eTrice GIT repository: http://git.eclipse.org/c/etrice/org.eclipse.etrice.git/tree/examples

The first one overrides the Java generator, the second one overrides the Java launch configuration to launch the derived generator. Please have a look at the comments marked with EXAMPLE: (you can add that as a Java task tag in the preferences and use the Tasks View to locate these comments).

Back to the top