Difference between revisions of "ETrice/Development/GettingStartedWithEtrice"

From Eclipsepedia

Jump to: navigation, search
(Prepare Eclipse and build eTrice)
 
Line 2: Line 2:
 
# get the sources ([[ETrice/Development/Repository |see how]])  
 
# get the sources ([[ETrice/Development/Repository |see how]])  
 
# download the latest release of the [http://www.eclipse.org/downloads/packages/eclipse-modeling-tools/keplerr Eclipse Modeling Tools package]
 
# download the latest release of the [http://www.eclipse.org/downloads/packages/eclipse-modeling-tools/keplerr Eclipse Modeling Tools package]
# start eclipse
+
# start Eclipse
 
# Install additional Plugins (if not already installed)
 
# Install additional Plugins (if not already installed)
 
## Graphiti for the Graphical Editors
 
## Graphiti for the Graphical Editors

Latest revision as of 17:35, 26 July 2013

[edit] Prepare Eclipse and build eTrice

  1. get the sources (see how)
  2. download the latest release of the Eclipse Modeling Tools package
  3. start Eclipse
  4. Install additional Plugins (if not already installed)
    1. Graphiti for the Graphical Editors
      1. select Help -> Install New Software -> Kepler - http://download.eclipse.org/releases/kepler
      2. select Graphiti 0.10.0
    2. Xtext and Xtend for the DSL development and the code generators
      1. Help -> Install New Software -> Kepler - http://download.eclipse.org/releases/kepler
      2. select Xtext 2.4.2 (from Modeling) and Xtend 2.4.2 (from Languages)
    3. might be already there: Apache Commons IO for file operations (e.g. for incremental code generator)
      1. Help -> Install New Software : http://download.eclipse.org/tools/orbit/downloads/drops/R20130118183705/repository/ (the link is a p2 update site of Orbit)
      2. Apache Commons IO 2.0.1
    4. Google Guava (needed for Kieler Plugins)
      1. Help -> Install New Software : Guava - http://guava-osgi.googlecode.com/svn/trunk/repository/
      2. deselect "show only the latest versions of available software", because we need an older version
      3. select Guava 8.0.0
    5. Kieler for automatic layout of graphical editors
      1. Help -> Install New Software : http://download.eclipse.org/etrice/KIELER/kieler-0.7.1
      2. if "there are no categorized items" in the list, de-select "Group items by category" -> do not forget to -> select after installation
      3. select all Kieler Plugins
  5. import all projects from your local GIT clone to your Workspace (with EGit plugin)
    1. Git Repositories View
    2. Add Repository (local GIT clone)
    3. Context Menu of Working Directory -> Import Projects
    4. Import all Projects
  6. make sure you are using a JDK (in Eclipse: Window->Preferences->Java->Installed JREs->e.g. jdk1.6.0_24), attention: do not use jdk1.6.0_18 or jdk1.6.0_22!

[edit] Working in the Runtime Workspace

  • start the runtime workspace: org.eclipse.etrice.core.room.ui -> eTrice-rt.launch (contextmenu -> Run As)
  • follow the steps in the Tutorials chapter of the eTrice online help (use Eclipse: Help > Help Contents or view the 0.3 documentation in HTML or as PDF)

[edit] Deriving from an Existing Generator

There is a minimal example that shows how a generator can be derived from the existing eTrice Java generator. The example shows how the derived DetailCodeTranslator handles an additional tag.

The example consist of two plugins:

  • examples/my.etrice.generator
  • examples/my.etrice.generator.launch

You will find the examples in the eTrice GIT repository: http://git.eclipse.org/c/etrice/org.eclipse.etrice.git/tree/examples

The first one overrides the Java generator, the second one overrides the Java launch configuration to launch the derived generator. Please have a look at the comments marked with EXAMPLE: (you can add that as a Java task tag in the preferences and use the Tasks View to locate these comments).