Jump to: navigation, search

Difference between revisions of "EMF DiffMerge/Download"

m
m
Line 1: Line 1:
 +
 +
[[Image:Egg-incubation.png|left]]
 +
 
=  Releases  =
 
=  Releases  =
  
All releases of the tool are compatible with Eclipse Modeling 3.6 (Helios), 3.7 (Indigo), 3.8/4.2 (Juno), 4.3 (Kepler), 4.4 (Luna), 4.5 (Mars) and 4.6 (Neon).<br>  
+
All releases of the tool are compatible with Eclipse Modeling from 3.6 (Helios) to 4.6 (Neon).<br>  
  
 
== v0.6.0 - Part of the Eclipse Neon release train (06/2016)  ==
 
== v0.6.0 - Part of the Eclipse Neon release train (06/2016)  ==
Line 59: Line 62:
 
*[https://hudson.eclipse.org/diffmerge/job/buckminster-emf-diffmerge-master/lastSuccessfulBuild/artifact/result/publish/org.eclipse.emf.diffmerge.scm.feature/site.p2/ Update site]  
 
*[https://hudson.eclipse.org/diffmerge/job/buckminster-emf-diffmerge-master/lastSuccessfulBuild/artifact/result/publish/org.eclipse.emf.diffmerge.scm.feature/site.p2/ Update site]  
 
*[https://hudson.eclipse.org/diffmerge/job/buckminster-emf-diffmerge-master/lastSuccessfulBuild/artifact/result/publish/org.eclipse.emf.diffmerge.scm.feature/dropins/*zip*/dropins.zip Dropins]
 
*[https://hudson.eclipse.org/diffmerge/job/buckminster-emf-diffmerge-master/lastSuccessfulBuild/artifact/result/publish/org.eclipse.emf.diffmerge.scm.feature/dropins/*zip*/dropins.zip Dropins]
 
[[Image:Egg-incubation.png|left]]
 

Revision as of 03:36, 28 June 2016

Egg-incubation.png

 Releases

All releases of the tool are compatible with Eclipse Modeling from 3.6 (Helios) to 4.6 (Neon).

v0.6.0 - Part of the Eclipse Neon release train (06/2016)

v0.5.0 - Part of the Eclipse Mars release train (06/2015)

v0.4.1 - 03/2015

Fixes bugs 461377, 461935, 461936. Compatible with Patterns (see above).

v0.4.0 - 12/2014

The API changes between versions 0.3.0 and 0.4.0 can be found here.

Patterns

A new major application of the diff/merge engine is available with this release: a tool for handling modeling patterns in modeling tools based on Sirius technology. The tool requires EMF Diff/Merge 0.4.x.

Warning 1: Using the tool in a new modeling environment is likely to require a new customization.

Warning 2: The tool is compatible with Sirius 2.x, not 3.x.

v0.3.0 - Part of the Eclipse Luna release train (06/2014)

The API changes between versions 0.2.0 and 0.3.0 can be found here.

v0.2.0 - Part of the Eclipse Kepler release train (06/2013)

v0.1.0 - 11/2012

Last build