Jump to: navigation, search

Difference between revisions of "EMF/Transaction/FAQ"

(Question about JRE 1.4 support)
Line 1: Line 1:
{{stub}}
+
== Does EMF Transaction 1.1 work with J2SE 1.4? ==
  
== Question ==
+
Yes.  The EMF Transaction API works with EMF 2.2 or higher and J2SE 1.4.
  
Answer.
+
Note, however, that EMF Transaction requires the EMF Validation framework. Thus, if you are using OCL to define validation constraints, then this may require J2SE 5.0, depending on the version of MDT OCL that you use. EMF Transaction 1.1 is compatible with EMF Validation 1.0.x, which does provide OCL validation support on J2SE 1.4.
 
+
== Another Question ==
+
 
+
Answer, with quoted source code:
+
 
+
  some sample code here
+
another line of code
+
  final bit of code
+
  
  
 
----
 
----
  
''Once this FAQ contains real content, add <code><nowiki>[[Category:FAQ]]</nowiki></code>.''
+
[[Category:FAQ]]
 
+
 
[[Category:Modeling]]
 
[[Category:Modeling]]
 
[[Category:EMF]]
 
[[Category:EMF]]

Revision as of 11:43, 25 July 2007

Does EMF Transaction 1.1 work with J2SE 1.4?

Yes. The EMF Transaction API works with EMF 2.2 or higher and J2SE 1.4.

Note, however, that EMF Transaction requires the EMF Validation framework. Thus, if you are using OCL to define validation constraints, then this may require J2SE 5.0, depending on the version of MDT OCL that you use. EMF Transaction 1.1 is compatible with EMF Validation 1.0.x, which does provide OCL validation support on J2SE 1.4.