Difference between revisions of "EMF/Transaction/FAQ"

From Eclipsepedia

Jump to: navigation, search
m (Does EMF Transaction 1.x work with J2SE 1.4?)
m (Bsd.mt.ca moved page EMF-Transaction-FAQ to EMF/Transaction/FAQ: EMF/Transaction links to EMF/Transaction/FAQ, and there's nothing there.)
 
(2 intermediate revisions by one user not shown)
Line 7: Line 7:
 
=== Does EMF Transaction 1.x work with J2SE 1.4? ===
 
=== Does EMF Transaction 1.x work with J2SE 1.4? ===
  
Yes and no. The core EMF Transaction framework works with EMF 2.2 or higher and J2SE 1.4.
+
Yes and no. The core EMF Transaction framework works with the EMF Validation framework, EMF 2.2 or higher and J2SE 1.4.
  
 
<table border="1"><tr><th>Transaction</th><th>Validation</th><th>EMF</th><th>Minimim JVM</th></tr>
 
<table border="1"><tr><th>Transaction</th><th>Validation</th><th>EMF</th><th>Minimim JVM</th></tr>
Line 58: Line 58:
 
<td>1.2</td>
 
<td>1.2</td>
 
<td>1.2</td>
 
<td>1.2</td>
<td>1.2</td>
+
<td>1.1+</td>
<td>2.4</td>
+
<td>2.3+</td>
 
<td>1.5</td>
 
<td>1.5</td>
 
</tr>
 
</tr>

Latest revision as of 09:27, 18 October 2013

In addition to the FAQ below, see also the EMF Model Transaction Developer Guide documentation included in the EMF Transaction SDK.

Contents


[edit] Newbie / General

[edit] Does EMF Transaction 1.x work with J2SE 1.4?

Yes and no. The core EMF Transaction framework works with the EMF Validation framework, EMF 2.2 or higher and J2SE 1.4.

TransactionValidationEMFMinimim JVM
1.0 1.0 2.2 1.4.2
1.1 1.1 2.2+ 1.4.2
1.2 1.2 2.3+ 1.5

However, if you need the OCL extensions in the org.eclipse.emf.validation.ocl plug-in, the requirements are different.

TransactionValidationOCLEMFMinimim JVM
1.0 1.0 1.0 2.2 1.4.2
1.1 1.1 1.1 2.3 1.5
1.2 1.2 1.1+ 2.3+ 1.5

See also OCL 1.x Requirements and EMF 2.3 JVM Requirements.