Jump to: navigation, search

Difference between revisions of "EMF/Transaction/FAQ"

m (Does EMF Transaction 1.x work with J2SE 1.4?)
m (Does EMF Transaction 1.x work with J2SE 1.4?)
Line 9: Line 9:
 
Yes and no. The core EMF Transaction framework works with EMF 2.2 or higher and J2SE 1.4.
 
Yes and no. The core EMF Transaction framework works with EMF 2.2 or higher and J2SE 1.4.
  
<table border="1"><tr><th>Transaction</th><th>Validation</th><th>Query</th><th>EMF</th><th>Minimim JVM</th></tr>
+
<table border="1"><tr><th>Transaction</th><th>Validation</th><th>EMF</th><th>Minimim JVM</th></tr>
  
 
<tr align="center">
 
<tr align="center">
<td>1.0</td>
 
 
<td>1.0</td>
 
<td>1.0</td>
 
<td>1.0</td>
 
<td>1.0</td>
Line 20: Line 19:
  
 
<tr align="center">
 
<tr align="center">
<td>1.1</td>
 
 
<td>1.1</td>
 
<td>1.1</td>
 
<td>1.1</td>
 
<td>1.1</td>
Line 28: Line 26:
  
 
<tr align="center">
 
<tr align="center">
<td>1.2</td>
 
 
<td>1.2</td>
 
<td>1.2</td>
 
<td>1.2</td>
 
<td>1.2</td>
Line 38: Line 35:
  
 
However, if you need the OCL extensions in the
 
However, if you need the OCL extensions in the
<tt style="color:DarkGreen">org.eclipse.emf.validation.ocl</tt> or <tt style="color:DarkGreen">org.eclipse.emf.query.ocl</tt> plug-ins, the requirements are different.
+
<tt style="color:DarkGreen">org.eclipse.emf.validation.ocl</tt> plug-in, the requirements are different.
  
<table border="1"><tr><th>Transaction</th><th>Validation</th><th>Query</th><th>OCL</th><th>EMF</th><th>Minimim JVM</th></tr>
+
<table border="1"><tr><th>Transaction</th><th>Validation</th><th>OCL</th><th>EMF</th><th>Minimim JVM</th></tr>
  
 
<tr align="center">
 
<tr align="center">
<td>1.0</td>
 
 
<td>1.0</td>
 
<td>1.0</td>
 
<td>1.0</td>
 
<td>1.0</td>
Line 52: Line 48:
  
 
<tr align="center">
 
<tr align="center">
<td>1.1</td>
 
 
<td>1.1</td>
 
<td>1.1</td>
 
<td>1.1</td>
 
<td>1.1</td>
Line 61: Line 56:
  
 
<tr align="center">
 
<tr align="center">
<td>1.2</td>
 
 
<td>1.2</td>
 
<td>1.2</td>
 
<td>1.2</td>
 
<td>1.2</td>

Revision as of 15:54, 5 June 2008

In addition to the FAQ below, see also the EMF Model Transaction Developer Guide documentation included in the EMF Transaction SDK.

Newbie / General

Does EMF Transaction 1.x work with J2SE 1.4?

Yes and no. The core EMF Transaction framework works with EMF 2.2 or higher and J2SE 1.4.

TransactionValidationEMFMinimim JVM
1.0 1.0 2.2 1.4.2
1.1 1.1 2.2+ 1.4.2
1.2 1.2 2.3+ 1.5

However, if you need the OCL extensions in the org.eclipse.emf.validation.ocl plug-in, the requirements are different.

TransactionValidationOCLEMFMinimim JVM
1.0 1.0 1.0 2.2 1.4.2
1.1 1.1 1.1 2.3 1.5
1.2 1.2 1.2 2.4 1.5

See also OCL 1.x Requirements and EMF 2.3 JVM Requirements.