Jump to: navigation, search

EMF/Query FAQ

In addition to the FAQ below, see also the EMF Model Query Developer Guide documentation included in the EMF Query SDK.

Newbie / General

Does EMF Query 1.x work with J2SE 1.4?

Yes and no. The core EMF Query framework works with EMF 2.2 or higher and J2SE 1.4.

However, if you need the OCL extensions in the org.eclipse.emf.query.ocl plug-in, the requirements are a little different. See below.

Queryq.ocl?OCLEMFMinimim JVM
1.0 Yes 1.0 2.2 1.4.2
No n/a 2.2 1.4.2
1.1 Yes 1.1 2.3 1.5
No n/a 2.2 1.4.2
1.2 Yes 1.2 2.4 1.5
No n/a 2.3 1.5

Consequently, using OCL with EMF Query requires J2SE 5.0 or greater. See also EMF 2.3 JVM Requirements.