Jump to: navigation, search

Difference between revisions of "EMF/Query FAQ"

< EMF
m
Line 1: Line 1:
In addition to the FAQ below, see also the EMF Model Query Developer Guide documentation included in the OCL SDK.
+
In addition to the FAQ below, see also the EMF Model Query Developer Guide documentation included in the EMF Query SDK.
  
 
__TOC__
 
__TOC__

Revision as of 11:54, 25 July 2007

In addition to the FAQ below, see also the EMF Model Query Developer Guide documentation included in the EMF Query SDK.

Newbie / General

Does EMF Query 1.1 work with J2SE 1.4?

Mostly, yes. The core EMF Query framework works with EMF 2.2 or higher and J2SE 1.4.

However, the OCL extensions in the org.eclipse.emf.query.ocl plug-in require OCL 1.1 and EMF 2.3. Consequently, using OCL with EMF Query requires J2SE 5.0 or greater.