Jump to: navigation, search

Difference between revisions of "EMF/Query FAQ"

< EMF
(Question about JRE dependencies)
Line 1: Line 1:
== Does EMF Query 1.1 work with J2SE 1.4? ==
+
In addition to the FAQ below, see also the EMF Model Query Developer Guide documentation included in the OCL SDK.
 +
 
 +
__TOC__
 +
 
 +
== Newbie / General ==
 +
 
 +
=== Does EMF Query 1.1 work with J2SE 1.4? ===
  
 
Mostly, yes.  The core EMF Query framework works with EMF 2.2 or higher and J2SE 1.4.
 
Mostly, yes.  The core EMF Query framework works with EMF 2.2 or higher and J2SE 1.4.
Line 7: Line 13:
  
  
----
 
  
 
[[Category:FAQ]]
 
[[Category:FAQ]]
 
[[Category:Modeling]]
 
[[Category:Modeling]]
 
[[Category:EMF]]
 
[[Category:EMF]]

Revision as of 11:52, 25 July 2007

In addition to the FAQ below, see also the EMF Model Query Developer Guide documentation included in the OCL SDK.

Newbie / General

Does EMF Query 1.1 work with J2SE 1.4?

Mostly, yes. The core EMF Query framework works with EMF 2.2 or higher and J2SE 1.4.

However, the OCL extensions in the org.eclipse.emf.query.ocl plug-in require OCL 1.1 and EMF 2.3. Consequently, using OCL with EMF Query requires J2SE 5.0 or greater.