Jump to: navigation, search

Difference between revisions of "EMF/Query FAQ"

< EMF
(Question about JRE dependencies)
Line 1: Line 1:
{{stub}}
+
== Does EMF Query 1.1 work with J2SE 1.4? ==
  
== Question ==
+
Mostly, yes.  The core EMF Query framework works with EMF 2.2 or higher and J2SE 1.4.
  
Answer.
+
However, the OCL extensions in the
 
+
<tt style="color:DarkGreen">org.eclipse.emf.query.ocl</tt> plug-in require OCL 1.1 and EMF 2.3.  Consequently, using OCL with EMF Query requires J2SE 5.0 or greater.
== Another Question ==
+
 
+
Answer, with quoted source code:
+
 
+
some sample code here
+
another line of code
+
final bit of code
+
  
  
 
----
 
----
  
''Once this FAQ contains real content, add <code><nowiki>[[Category:FAQ]]</nowiki></code>.''
+
[[Category:FAQ]]
 
+
 
[[Category:Modeling]]
 
[[Category:Modeling]]
 
[[Category:EMF]]
 
[[Category:EMF]]

Revision as of 11:31, 25 July 2007

Does EMF Query 1.1 work with J2SE 1.4?

Mostly, yes. The core EMF Query framework works with EMF 2.2 or higher and J2SE 1.4.

However, the OCL extensions in the org.eclipse.emf.query.ocl plug-in require OCL 1.1 and EMF 2.3. Consequently, using OCL with EMF Query requires J2SE 5.0 or greater.