Difference between revisions of "EMF/Query FAQ"

From Eclipsepedia

< EMF
Jump to: navigation, search
 
(11 intermediate revisions by 3 users not shown)
Line 1: Line 1:
In addition to the FAQ below, see also the EMF Model Query Developer Guide documentation included in the OCL SDK.
+
In addition to the FAQ below, see also the EMF Model Query Developer Guide documentation included in the EMF Query SDK.<ref>[http://www.eclipse.org/modeling/emf/?project=query EMF Model Query Project]</ref><ref>[http://www.eclipse.org/modeling/emf/?project=query2 EMF Model Query2 Project]</ref>
  
 
__TOC__
 
__TOC__
Line 5: Line 5:
 
== Newbie / General ==
 
== Newbie / General ==
  
=== Does EMF Query 1.1 work with J2SE 1.4? ===
+
=== Does EMF Query 1.x work with J2SE 1.4? ===
  
Mostly, yes.  The core EMF Query framework works with EMF 2.2 or higher and J2SE 1.4.
+
Yes and no.  The core EMF Query framework works with EMF 2.2 or higher and J2SE 1.4.
  
However, the OCL extensions in the
+
<table border="1"><tr><th>Query</th><th>EMF</th><th>Minimim JVM</th></tr>
<tt style="color:DarkGreen">org.eclipse.emf.query.ocl</tt> plug-in require OCL 1.1 and EMF 2.3.  Consequently, using OCL with EMF Query requires J2SE 5.0 or greater.
+
  
 +
<tr align="center">
 +
<td>1.0</td>
 +
<td>2.2</td>
 +
<td>1.4.2</td>
 +
</tr>
  
 +
<tr align="center">
 +
<td>1.1</td>
 +
<td>2.2+</td>
 +
<td>1.4.2</td>
 +
</tr>
 +
 +
<tr align="center">
 +
<td>1.2</td>
 +
<td>2.3+</td>
 +
<td>1.5</td>
 +
</tr>
 +
 +
</table>
 +
 +
However, if you need the OCL extensions in the
 +
<tt style="color:DarkGreen">org.eclipse.emf.query.ocl</tt> plug-in, the requirements are different.
 +
 +
<table border="1"><tr><th>Query</th><th>OCL</th><th>EMF</th><th>Minimim JVM</th></tr>
 +
 +
<tr align="center">
 +
<td>1.0</td>
 +
<td>1.0</td>
 +
<td>2.2</td>
 +
<td>1.4.2</td>
 +
</tr>
 +
 +
<tr align="center">
 +
<td>1.1</td>
 +
<td>1.1</td>
 +
<td>2.3</td>
 +
<td>1.5</td>
 +
</tr>
 +
 +
<tr align="center">
 +
<td>1.2</td>
 +
<td>1.2</td>
 +
<td>2.4</td>
 +
<td>1.5</td>
 +
</tr>
 +
</table>
 +
 +
See also [[MDT-OCL-FAQ#Does_OCL_1.x_work_with_J2SE_1.4.3F|OCL 1.x Requirements]] and [[EMF/EMF 2.3/JVM Requirements|EMF 2.3 JVM Requirements]].
 +
 +
== Resources ==
 +
 +
<references />
  
 
[[Category:FAQ]]
 
[[Category:FAQ]]
 
[[Category:Modeling]]
 
[[Category:Modeling]]
 
[[Category:EMF]]
 
[[Category:EMF]]
 +
[[Category:Query]]

Latest revision as of 16:55, 27 December 2010

In addition to the FAQ below, see also the EMF Model Query Developer Guide documentation included in the EMF Query SDK.[1][2]

Contents


[edit] Newbie / General

[edit] Does EMF Query 1.x work with J2SE 1.4?

Yes and no. The core EMF Query framework works with EMF 2.2 or higher and J2SE 1.4.

QueryEMFMinimim JVM
1.0 2.2 1.4.2
1.1 2.2+ 1.4.2
1.2 2.3+ 1.5

However, if you need the OCL extensions in the org.eclipse.emf.query.ocl plug-in, the requirements are different.

QueryOCLEMFMinimim JVM
1.0 1.0 2.2 1.4.2
1.1 1.1 2.3 1.5
1.2 1.2 2.4 1.5

See also OCL 1.x Requirements and EMF 2.3 JVM Requirements.

[edit] Resources

  1. EMF Model Query Project
  2. EMF Model Query2 Project