Jump to: navigation, search

Difference between revisions of "EMF/Query FAQ"

< EMF
m (Does EMF Query 1.x work with J2SE 1.4?)
m (Does EMF Query 1.x work with J2SE 1.4?)
Line 9: Line 9:
 
Yes and no.  The core EMF Query framework works with EMF 2.2 or higher and J2SE 1.4.
 
Yes and no.  The core EMF Query framework works with EMF 2.2 or higher and J2SE 1.4.
  
However, if you need the OCL extensions in the
+
<table border="1"><tr><th>Query</th><th>EMF</th><th>Minimim JVM</th></tr>
<tt style="color:DarkGreen">org.eclipse.emf.query.ocl</tt> plug-in, the requirements are a little different. See below.
+
 
+
<table border="1"><tr><th>Query</th><th><tt style="color:DarkGreen">q.ocl</tt>?</th><th>OCL</th><th>EMF</th><th>Minimim JVM</th></tr>
+
  
 
<tr align="center">
 
<tr align="center">
<td rowspan="2">1.0</td>
 
<td>Yes</td>
 
 
<td>1.0</td>
 
<td>1.0</td>
 
<td>2.2</td>
 
<td>2.2</td>
 
<td>1.4.2</td>
 
<td>1.4.2</td>
 
</tr>
 
</tr>
 +
 
<tr align="center">
 
<tr align="center">
<td>No</td>
+
<td>1.1</td>
<td>n/a</td>
+
<td>2.2+</td>
<td>2.2</td>
+
 
<td>1.4.2</td>
 
<td>1.4.2</td>
 
</tr>
 
</tr>
  
 
<tr align="center">
 
<tr align="center">
<td rowspan="2">1.1</td>
+
<td>1.2</td>
<td>Yes</td>
+
<td>2.3+</td>
<td>1.1</td>
+
<td>2.3</td>
+
 
<td>1.5</td>
 
<td>1.5</td>
 
</tr>
 
</tr>
 +
 +
</table>
 +
 +
However, if you need the OCL extensions in the
 +
<tt style="color:DarkGreen">org.eclipse.emf.query.ocl</tt> plug-in, the requirements are different.
 +
 +
<table border="1"><tr><th>Query</th><th><th>OCL</th><th>EMF</th><th>Minimim JVM</th></tr>
 +
 
<tr align="center">
 
<tr align="center">
<td>No</td>
+
<td>1.0</td>
<td>n/a</td>
+
<td>1.0</td>
 
<td>2.2</td>
 
<td>2.2</td>
 
<td>1.4.2</td>
 
<td>1.4.2</td>
Line 43: Line 44:
  
 
<tr align="center">
 
<tr align="center">
<td rowspan="2">1.2</td>
+
<td>1.1</td>
<td>Yes</td>
+
<td>1.1</td>
<td>1.2</td>
+
<td>2.3</td>
<td>2.4</td>
+
 
<td>1.5</td>
 
<td>1.5</td>
 
</tr>
 
</tr>
 +
 
<tr align="center">
 
<tr align="center">
<td>No</td>
+
<td>1.2</td>
<td>n/a</td>
+
<td>1.2</td>
<td>2.3</td>
+
<td>2.4</td>
 
<td>1.5</td>
 
<td>1.5</td>
 
</tr>
 
</tr>
 
 
</table>
 
</table>
  
Consequently, using OCL with EMF Query 1.1 or later requires J2SE 5.0 or greater. See also [[EMF/EMF 2.3/JVM Requirements|EMF 2.3 JVM Requirements]].
+
See also [[EMF/EMF 2.3/JVM Requirements|EMF 2.3 JVM Requirements]].
 
+
  
 
[[Category:FAQ]]
 
[[Category:FAQ]]
 
[[Category:Modeling]]
 
[[Category:Modeling]]
 
[[Category:EMF]]
 
[[Category:EMF]]

Revision as of 16:30, 5 June 2008

In addition to the FAQ below, see also the EMF Model Query Developer Guide documentation included in the EMF Query SDK.

Newbie / General

Does EMF Query 1.x work with J2SE 1.4?

Yes and no. The core EMF Query framework works with EMF 2.2 or higher and J2SE 1.4.

QueryEMFMinimim JVM
1.0 2.2 1.4.2
1.1 2.2+ 1.4.2
1.2 2.3+ 1.5

However, if you need the OCL extensions in the org.eclipse.emf.query.ocl plug-in, the requirements are different.

QueryOCLEMFMinimim JVM
1.0 1.0 2.2 1.4.2
1.1 1.1 2.3 1.5
1.2 1.2 2.4 1.5

See also EMF 2.3 JVM Requirements.