Jump to: navigation, search

Difference between revisions of "EMF/Query FAQ"

< EMF
m (Does EMF Query 1.x work with J2SE 1.4?)
m (Does EMF Query 1.x work with J2SE 1.4?)
Line 7: Line 7:
 
=== Does EMF Query 1.x work with J2SE 1.4? ===
 
=== Does EMF Query 1.x work with J2SE 1.4? ===
  
Mostly, yes.  The core EMF Query framework works with EMF 2.2 or higher and J2SE 1.4.
+
Yes and no.  The core EMF Query framework works with EMF 2.2 or higher and J2SE 1.4.
  
However, the OCL extensions in the
+
However, if you need the OCL extensions in the
<tt style="color:DarkGreen">org.eclipse.emf.query.ocl</tt> plug-in require:
+
<tt style="color:DarkGreen">org.eclipse.emf.query.ocl</tt> plug-in, the requirements are a little different. See below.
:* For Query 1.2: OCL 1.2 and EMF 2.4
+
 
:* For Query 1.1: OCL 1.1 and EMF 2.3
+
<table border="1"><tr><th>Query</th><th><tt style="color:DarkGreen">q.ocl</tt>?</th><th>OCL</th><th>EMF</th><th>Minimim JVM</th></tr>
 +
 
 +
<tr align="center">
 +
<td rowspan="2">1.0</td>
 +
<td>Yes</td>
 +
<td>1.0</td>
 +
<td>2.2</td>
 +
<td>1.4.2</td>
 +
</tr>
 +
<tr align="center">
 +
<td>No</td>
 +
<td>n/a</td>
 +
<td>2.2</td>
 +
<td>1.4.2</td>
 +
</tr>
 +
 
 +
<tr align="center">
 +
<td rowspan="2">1.1</td>
 +
<td>Yes</td>
 +
<td>1.1</td>
 +
<td>2.3</td>
 +
<td>1.5</td>
 +
</tr>
 +
<tr align="center">
 +
<td>No</td>
 +
<td>n/a</td>
 +
<td>2.2</td>
 +
<td>1.4.2</td>
 +
</tr>
 +
 
 +
<tr align="center">
 +
<td rowspan="2">1.2</td>
 +
<td>Yes</td>
 +
<td>1.2</td>
 +
<td>2.4</td>
 +
<td>1.5</td>
 +
</tr>
 +
<tr align="center">
 +
<td>No</td>
 +
<td>n/a</td>
 +
<td>2.3</td>
 +
<td>1.5</td>
 +
</tr>
 +
 
 +
</table>
  
 
Consequently, using OCL with EMF Query requires J2SE 5.0 or greater. See also [[EMF/EMF 2.3/JVM Requirements|EMF 2.3 JVM Requirements]].
 
Consequently, using OCL with EMF Query requires J2SE 5.0 or greater. See also [[EMF/EMF 2.3/JVM Requirements|EMF 2.3 JVM Requirements]].

Revision as of 16:22, 5 June 2008

In addition to the FAQ below, see also the EMF Model Query Developer Guide documentation included in the EMF Query SDK.

Newbie / General

Does EMF Query 1.x work with J2SE 1.4?

Yes and no. The core EMF Query framework works with EMF 2.2 or higher and J2SE 1.4.

However, if you need the OCL extensions in the org.eclipse.emf.query.ocl plug-in, the requirements are a little different. See below.

Queryq.ocl?OCLEMFMinimim JVM
1.0 Yes 1.0 2.2 1.4.2
No n/a 2.2 1.4.2
1.1 Yes 1.1 2.3 1.5
No n/a 2.2 1.4.2
1.2 Yes 1.2 2.4 1.5
No n/a 2.3 1.5

Consequently, using OCL with EMF Query requires J2SE 5.0 or greater. See also EMF 2.3 JVM Requirements.