Jump to: navigation, search

Difference between revisions of "EMF/Query FAQ"

< EMF
m (Does EMF Query 1.1 work with J2SE 1.4?: link to EMF 2.3 jvm reqs)
m (Does EMF Query 1.x work with J2SE 1.4?)
Line 5: Line 5:
 
== Newbie / General ==
 
== Newbie / General ==
  
=== Does EMF Query 1.1 work with J2SE 1.4? ===
+
=== Does EMF Query 1.x work with J2SE 1.4? ===
  
 
Mostly, yes.  The core EMF Query framework works with EMF 2.2 or higher and J2SE 1.4.
 
Mostly, yes.  The core EMF Query framework works with EMF 2.2 or higher and J2SE 1.4.
  
 
However, the OCL extensions in the
 
However, the OCL extensions in the
<tt style="color:DarkGreen">org.eclipse.emf.query.ocl</tt> plug-in require OCL 1.1 and EMF 2.3Consequently, using OCL with EMF Query requires J2SE 5.0 or greater. See also [[EMF/EMF 2.3/JVM Requirements|EMF 2.3 JVM Requirements]].
+
<tt style="color:DarkGreen">org.eclipse.emf.query.ocl</tt> plug-in require:
 +
:* For Query 1.2: OCL 1.2 and EMF 2.4
 +
:* For Query 1.1: OCL 1.1 and EMF 2.3
 +
 
 +
Consequently, using OCL with EMF Query requires J2SE 5.0 or greater. See also [[EMF/EMF 2.3/JVM Requirements|EMF 2.3 JVM Requirements]].
  
  

Revision as of 15:08, 5 June 2008

In addition to the FAQ below, see also the EMF Model Query Developer Guide documentation included in the EMF Query SDK.

Newbie / General

Does EMF Query 1.x work with J2SE 1.4?

Mostly, yes. The core EMF Query framework works with EMF 2.2 or higher and J2SE 1.4.

However, the OCL extensions in the org.eclipse.emf.query.ocl plug-in require:

  • For Query 1.2: OCL 1.2 and EMF 2.4
  • For Query 1.1: OCL 1.1 and EMF 2.3

Consequently, using OCL with EMF Query requires J2SE 5.0 or greater. See also EMF 2.3 JVM Requirements.