Jump to: navigation, search

EMF-Validation-FAQ

Revision as of 11:36, 25 July 2007 by Cdamus.ca.ibm.com (Talk | contribs) (Question about JRE 1.4 support)

Does EMF Validation 1.1 work with J2SE 1.4?

Mostly, yes. The core EMF Validation framework works with EMF 2.2 or higher and J2SE 1.4.

However, the OCL extensions in the org.eclipse.emf.validation.ocl plug-in require OCL 1.1 and EMF 2.3. Consequently, using OCL with EMF validation requires J2SE 5.0 or greater.