Skip to main content
Jump to: navigation, search


Revision as of 16:09, 5 June 2008 by (Talk | contribs) (Does EMF Validation 1.x work with J2SE 1.4?)

In addition to the FAQ below, see also the EMF Validation Framework Developer Guide documentation included in the EMF Validation SDK.

Newbie / General

Does EMF Validation 1.x work with J2SE 1.4?

Mostly, yes. The core EMF Validation framework works with EMF 2.2 or higher and J2SE 1.4.

However, the OCL extensions in the org.eclipse.emf.validation.ocl plug-in require:

  • For Validation 1.2: OCL 1.2 and EMF 2.4
  • For Validation 1.1: OCL 1.1 and EMF 2.3

Consequently, using OCL with EMF validation requires J2SE 5.0 or greater.

Back to the top