EMF-Validation-FAQ

From Eclipsepedia

Jump to: navigation, search

In addition to the FAQ below, see also the EMF Validation Framework Developer Guide documentation included in the EMF Validation SDK.

Contents


Newbie / General

Does EMF Validation 1.x work with J2SE 1.4?

Yes and no. The core EMF Validation framework works with EMF 2.2 or higher and J2SE 1.4.

ValidationEMFMinimim JVM
1.0 2.2 1.4.2
1.1 2.2+ 1.4.2
1.2 2.3+ 1.5

However, if you need the OCL extensions in the org.eclipse.emf.validation.ocl plug-in, the requirements are different.

QueryOCLEMFMinimim JVM
1.0 1.0 2.2 1.4.2
1.1 1.1 2.3 1.5
1.2 1.1+ 2.3+ 1.5

See also OCL 1.x Requirements and EMF 2.3 JVM Requirements.