Jump to: navigation, search

Difference between revisions of "EMF-Validation-FAQ"

(Question about JRE 1.4 support)
Line 1: Line 1:
== Does EMF Validation 1.1 work with J2SE 1.4? ==
+
In addition to the FAQ below, see also the OCL Developer Guide documentation included in the OCL SDK.
 +
 
 +
__TOC__
 +
 
 +
== Newbie / General ==
 +
 
 +
=== Does EMF Validation 1.1 work with J2SE 1.4? ===
  
 
Mostly, yes.  The core EMF Validation framework works with EMF 2.2 or higher and J2SE 1.4.
 
Mostly, yes.  The core EMF Validation framework works with EMF 2.2 or higher and J2SE 1.4.
Line 6: Line 12:
 
<tt style="color:DarkGreen">org.eclipse.emf.validation.ocl</tt> plug-in require OCL 1.1 and EMF 2.3.  Consequently, using OCL with EMF validation requires J2SE 5.0 or greater.
 
<tt style="color:DarkGreen">org.eclipse.emf.validation.ocl</tt> plug-in require OCL 1.1 and EMF 2.3.  Consequently, using OCL with EMF validation requires J2SE 5.0 or greater.
  
 
----
 
  
 
[[Category:FAQ]]
 
[[Category:FAQ]]
 
[[Category:Modeling]]
 
[[Category:Modeling]]
 
[[Category:EMF]]
 
[[Category:EMF]]

Revision as of 11:53, 25 July 2007

In addition to the FAQ below, see also the OCL Developer Guide documentation included in the OCL SDK.

Newbie / General

Does EMF Validation 1.1 work with J2SE 1.4?

Mostly, yes. The core EMF Validation framework works with EMF 2.2 or higher and J2SE 1.4.

However, the OCL extensions in the org.eclipse.emf.validation.ocl plug-in require OCL 1.1 and EMF 2.3. Consequently, using OCL with EMF validation requires J2SE 5.0 or greater.