Jump to: navigation, search

Difference between revisions of "EMF-Validation-FAQ"

m (Does EMF Validation 1.x work with J2SE 1.4?)
m (Does EMF Validation 1.x work with J2SE 1.4?)
Line 7: Line 7:
 
=== Does EMF Validation 1.x work with J2SE 1.4? ===
 
=== Does EMF Validation 1.x work with J2SE 1.4? ===
  
Mostly, yes. The core EMF Validation framework works with EMF 2.2 or higher and J2SE 1.4.
+
Yes and no. The core EMF Validation framework works with EMF 2.2 or higher and J2SE 1.4.
  
However, the OCL extensions in the
+
<table border="1"><tr><th>Validation</th><th>EMF</th><th>Minimim JVM</th></tr>
<tt style="color:DarkGreen">org.eclipse.emf.validation.ocl</tt> plug-in require:
+
  
:* For Validation 1.2: OCL 1.2 and EMF 2.4
+
<tr align="center">
:* For Validation 1.1: OCL 1.1 and EMF 2.3
+
<td>1.0</td>
 +
<td>2.2</td>
 +
<td>1.4.2</td>
 +
</tr>
  
Consequently, using OCL with EMF validation requires J2SE 5.0 or greater.
+
<tr align="center">
 +
<td>1.1</td>
 +
<td>2.2+</td>
 +
<td>1.4.2</td>
 +
</tr>
  
 +
<tr align="center">
 +
<td>1.2</td>
 +
<td>2.3+</td>
 +
<td>1.5</td>
 +
</tr>
 +
 +
</table>
 +
 +
However, if you need the OCL extensions in the
 +
<tt style="color:DarkGreen">org.eclipse.emf.validation.ocl</tt> plug-in, the requirements are different.
 +
 +
<table border="1"><tr><th>Query</th><th>OCL</th><th>EMF</th><th>Minimim JVM</th></tr>
 +
 +
<tr align="center">
 +
<td>1.0</td>
 +
<td>1.0</td>
 +
<td>2.2</td>
 +
<td>1.4.2</td>
 +
</tr>
 +
 +
<tr align="center">
 +
<td>1.1</td>
 +
<td>1.1</td>
 +
<td>2.3</td>
 +
<td>1.5</td>
 +
</tr>
 +
 +
<tr align="center">
 +
<td>1.2</td>
 +
<td>1.1+</td>
 +
<td>2.3+</td>
 +
<td>1.5</td>
 +
</tr>
 +
</table>
 +
 +
See also [[MDT-OCL-FAQ#Does_OCL_1.x_work_with_J2SE_1.4.3F|OCL 1.x Requirements]] and [[EMF/EMF 2.3/JVM Requirements|EMF 2.3 JVM Requirements]].
  
 
[[Category:FAQ]]
 
[[Category:FAQ]]
 
[[Category:Modeling]]
 
[[Category:Modeling]]
 
[[Category:EMF]]
 
[[Category:EMF]]

Revision as of 16:39, 5 June 2008

In addition to the FAQ below, see also the EMF Validation Framework Developer Guide documentation included in the EMF Validation SDK.

Newbie / General

Does EMF Validation 1.x work with J2SE 1.4?

Yes and no. The core EMF Validation framework works with EMF 2.2 or higher and J2SE 1.4.

ValidationEMFMinimim JVM
1.0 2.2 1.4.2
1.1 2.2+ 1.4.2
1.2 2.3+ 1.5

However, if you need the OCL extensions in the org.eclipse.emf.validation.ocl plug-in, the requirements are different.

QueryOCLEMFMinimim JVM
1.0 1.0 2.2 1.4.2
1.1 1.1 2.3 1.5
1.2 1.1+ 2.3+ 1.5

See also OCL 1.x Requirements and EMF 2.3 JVM Requirements.