Jump to: navigation, search

EMF/Transaction/FAQ

< EMF‎ | Transaction
Revision as of 10:43, 25 July 2007 by Cdamus.ca.ibm.com (Talk | contribs) (Question about JRE 1.4 support)

Does EMF Transaction 1.1 work with J2SE 1.4?

Yes. The EMF Transaction API works with EMF 2.2 or higher and J2SE 1.4.

Note, however, that EMF Transaction requires the EMF Validation framework. Thus, if you are using OCL to define validation constraints, then this may require J2SE 5.0, depending on the version of MDT OCL that you use. EMF Transaction 1.1 is compatible with EMF Validation 1.0.x, which does provide OCL validation support on J2SE 1.4.