Jump to: navigation, search

Difference between revisions of "EDT:Supported Platforms"

Line 35: Line 35:
 
| bgcolor="#cccccc" | Browser<br>  
 
| bgcolor="#cccccc" | Browser<br>  
 
|  
 
|  
*Microsoft Internet Explorer 8 and 9<br>
+
*Microsoft Internet Explorer 8 and 9<br>  
 
*Google Chrome  
 
*Google Chrome  
*Mozilla FireFox <br><br><br>WebKit is supported only on Eclipse 3.7, but is not supported on Red Hat Enterprise Edition. Also, the 64-bit version of WebKit is not supported on Windows platforms. <br><br>Here are details on setting the internal browser to XULRunner: <br>[http://www.eclipse.org/swt/faq.php#howusemozilla http://www.eclipse.org/swt/faq.php#howusemozilla] <br>
+
*Mozilla FireFox <br><br>WebKit is supported only on Eclipse 3.7, but is not supported on Red Hat Enterprise Edition. Also, the 64-bit version of WebKit is not supported on Windows platforms. <br><br>Here are details on setting the internal browser to XULRunner: <br>[http://www.eclipse.org/swt/faq.php#howusemozilla http://www.eclipse.org/swt/faq.php#howusemozilla] <br><br>The following render engines are supported in the EDT Visual Editor on all operating systems, where available:
 +
*XULRunner 1.9
 +
*WebKit 1.2 on Eclipse 3.6
 +
*WebKit 1.2 through 1.4 on Eclipse 3.7<br>  
  
 
|  
 
|  
Line 54: Line 57:
 
| bgcolor="#cccccc" | Database<br>  
 
| bgcolor="#cccccc" | Database<br>  
 
|  
 
|  
*Apache Derby v10<br>
+
*Apache Derby v10<br>  
 
*JDBC 4.0 driver required<br>
 
*JDBC 4.0 driver required<br>
 +
 
|  
 
|  
 
*IBM DB2 v9.7  
 
*IBM DB2 v9.7  

Revision as of 16:39, 26 June 2012

Supported platforms and related software for EDT 0.8


Tested and validated platforms
Platforms expected to work
We encourage community support in testing!
Eclipse IDE for Java EE Developers

JRE
  • Oracle Java JRE 6
  • IBM Runtime Environment, Java Technology Edition 1.6 and 1.7
  • Oracle Java JRE 7
Operating System
  • Microsoft Windows XP
  • Microsoft Windows 7
  • Microsoft Vista
  • Red Hat Linux 5

Browser
  • Microsoft Internet Explorer 8 and 9
  • Google Chrome
  • Mozilla FireFox

    WebKit is supported only on Eclipse 3.7, but is not supported on Red Hat Enterprise Edition. Also, the 64-bit version of WebKit is not supported on Windows platforms.

    Here are details on setting the internal browser to XULRunner:
    http://www.eclipse.org/swt/faq.php#howusemozilla

    The following render engines are supported in the EDT Visual Editor on all operating systems, where available:
  • XULRunner 1.9
  • WebKit 1.2 on Eclipse 3.6
  • WebKit 1.2 through 1.4 on Eclipse 3.7
  • Apple Safari
Application/Web Server
  • Apache Tomcat 6.x
  • Apache Tomcat 7
  • Jetty
Database
  • Apache Derby v10
  • JDBC 4.0 driver required
  • IBM DB2 v9.7
  • MySQL v5.5


Tested with EDT

Microsoft Trident: 

  • On a 32-bit Windows platform, Trident version 4.0 (for Internet Explorer 8) and 5.0 (for Internet Explorer 9).
  • On a 64-bit Windows platform, Trident version 5.0 (for Internet Explorer 9, both 32- and 64-bit).

WebKit:

  • On a 32-bit Windows platform, WebKit version 535.19 and 534.55.

XULRunner:

  • On a 32-bit Windows platform, 32-bit XULRunner versions 1.9.2.23 and 1.9.2.24.
  • On a 64-bit Windows platform, 32-bit XULRunner; but the version was not recorded.
  • On a 32-bit Linux platform, 32-bit XULRunner version 1.9.2.24.
  • On a 64-bit Linux platform, 32-bit XULRunner; but the version was not recorded.
  • On a 64-bit Linux platform, 64-bit XULRunner versions 1.9.2.20, 1.9.2.23, and 1.9.2.24.