Skip to main content
Jump to: navigation, search

E4/UI/Running the photo demo

< E4‎ | UI
Revision as of 15:51, 26 February 2010 by Pwebster.ca.ibm.com (Talk | contribs) (Setup steps)

A screenshot of the e4 photo demo.
The instructions provided on this page were last updated for the e4 1.0M4 milestone.

The e4 photo demo showcases an e4-based RCP application that allows the user to browse images in their workspace.

Prerequisites

Features

  • Shows how CSS can be used to skin an application (note that the CSS engine does not have any particular dependencies on e4 technologies and can be reused in an Eclipse 3.x-based application)

Setup steps

LaunchPhoto.png
  1. Download an e4 SDK here.
  2. Unzip/Untar the file as you would with a regular Eclipse SDK download.
  3. Start up Eclipse.
    1. If you downloaded the eclipse e4 SDK you can quickly load the demo projects by generating a PSF project, using the menu e4>Generate e4 Example Project
    2. Then select the /org.eclipse.e4.examples.psf/e4-examples.psf file and Import PSF Project from the context menu.
    3. skip to step 11
  4. Start Eclipse with an empty workspace directory.
  5. Select File > Import... and select CVS > Projects from CVS, click Next.
  6. Copy the CVS repository location and paste it into the "Host" field to populate the wizard page: :pserver:anonymous@dev.eclipse.org:/cvsroot/eclipse
  7. You should see "Host: dev.eclipse.org, Repository path: /cvsroot/eclipse, User: anonymous, Connection type: pserver".
  8. Click Next and select the second option Use an existing module.
  9. Drill down as follows: e4 > org.eclipse.e4.ui > examples and select org.eclipse.e4.demo.e4photo. Click Next.
  10. Important: Do not click Finish just yet. Advance to the last wizard page using Next, then click on Refresh Tags. Select the tag appropriate for your installation (e.g. M3, I20100112-0800, R0_9 ... you can find your installation's build tag in the Help > About Eclipse SDK dialog) and click Finish.
  11. This will check out a project into your workspace. Expand the project in the Package Explorer and open the e4photo.product file.
  12. Click on the link Launch an Eclipse Application at the bottom left of the e4photo.product file editor. An error will show up.
  13. Run > Run Configurations...
  14. Now launch the product from the dialog, it should open.

Click on the Create Album toolbar button or select File > Create Album. The new album location on disk will be printed to your Eclipse console. Just drop a couple (not too many!) of JPEG photos in that directory, then play with the application. Make sure you find a photo with embedded GPS coordinates - when you select it in the Exif view, the Location view will show where the photo was taken using Google Maps. You can find an example photo with GPS coordinates on bug 263898.

Then, have a look at the Application.e4xmi file to see how the demo application is configured, and/or look at the source files for the individual pieces (views and command handlers).

Known issues

  • You may see some syserr output in the console like the following. It is safe to ignore them.
Unable to find parent with ID "{0}"

Unable to find parent with ID "{0}"
  • When switching between perspectives, the window may become blank. If you switch it back to the previous one and then again, the contents should render.
  • The 'Exif' view may not react to selection changes if it is rendered, see bug 299755 for more details.
  • On Windows, you may see errors if you have a browser rendered in the 'Location' view. See bug 303978 for more details.

Back to the top