Skip to main content
Jump to: navigation, search

Difference between revisions of "E4/UI/Running the photo demo"

< E4‎ | UI
Line 12: Line 12:
 
# Click Next and select the second option <i>Use an existing module</i>.
 
# Click Next and select the second option <i>Use an existing module</i>.
 
# Drill down as follows: <i>e4 > org.eclipse.e4.ui > examples</i> and select <i>org.eclipse.e4.demo.e4photo</i>. Click <b><i>Next</i></b>.
 
# Drill down as follows: <i>e4 > org.eclipse.e4.ui > examples</i> and select <i>org.eclipse.e4.demo.e4photo</i>. Click <b><i>Next</i></b>.
# <b>Important:</b> Do not click Finish just yet. Advance to the last wizard page using Next, then click on <i>Refresh Tags</i>. Select <i>v20090206-0840</i> and click <i>Finish</i>.
+
# <b>Important:</b> Do not click Finish just yet. Advance to the last wizard page using Next, then click on <i>Refresh Tags</i>. Select <i>R0_9</i> and click <i>Finish</i>.
 
# This will check out one project into your workspace. Expand the project in the Package Explorer and open the <i>e4photo.product</i> file.
 
# This will check out one project into your workspace. Expand the project in the Package Explorer and open the <i>e4photo.product</i> file.
 
# Click on the link <i>Launch an Eclipse Application</i> at the bottom left of the <i>e4photo.product</i> file editor.
 
# Click on the link <i>Launch an Eclipse Application</i> at the bottom left of the <i>e4photo.product</i> file editor.

Revision as of 11:55, 23 July 2009

E4-m1-photo-demo.PNG

Prerequisite: Make sure you've installed the e4 UI runtime components as described here.

Optionally, install the EMF SDK to be able to open .xmi files using the EMF editor: "Help" -> "Install New Software..." -> "Models and Model Development" -> "EMF SDK - Eclipse Modeling Framework SDK 2.4.1", then restart Eclipse.

Check out the e4 photo demo project from CVS as follows:

  1. Start Eclipse with an empty workspace directory.
  2. Select File > Import... and select CVS > Projects from CVS, click Next.
  3. Copy the CVS repository location and paste it into the "Host" field to populate the wizard page: :pserver:anonymous@dev.eclipse.org:/cvsroot/eclipse
  4. You should see "Host: dev.eclipse.org, Repository path: /cvsroot/eclipse, User: anonymous, Connection type: pserver".
  5. Click Next and select the second option Use an existing module.
  6. Drill down as follows: e4 > org.eclipse.e4.ui > examples and select org.eclipse.e4.demo.e4photo. Click Next.
  7. Important: Do not click Finish just yet. Advance to the last wizard page using Next, then click on Refresh Tags. Select R0_9 and click Finish.
  8. This will check out one project into your workspace. Expand the project in the Package Explorer and open the e4photo.product file.
  9. Click on the link Launch an Eclipse Application at the bottom left of the e4photo.product file editor.

LaunchPhoto.png

The e4 photo demo application will come up. Click on the Create Album toolbar button or select File > Create Album. The new album location on disk will be printed to your Eclipse console. Just drop a couple (not too many!) of JPEG photos in that directory, then play with the application. Make sure you find a photo with embedded GPS coordinates - when you select it in the Exif view, the Location view will show where the photo was taken using Google Maps. You can find an example photo with GPS coordinates on bug 263898.

Then, have a look at the Application.xmi file to see how the demo application is configured, and/or look at the source files for the individual pieces (views and command handlers).

Back to the top