Skip to main content
Jump to: navigation, search

Difference between revisions of "E4/UI/Running the photo demo"

< E4‎ | UI
Line 15: Line 15:
 
## Click on the link "Launch an Eclipse Application" at the bottom left of the .product file editor.
 
## Click on the link "Launch an Eclipse Application" at the bottom left of the .product file editor.
  
The e4 photo demo application will come up.
+
The e4 photo demo application will come up. Click on the "Create Album" toolbar button or select File > Create Album. The new album location on disk will be printed to your Eclipse console. Just drop a couple (not too many!) of JPEG photos in that directory, then play with the application. Make sure you find a photo with embedded GPS coordinates - when you select it in the "Exif" view, the "Location" view will show where the photo was taken using Google Maps. You can find an example photo with GPS coordinates on [https://bugs.eclipse.org/bugs/show_bug.cgi?id=263898 bug 263898].

Revision as of 16:46, 6 February 2009

  1. Make sure you've installed the e4 UI runtime components as described here.
  2. Optionally, install the EMF SDK to be able to open .xmi files using the EMF editor: "Help" -> "Install New Software..." -> "Models and Model Development" -> "EMF - Eclipse Modeling Framework", then restart Eclipse.
  3. Now check out the e4 photo demo project from CVS as follows:
    1. Start Eclipse with an empty workspace directory.
    2. Select File > Import...
    3. Select CVS > Projects from CVS.
    4. Click Next.
    5. Copy the CVS repository location and paste it into the "Host" field to populate the wizard page: :pserver:anonymous@dev.eclipse.org:/cvsroot/eclipse
    6. You should see "Host: dev.eclipse.org, Repository path: /cvsroot/eclipse, User: anonymous, Connection type: pserver".
    7. Click Next and select the second option "Use an existing module".
    8. Drill down as follows: e4 > org.eclipse.e4.ui > examples > org.eclipse.e4.demo.e4photo.
    9. With "org.eclipse.e4.demo.e4photo" selected, click Finish.
    10. This will check out one project into your workspace. Expand the project in the Package Explorer.
    11. Open the "e4photo.product" file.
    12. Click on the link "Launch an Eclipse Application" at the bottom left of the .product file editor.

The e4 photo demo application will come up. Click on the "Create Album" toolbar button or select File > Create Album. The new album location on disk will be printed to your Eclipse console. Just drop a couple (not too many!) of JPEG photos in that directory, then play with the application. Make sure you find a photo with embedded GPS coordinates - when you select it in the "Exif" view, the "Location" view will show where the photo was taken using Google Maps. You can find an example photo with GPS coordinates on bug 263898.

Back to the top