Jump to: navigation, search

E4/Running the demos

e4 Photo Demo

To run the e4 photo demo (a RCP style example app), you can follow these steps:

  1. Start with Eclipse 3.4 and an empty workspace.
  2. Open the CVS Repositories view (Ctrl+3 CVSR).
  3. Right-click in the view and select New > Repository Location.
  4. Copy the following string and paste it into the 'Host' field: :pserver:anonymous@dev.eclipse.org:/cvsroot/eclipse .
  5. (Optional: Adjust user name, password and connection method if you are a committer.)
  6. Expand the repository, then HEAD, e4-incubator, ui.
  7. Right-click on 'demos' and select 'Check Out'.
  8. In the Package Explorer, expand demos, then projectSets, and select the file 'ui-e4photo.psf'.
  9. Select 'Import Project Set' from the context menu on the the psf file
  10. A dialog will open asking you to create repository locations. Select each location and click 'Create', providing username 'anonymous' unless you are a committer. Click OK.
  11. Open the Run Configurations dialog (Ctrl+3 MRC), expand 'Eclipse Application', select 'e4 photo demo', and click Run.
  12. The demo app should open, looking empty. Click on "Create Album".
  13. Check the outer Eclipse's Console view, it should have printed a location on disk where it created the album. (It created a project in an Eclipse workspace.) Copy sample photos from your workspace (under demos/sampleData/photos) into the album directory. You can do this while the demo application is running, it will pick up the changes in its "Library" view.

Demos from EclipseCon 2008

Project Set Files

Download the project set files referenced below from here: E4-demos-psf-projects.zip. (NOTE: This project set contains all of the EclipseCon demos. You will be instructed in the steps below as to which one are needed for Flex, Dojo and the other demos).

You can also get the latest versions of the project set files from the demos project under 'e4-incubator/ui' :pserver:anonymous@dev.eclipse.org:/cvsroot/eclipse

The demos project also includes the EMF workbench prototype.

SWT for Flex

The SWT port for Flex consists of the Adobe Flex environment (the ActionScript compiler), the Eclipse host environment (the plugins needed to compile and launch Java code in a Flash player) and the Eclipse target environment (the running plugins, the SWT port itself and example code). NOTE: That the both the tools and the port are in the pre-alpha stage. You are living on the bleeding edge. Good luck!

The Eclipse target environment provides support for compiling, launching and debugging java applications in flash player.

Setup Flex environment:

  1. Download and install the Adobe Open Source Flex SDK (available from http://opensource.adobe.com). NOTE: The path where you install the Flex SDK must contain no spaces. This is due to a bug in FCSH.
  2. Add an environment variable called FLEX_SDK pointing to the root of the flex SDK ("Control Panel" -> "System" -> "Advanced" -> "Environment Variables" -> "New" under user variables). IMPORTANT: Set this variable first before running the Eclipse host or target environment or it will be undefined.
  3. Verify that your Flex install works by opening a command prompt, changing to the Flex SDK bin directory, typing "mxmlc" and hitting Enter. If you get a message like the following, you will need to add a JAVA_HOME environment variable that points to the home dir or edit the bin/jvm.config file in the Flex SDK.
  Error: could not find JRE
  Error: could not find Java 2 Runtime Environment.

Setup the Eclipse host environment:

  1. Create a new Eclipse Workspace. NOTE: The path were you create the workspace must contain no spaces. This is due to a bug in FCSH.
  2. Download the project set file (link above) and extract.
  3. Create a path variable in Linked Resources preference page (Preferences>Workspace>Linked Resources). The variable should be called FLEX_SDK and point to the root of the Flex SDK.
  4. Import the swt-e4Plugins.psf project set ("Import..." -> "Team" -> "Team Project Set"). IMPORTANT: You must use anonymous:anonymous when prompted for username:pwd.
  5. Refresh the project org.eclipse.swt.tools.actionscript.core.
  6. Create a new "Eclipse Application" launch configuration and in the Arguments tab add "-Xmx512M" to its VM arguments. IMPORTANT: If you do not increase the amount of memory that the VM can use, the Eclipse target will fail with out of memory errors.
  7. Launch the target environment

Setup the Eclipse target environment

  1. Turn off auto build ('Project' -> 'Build Automatically')
  2. Create a workspace variable in Linked Resources preference page ('Preferences' -> 'Workspace' -> 'Linked Resources'). The variable should be called WORKSPACE and point to the root of the target Eclipse workspace.
  3. Add a new ActionScript VM. ('Window' -> 'Preferences' -> 'Java>Installed JREs').
    1. Click Add...
    2. Select ActionScript VM, click next.
    3. Click Directory... and browse to either your Firefox or IE install directory.
    4. Click OK.
    5. Click Finish
  4. Import the swt-e4Demos project set. IMPORTANT: You must use anonymous:anonymous when prompted for username:pwd.
  5. Change the .classpath_flex to .classpath for the following projects. (Note that in order to see the classpath files, you have to either do this in the Navigator view or turn off the resources filter in the Packages Explorer by clicking on the drop down arrow menu in the top right hand corner of the package explorer, selecting Filters and unchecking *.resources).
    1. org.eclipse.swt
    2. org.eclipse.swt.e4.jcl
    3. org.eclipse.swt.examples
  1. Refresh the org.eclipse.swt project to pick up the linked resources.
  2. Turn on Build Automatically (You can watch the build progress in the ActionScript Build Console, available from the Console view)
  3. You can run any of the demos from org.eclipse.swt.e4.examples by clicking on them and Selecting "Run As>ActionScript Application". Note that for the Flickr example, you must select static linking in the launch configuration dialog.


Setup a sample SWT ActionScript project from scratch

 Note that this assumes you have gone through the steps above.
  1. Create a Java Project.
  2. Add the ActionScript nature to the project "Select Project>Popup Menu>Action Script Tools>Toogle Nature".
  3. Add the org.eclipse.swt project to the Java Build Path projects tab.
  4. Change the execution environment of the project JRE container to J2AS-1.5
  5. Add this class and save
  1. Add an environment variable called FLEX_SDK pointing to the root of the flex SDK ("Control Panel" -> "System" -> "Advanced" -> "Environment Variables" -> "New" under user variables).
  2. Verify that your Flex install works by opening a command prompt and typing "mxmlc" and hit Enter. If you get a message like the following, you will need to add a JAVA_HOME environment variable that points to the home dir or edit the bin/jvm.config file in the Flex SDK.
  Error: could not find JRE
  Error: could not find Java 2 Runtime Environment.

Setup the Eclipse host environment:

  1. Create a new Eclipse Workspace
  2. Download the project set file (link above) and extract.
  3. Create a path variable in Linked Resources preference page (Preferences>Workspace>Linked Resources). The variable should be called FLEX_SDK and point to the root of the Flex SDK.
  4. Import the swt-e4Plugins.psf project set (if you don't have a username:pwd, use can use anonymous:anonymous).
  5. Refresh the project org.eclipse.swt.tools.actionscript.core.
  6. Create a new "Eclipse Application" launch configuration and in the Arguments tab add "-Xmx512M" to its VM arguments.
  7. Launch the target environment

Setup the Eclipse target environment

  1. Turn off auto build (Project>Build Automatically)
  2. Create a workspace variable in Linked Resources preference page (Preferences>Workspace>Linked Resources). The variable should be called WORKSPACE and point to the root of the target Eclipse workspace.
  3. Add a new ActionScript VM. (Window>Preferences>Java>Installed JREs).
    1. Click Add...
    2. Select ActionScript VM, click next.
    3. Click Directory... and browse to either your Firefox or IE install directory.
    4. Click OK.
    5. Click Finish
  4. Import the swt-e4Demos project set.
  5. Change the .classpath_flex to .classpath for the following projects. (Note that in order to see the classpath files, you have to either do this in the Navigator view or turn off the resources filter in the Packages Explorer by clicking on the drop down arrow menu in the top right hand corner of the package explorer, selecting Filters and unchecking *.resources).
    1. org.eclipse.swt
    2. org.eclipse.swt.e4.jcl
    3. org.eclipse.swt.examples
  1. Refresh the org.eclipse.swt project to pick up the linked resources.
  2. Turn on Build Automatically (You can watch the build progress in the ActionScript Build Console, available from the Console view)
  3. You can run any of the demos by clicking on them and Selecting "Run As>ActionScript Application". Note that for the Flickr example, you must select static linking in the launch configuration dialog.


Setup a sample SWT ActionScript project from scratch

 Note that this assumes you have gone through the steps above.
  1. Create a Java Project.
  2. Add the ActionScript nature to the project "Select Project>Popup Menu>Action Script Tools>Toogle Nature".
  3. Add the org.eclipse.swt project to the Java Build Path projects tab.
  4. Change the execution environment of the project JRE container to J2AS-1.5
  5. Add this class, save and Run as ActionScript Application
public class Main {
	public static void main(String[] args) {
		Display display = new Display();
		Shell shell = new Shell(display);
		shell.setLayout(new GridLayout(1, false));
 
		Button b = new Button(shell, SWT.PUSH);
		b.setText("Push");
 
		shell.pack();
		shell.open();
	}
}

SWT for Dojo

*** Due to project refactoring, these instructions are out of date and this demo is broken. We are working to fix this situation. Please stay tuned.

Common setup between the two SWT demos:

  1. Create new Eclipse Workspace.
  2. Import the swt-e4Set.psf file into your workspace. (Just click "OK" when it asks for "compatible locations".)
  3. Change "Preferences -> Java -> Compiler -> Building -> Build path problems -> Circular dependencies" to Warning.

Steps specific to Dojo:

  1. Copy .classpath_dojo to .classpath in both the org.eclipse.swt and org.eclispse.swt.e4 projects. (Note that in order to see the classpath files, you have to either do this in the Navigator view or turn off the resources filter in the Packages Explorer by clicking on the drop down arrow menu in the top right hand corner of the package explorer, selecting Filters and unchecking *.resources).
  2. Download the Google Web Toolkit for Linux (use version 1.4.62 for now). Note it is important to get the Linux download regardless of the OS you are running on.
  3. Download the Dojo Toolkit (use version 1.1.1).
  4. Create a Java Project, call it "DojoResources".
  5. Create 2 subfolders, named "public" and "gwt". In the "public" subfolder, create another folder named "dojo".
  6. Extract the Dojo download and import the folders into the "dojo" folder. Your directory structure should look like this:
public
--dojo
	-- dijit
	-- dojo
	-- dojoX
	-- util
  1. Extract the GWT download and import "gwt-dev-linux.jar" and "gwt-user.jar" into the "gwt" folder. Your directory structure should look like this:
gwt
-- gwt-dev-linux.jar
-- gwt-user.jar
  1. Copy the dojoLib.gwt.xml file from org.eclipse.swt.e4\Eclipse SWT PI\dojo\build to the root of the DojoResources project.
  2. To build the example, run the script org.eclipse.swt.e4.examples\dojo\build.xml. To run the script, right click and select Run As>Ant Build... Click on the JRE tab and select "Run in the same JRE as the workspace".
  3. Copy the index.html file from /org.eclipse.swt.e4/Eclipse SWT PI/dojo/build/ to the generated controlexample folder (org.eclipse.swt.e4.examples/dojo/bin/www/controlexample).
  4. Replace the following line in the index.html file :
<!-- <script src="NAME_OF_GWT_XML_FILE.nocache.js" language="javascript"></script> -->

with this:

<script src="controlexample.nocache.js" language="javascript"></script>
  1. Open the index.html file in a browser (embeded or system one).

Scriptable Workbench

Common setup between the two Platform UI demos:

  1. Download 3.4.
  2. Install XULRunner 1.8.1.3 as described in the SWT FAQ.
  3. Create a new workspace. This is important - the demo will not run with the SWT projects from above.
  4. Download the "Mozilla XPCom for Java" feature from this update site: http://releases.mozilla.org/pub/mozilla.org/xulrunner/releases/1.8.1.3/contrib/eclipse/
  5. Import the ui-e4Set.psf file.

Running the "Scriptable Workbench" demo:

  1. Run an inner Eclipse.
  2. Open the "Workbench Model" view by using the Quick Access (CTRL+3) and entering "Workbench Model"

Note that this is experimental code, and many things in the inner Eclipse don't work. Try and play around by changing and running the Javascript code in the right pane of the Model View.

Eclipse Web Client

Common setup between the two Platform UI demos:

  1. Download 3.4.
  2. Install XULRunner 1.8.1.3 as described in the SWT FAQ.
  3. Create a new workspace. This is important - the demo will not run with the SWT projects from above.
  4. Download the "Mozilla XPCom for Java" feature from this update site: http://releases.mozilla.org/pub/mozilla.org/xulrunner/releases/1.8.1.3/contrib/eclipse/
  5. Import the ui-e4Set.psf file.

Running the "Eclipse Web Client" demo:

  1. Run an inner Eclipse.
  2. Create a new project (for example, the RCP Mail project)
  3. In Firefox 2, go to about:config and change the value of network.http.max-persistent-connections-per-server to 4 (default is 2).
  4. Start Firefox 2 and point it at http://localhost:8000/e4/files/workbench.html.

Note that the demo only runs in Firefox.