Jump to: navigation, search

Difference between revisions of "Development Resources/Project Plan/Modeling Project"

(New page: In the Modeling Project, we're all about Agile development, so the intent is to make the overhead as lightweight as possible. Consistency while supporting variety. Here's how to ident...)
 
m (add reference to bug 248672 re: galileo%2B / galileo+ not being properly encoded)
Line 16: Line 16:
 
|}
 
|}
  
 +
Finally, you need to embed queries in your plan.xml. [http://dev.eclipse.org/viewcvs/index.cgi/www/modeling/emf/emf/project-info/plan.xml?root=Eclipse_Website&content-type=text%2Fplain&view=co Here's an example].
 +
 +
If your query works in a browser but returns nothing when viewed through the project plan renderer, it maybe be because the renderer is stripping parts of your query. See {{bug|248672}}, or this [http://dev.eclipse.org/viewcvs/index.cgi/www/modeling/emf/emf/project-info/plan.xml?root=Eclipse_Website&r1=1.11&r2=1.12 this workaround].
  
 
[[Category:Modeling]] [[Category:Releng]]
 
[[Category:Modeling]] [[Category:Releng]]

Revision as of 18:07, 26 September 2008

In the Modeling Project, we're all about Agile development, so the intent is to make the overhead as lightweight as possible. Consistency while supporting variety.

Here's how to identify bugs in your plan.xml using the galileo flag:

  • Committed Items: mark with galileo+, and assign to a reusable milestone, eg. "M1", "M2", ... "M7" or "RC"
  • Proposed Items: mark with galileo+, and assign to either the "---" target milestone, or the actual release version, eg., for EMF, 2.5; for OCL, 1.3.
  • Deferred Items: mark with galileo-


Next, to group your plan items by theme, it's suggested that you use the Status Whiteboard. To do so, query for one or more bugs, click the Change Several Bugs at Once link, select the bugs you want to change, and set a Status Whiteboard value for those bugs:

Eclipse-bugzilla-status-whiteboard.png

Finally, you need to embed queries in your plan.xml. Here's an example.

If your query works in a browser but returns nothing when viewed through the project plan renderer, it maybe be because the renderer is stripping parts of your query. See bug 248672, or this this workaround.