Difference between revisions of "Descriptive XSD Smoke Test Scenarios"

From Eclipsepedia

Jump to: navigation, search
(Extensions)
(Validation)
 
(7 intermediate revisions by one user not shown)
Line 91: Line 91:
 
# Replace ''<simpleType name="ShaftType">'' with ''<simpleType name="ShaftTypeChanged">'' and save
 
# Replace ''<simpleType name="ShaftType">'' with ''<simpleType name="ShaftTypeChanged">'' and save
 
# '''Verify''' that validation kicks in and marks the file with one error
 
# '''Verify''' that validation kicks in and marks the file with one error
# Go to the ''Problems'' view and '''verify''' that an error appears like ''XSD: Type reference "http://www.example.org/GolfCountryClub#ShaftType" is unresolved''
+
# Go to the ''Problems'' view and '''verify''' that an error appears like ''src-resolve: Cannot resolve the name 'tns:ShaftType' to a(n) 'type definition' component.''
  
 
=Secondary Rotating Tests=
 
=Secondary Rotating Tests=
Line 97: Line 97:
  
 
==Drag & Drop Tests==
 
==Drag & Drop Tests==
# '''Sequence''': setup by creating a new Complex Type, adding a sequence, and adding a few elements into the sequence.  In the Design view, re-order the sequence elements by dragging. 
+
# Import the XML Examples: ''New -> Example ... -> Editing and validating XML files''
# '''Group''': setup by creating a new Group and adding a few elements.  In the Design view, re-order the sequence elements by dragging. 
+
# Open ''XMLExamples/GolfCountryClub/GolfCountryClub.xsd'' and switch to the ''design'' view
# '''Attribute''': setup by creating a new Complex Type and adding a few attributes.  In the Design view, re-order the attributes by dragging. 
+
# Right click in the ''Types'' section and select ''Add Complex Type''
# '''Attribute group''': setup by creating a new Attribute Group and adding a few attributes.  In the Design view, re-order the attributes by dragging. 
+
# Double click the newly added complex type to drill down to its details
 
+
# Right click on the complex type and select ''Add Sequence''
The reordering must be reflected in the bothe the Design and Outline view and in the editor's Source view.
+
# Add four elements in the newly created sequence
 
+
# Drag & drop in the design view to re-order them
 +
# '''Verify''' the order is changed correctly in the design view, outline view and source view
 +
# Add four attribute in the complex type as well
 +
# Drag & drop in the design view to re-order them
 +
# '''Verify''' the order is changed correctly in the design view, outline view and source view
  
 
==Source Editing==
 
==Source Editing==
Line 141: Line 145:
  
 
==XML Catalog==
 
==XML Catalog==
# '''Load an XML schema from the jar''': create a new XML Schema or use an existing XML schema -> select Extensions from the vertical tab in the Properties view -> Add -> Add... -> fill in a schema name -> select a Schema from Catalog (these schema documents are from jar files). Not all schemas will have components, so select schemas like http://schemas.xmlsoap.org/wsdl/ -> a component should show up in the Available components to Add list, select one and press OK. Check that the imported schema shows up in the Source view and the component added
+
===Schema resolution using XML Catalog===
# '''Export XML catalog file''': right click on a project in the Package Explorer view -> Export... -> select the XML Catalog from the XML folder and press the Next button ->  select a directory to export file to and add a name which ends in .xml -> press the Finish button.  Open the newly export XML Catalog File and verify that it isn't empty (should contain the element <catalog xmlns="urn:oasis:names:tc:entity:xmlns:xml:catalog"/>)
+
# Import the XML Examples: ''New -> Example ... -> Editing and validating XML files''
# '''Import XML catalog file''': right click on a project in the Package Explorer view -> Import... select the XML Catalog from the XML folder and press the Next button -> select a directory -> press the Import Files... button -> Use browse to find the location of an XML Catalog file -> select the XML file(s) -> click the Finish button.  Verify the files were added into the correct directory and contain the correct information. A quick way to export files is to use files in the same workspace but export to a different directory within the project
+
# Open ''XMLExamples/GolfCountryClub/GolfCountryClub.xml'' and switch to the ''source'' view
 +
# Change ''<GolfCourse NumberOfHoles="18">'' to ''<GolfCourse NumberOfHoles="19">''
 +
# Right click on ''XMLExamples/GolfCountryClub/GolfCountryClub.xml'' and select ''Validate''
 +
# '''Verify''' there is one error complaining the value of ''NumberOfHoles''
 +
# Add a schema location-based custom entry to XML Catalog:
 +
## Go to ''Window -> Preferences -> XML -> XML Catalog''
 +
## Click ''Add...''
 +
## Click ''Workspace...'' and select ''XMLExamples/GolfCountryClub/GolfCountryClub.xsd''
 +
## Set ''Key Type'' to ''Schema Location'' and ''Key'' is ''http://my.schema.location''
 +
# Replace ''xsi:schemaLocation="http://www.example.org/GolfCountryClub GolfCountryClub.xsd "'' with ''xsi:schemaLocation="http://www.example.org/GolfCountryClub http://my.schema.location "'', and save
 +
# Right click on ''XMLExamples/GolfCountryClub/GolfCountryClub.xml'' and select ''Validate''
 +
# '''Verify''' there is one error complaining the value of ''NumberOfHoles''
 +
# Change the XML Catalog to Namespace-based:
 +
## Go to ''Window -> Preferences -> XML -> XML Catalog''
 +
## Edit the entry ''http://my.schema.location'': change ''Key Type'' to ''Namespace Name'' and set the ''Key'' to ''http://www.example.org/GolfCountryClub''
 +
# Go back to the XML file and delete ''xsi:schemaLocation="http://www.example.org/GolfCountryClub http://my.schema.location "'', and save
 +
# Right click on ''XMLExamples/GolfCountryClub/GolfCountryClub.xml'' and select ''Validate''
 +
# '''Verify''' there is one error complaining the value of ''NumberOfHoles''
 +
 
 +
===Export the custom XML Catalog===
 +
# Use the same workspace as the above step
 +
# Click ''File -> Export... -> XML -> XML Catalog'', and export it to ''XMLExamples/catalog.xml''
 +
# '''Verify''' that ''catalog.xml'' looks like:
 +
<?xml version="1.0" encoding="UTF-8"?><catalog xmlns="urn:oasis:names:tc:entity:xmlns:xml:catalog">
 +
  <uri name="http://www.example.org/GolfCountryClub" uri="platform:/resource/XMLExamples1/GolfCountryClub/GolfCountryClub.xsd"/>
 +
</catalog>
 +
 
 +
===Import the custom XML Catalog===
 +
# Go to ''Window -> Preferences -> XML -> XML Catalog'', and delete the custom entry
 +
# Import ''XMLExamples/catalog.xml'' using ''File -> Import... -> XML -> Catalog''
 +
# Go to ''Window -> Preferences -> XML -> XML Catalog'', and '''verify''' that you see a custom entry named ''http://www.example.org/GolfCountryClub''
  
 
==Generators==
 
==Generators==
Line 177: Line 211:
 
# Import the XML Examples: ''New -> Example ... -> Editing and validating XML files''
 
# Import the XML Examples: ''New -> Example ... -> Editing and validating XML files''
 
# Download [[Image:Honourallschemaloc.zip]] and unzip the files to ''XMLExamples''
 
# Download [[Image:Honourallschemaloc.zip]] and unzip the files to ''XMLExamples''
 +
# Go to ''Window -> Preferences -> XML -> XML Schema Files -> Validation'' (Note: In WTP 3.0.5, it's ''Window -> Preferences -> XML -> XML Schema Files''), '''uncheck''' "Honour all schema locations"
 
# Right click ''C.xsd'' and select ''Validate''.   
 
# Right click ''C.xsd'' and select ''Validate''.   
 
# '''Verify''' that an error src-resolve.   
 
# '''Verify''' that an error src-resolve.   
# Go to ''Window -> Preferences -> XML -> XML Schema Files'', check "Honour all schema locations"  
+
# Go to ''Window -> Preferences -> XML -> XML Schema Files -> Validation'' (Note: In WTP 3.0.5, it's ''Window -> Preferences -> XML -> XML Schema Files''), check "Honour all schema locations"  
 
# Validate C.xsd again. '''Verify''' that the error message should disappear.
 
# Validate C.xsd again. '''Verify''' that the error message should disappear.
 
  
 
===Modify full schema conformance===
 
===Modify full schema conformance===
  
Download the schema overlap.xsd from https://bugs.eclipse.org/bugs/show_bug.cgi?id=162244 or alternatively, use the code below, which simulates the same scenario.
+
# Import the XML Examples: ''New -> Example ... -> Editing and validating XML files''
 +
# Go to ''Window -> Preferences -> XML -> XML Schema Files'', '''verify''' by default the preference "Check full XML Schema conformance" is enabled
 +
# Create a new schema file like below:
  
 
''FullConformance.xsd''
 
''FullConformance.xsd''
Line 205: Line 241:
 
</source>
 
</source>
  
Validate this file and notice that an error is displayed (prefixed by cos-nonambig).  By default the preference "Check full XML Schema conformance" is enabled, resulting in this error message.  In the XSD schema preference, uncheck the preference "Check full XML Schema conformance" and validate the file.  The error should disappear.
+
# Validate this file and '''verify''' that an error is displayed (prefixed by cos-nonambig)
 
+
# Go back to the preference and uncheck the preference ''Check full XML Schema conformance''
 +
# Validate the file and '''verify''' that error disappears.
  
 
===Remove unused imports (New to 3.0.1)===
 
===Remove unused imports (New to 3.0.1)===
  
 
# Import the XML Examples: ''New -> Example ... -> Editing and validating XML files''
 
# Import the XML Examples: ''New -> Example ... -> Editing and validating XML files''
# Go to ''Window -> Preferences -> XML -> XML Schema Files'', uncheck ''Automatically remove unused XSD imports and XML Namespace entries''
+
# Go to ''Window -> Preferences -> XML -> XML Schema Files -> Editor'' (Note: In WTP 3.0.5, it's ''Window -> Preferences -> XML -> XML Schema Files''), uncheck, if needed, ''Automatically remove unused XSD imports and XML Namespace entries''
 
# Open ''XMLExamples/GolfCountryClub/GolfCountryClub.xsd''
 
# Open ''XMLExamples/GolfCountryClub/GolfCountryClub.xsd''
 
# Switch to source view, add ''<import schemaLocation="../PhoneBanking/PhoneBanking.xsd" namespace="http://www.example.com/PhoneBanking"></import>'' as a child to the top level element ''<schema>''
 
# Switch to source view, add ''<import schemaLocation="../PhoneBanking/PhoneBanking.xsd" namespace="http://www.example.com/PhoneBanking"></import>'' as a child to the top level element ''<schema>''
 
# Save and '''verify''' that the import is persisted
 
# Save and '''verify''' that the import is persisted
# Go to ''Window -> Preferences -> XML -> XML Schema Files'', check ''Automatically remove unused XSD imports and XML Namespace entries''
+
# Go to ''Window -> Preferences -> XML -> XML Schema Files -> Editor'' (Note: In WTP 3.0.5, it's ''Window -> Preferences -> XML -> XML Schema Files'', check ''Automatically remove unused XSD imports and XML Namespace entries''
 
# Add a white space after the ''</import>'' tag and save
 
# Add a white space after the ''</import>'' tag and save
 
# '''Verify''' that the import is removed
 
# '''Verify''' that the import is removed

Latest revision as of 12:12, 26 August 2009

The smoke tests are organized into three categories: core tests, secondary rotating tests and adhoc tests. In every test run, the goal is to devote 60% of the time to core tests from which every test should be run, 30% to secondary rotating tests from which a tester can pick two or three tests making sure to cover each test at least once in a milestone, and 10% to adhoc test which can be picked randomly.

Contents

[edit] Core Tests

Every test in this category should be run in every smoke test.

[edit] Open and Close Editor

  1. Import the XML Examples: New -> Example ... -> Editing and validating XML files
  2. Open XMLExamples/GolfCountryClub/GolfCountryClub.xsd and make sure you're in the design view
  3. Verify you can find BoxOfBallsType in the Types section of the design view; and there are two elements and 12 types in total

[edit] File Creation & Saving

  1. Import the XML Examples: New -> Example ... -> Editing and validating XML files
  2. File -> New -> Other... -> XML folder -> XML Schema to create an empty Schema file: NewXMLSchema.xsd
  3. Verify the new file is created and opened in the Schema Editor
  4. Right click in the Element section and add a new element called NewElement and add a NewComplexType in the Types section as well
  5. Save and close the editor
  6. Reopen the editor and verify that the NewElement and NewComplexType are persisted.
  7. File -> Save As..., and use the name NewXMLSchemaSaveAs.xsd
  8. Verify the NewXMLSchemaSaveAs.xsd file appear in the navigator
  9. In NewXMLSchemaSaveAs.xsd, add a new element and a new complex type
  10. Close the editor without saving the changes
  11. Reopen the NewXMLSchemaSaveAs.xsd, and verify that the new changes are discarded


[edit] Selection Tests

Synchronization between Properties, Design, Source, and Outline views: while conducting the Add/Modify tests, delete tests, and drag & drop tests, observe that these three views are synchronized


Note: if the nodes are collapsed and you add a new child, the node will not automatically expand. Therefore to test synchronization, expand the nodes whenever necessary to verify the synchronization between the Outline and Design view

[edit] Add/Modify Tests

For the tests where a new item is added:

  • Verify that the item was successfully added by finding and selecting the item from the Outline view or Design view
  • Whenever possible, modify the name of the item by changing the Name property in the Properties view under General properties

Tests:

  1. Include: create a copy of the XML schema of interest and copy to another workspace directory. In Outline view, right click on the Directives node -> Add Include. In the Properties view, select the copied schema as the Schema location
  2. Import: in Outline view, right click on the Directives node -> Add Import. Select a schema from the workbench
  3. Redefine: in Outline view, right click on the Directives node -> Add Redefine. Select a schema from the workbench
  4. Element: in Outline view, right click on the Elements node -> Add Element
  5. Attribute: in Outline view, right click on the Attributes node -> Add Attribute
  6. Attribute Group: in Outline view, right click on the Attributes node -> Add Attribute Group. Right click on the newly created Attribute Group -> Add Attribute
  7. Attribute default and fixed values: right click on an Attribute -> select the Default radio button from the Properties view under the General vertical tab -> Put a value. Verify changes by going to Source view. Now change the radio button to Fixed and verify the change in the source view.
  8. Complex Type: in Outline view, right click on the Types node -> Add Complex Type
  9. Simple Type: in Outline view, right click on the Types node -> Add Simple Type
  10. Group: in Outline view, right click on the Groups node -> Add Group
  11. Attribute ref: in Outline view, right click on a Complex Type -> Add Attribute Ref
  12. Attribute ref default and fixed values: right click on an Attribute ref -> select the Default radio button from the Properties view under the General vertical tab -> Put a value. Verify changes by going to Source view. Now change the radio button to Fixed and verify the change in the source view.
  13. Attribute group ref: in Outline view, right click on a Complex Type -> Add Attribute Group Ref
  14. Any Attribute: in Outline view, right click on a Complex Type -> Add Any Attribute
  15. Sequence: in Outline view, right click on a Complex Type -> Add Sequence
  16. Choice: in Outline view, right click on a Complex Type -> Add Choice
  17. All: in Outline view, right click on a Complex Type -> Add All
  18. Repeat the same steps for Design View. The UI element to mouseover and right click for each test is highlighted when selected in the Outline view

[edit] Delete Tests

  1. Delete items: Delete the following in Outline or Design view: Include, Import, Redefine, Element, Attribute, Attribute Group, Group, Attribute ref, Attribute group ref, Any Attribute, Sequence, Choice, All, Complex Type, Simple Type
  2. Delete locals and globals: Delete locals by removing a non-root element from the XML schema document and remove globals by removing a root element from the XML schema. Remove by right clicking on the element -> Delete

[edit] Search & Refactoring

[edit] Search & Rename

  1. Import the XML Examples: New -> Example ... -> Editing and validating XML files
  2. Create a new Schema file called NewSchema.xsd under the folder GolfCountryClub
  3. Create a new element and right click on it: Set Type -> Browse...
  4. Change the Search scope to Enclosing project and select BoxOfBallsType.
  5. Click OK and save
  6. Open GolfCountryClub.xsd
  7. Right click BoxOfBallsType in the Types section: References -> Project
  8. Verify that there is one reference in NewSchema.xsd and one reference in GolfCountryClub.xsd
  9. Right click BoxOfBallsType in the Types section: Refactor -> Rename...'
  10. Check Update references and change the name to BoxOfBallsTypeChanged and click Preview ->
  11. Verify that there are two changes in GolfCountryClub.xsd and one change in NewSchema.xsd
  12. Click OK and verify that the changes in the preview are applied to the two files using the editor. (Hint: can search for BoxOfBallsTypeChanged in the two files.)

[edit] Make Anonymous Type Global

  1. Use the same XML Examples project imported in the section above and open GolfCountryClub.xsd
  2. In the Outline view, select Elements -> GolfCountryClub -> local type
  3. Right click local type and select Refactor -> Make Anonymous Type Global
  4. Verify that local type becomes GolfCountryClubComplexType and the Types tree has a new element also called GolfCountryClubComplexType

[edit] Make Local Element Global

  1. Use the same XML Examples project imported in the section above and open GolfCountryClub.xsd
  2. In the Outline view, select Elements -> GolfClubType -> Shaft: ShaftType
  3. Right click Shaft: ShaftType and select Refactor -> Make Local Element Global
  4. Verify that a new Shaft: ShaftType element appears in the Elements tree at the same level as the GolfClub: GolfClubType, and also that a little arrow icon overlays the original Shaft: ShaftType

[edit] Validation

  1. Import the XML Examples: New -> Example ... -> Editing and validating XML files
  2. Right click on the project XMLExamples -> Properties -> select Validation from the list of properties -> add a check to the "Add Validation Builder to project" checkbox.
  3. Open XMLExamples/GolfCountryClub/GolfCountryClub.xsd and switch to source view by clicking the source tab at the bottom of the editor.
  4. Replace <simpleType name="ShaftType"> with <simpleType name="ShaftTypeChanged"> and save
  5. Verify that validation kicks in and marks the file with one error
  6. Go to the Problems view and verify that an error appears like src-resolve: Cannot resolve the name 'tns:ShaftType' to a(n) 'type definition' component.

[edit] Secondary Rotating Tests

Two or three tests from this category should be run in every smoke test. Testers should make sure every test should be run at least once in any given milestone.

[edit] Drag & Drop Tests

  1. Import the XML Examples: New -> Example ... -> Editing and validating XML files
  2. Open XMLExamples/GolfCountryClub/GolfCountryClub.xsd and switch to the design view
  3. Right click in the Types section and select Add Complex Type
  4. Double click the newly added complex type to drill down to its details
  5. Right click on the complex type and select Add Sequence
  6. Add four elements in the newly created sequence
  7. Drag & drop in the design view to re-order them
  8. Verify the order is changed correctly in the design view, outline view and source view
  9. Add four attribute in the complex type as well
  10. Drag & drop in the design view to re-order them
  11. Verify the order is changed correctly in the design view, outline view and source view

[edit] Source Editing

  1. As you type validation: add invalid attributes or elements to the XML Schema. As you type them, the text should be underlined in red and on mouseover, an error message should be displayed (if you already verified as you type validation while you were verifying validation, you can skip this step)
  2. Content Assist: use CTRL+SPACE in various parts of the Schema to see the possible entries that can be added
  3. Switching between Design and Source view: make sure changes to the source are reflected in the Design view

[edit] Hyperlink Navigation

  1. Import the XML Examples: New -> Example ... -> Editing and validating XML files
  2. Open XMLExamples/GolfCountryClub/GolfCountryClub.xsd and switch to the source view
  3. Go to the line <element name="GolfCourse" type="tns:GolfCourseType" maxOccurs="unbounded" minOccurs="1"></element>
  4. Hold Ctrl and click on tns:GolfCourseType
  5. Verify that the editor "jumps" to this line <complexType name="GolfCourseType">
  6. Add an import like: <import schemaLocation="../PhoneBanking/PhoneBanking.xsd" namespace="http://www.example.com/PhoneBanking"></import>
  7. Hold Ctrl and click on "../PhoneBanking/PhoneBanking.xsd"
  8. Verify that an external editor is opened on PhoneBanking.xsd

[edit] Extensions

  1. Import the XML Examples: New -> Example ... -> Editing and validating XML files
  2. Open XMLExamples/GolfCountryClub/GolfCountryClub.xsd and switch to the design view
  3. Right click Types -> BoxOfBallsType and select Show properties
  4. In the properties view, click the Extensions tab
  5. Click Add..., and then Add... in the popup dialog
  6. Click Workspace... and select XMLExamples/PhoneBanking/PhoneBanking.xsd
  7. Select and add AccountSummary
  8. Verify that the AccountSummary is added as an extension
  9. Click Add..., and then Add... in the popup dialog again
  10. Click XML Catalog... and select http://schemas.xmlsoap.org/wsdl/soap/
  11. Select and add binding
  12. Verify; that the binding is added as an extension
  13. Select binding and verify that it has three attributes: required, style and transport
  14. Fill attributes, save and reopen the file
  15. Verify that the two new extensions are persisted and the attributes of the binding extension as well
  16. Delete the two extensions
  17. Save and reopen the file
  18. Verify that the two extensions have been deleted

[edit] XML Catalog

[edit] Schema resolution using XML Catalog

  1. Import the XML Examples: New -> Example ... -> Editing and validating XML files
  2. Open XMLExamples/GolfCountryClub/GolfCountryClub.xml and switch to the source view
  3. Change <GolfCourse NumberOfHoles="18"> to <GolfCourse NumberOfHoles="19">
  4. Right click on XMLExamples/GolfCountryClub/GolfCountryClub.xml and select Validate
  5. Verify there is one error complaining the value of NumberOfHoles
  6. Add a schema location-based custom entry to XML Catalog:
    1. Go to Window -> Preferences -> XML -> XML Catalog
    2. Click Add...
    3. Click Workspace... and select XMLExamples/GolfCountryClub/GolfCountryClub.xsd
    4. Set Key Type to Schema Location and Key is http://my.schema.location
  7. Replace xsi:schemaLocation="http://www.example.org/GolfCountryClub GolfCountryClub.xsd " with xsi:schemaLocation="http://www.example.org/GolfCountryClub http://my.schema.location ", and save
  8. Right click on XMLExamples/GolfCountryClub/GolfCountryClub.xml and select Validate
  9. Verify there is one error complaining the value of NumberOfHoles
  10. Change the XML Catalog to Namespace-based:
    1. Go to Window -> Preferences -> XML -> XML Catalog
    2. Edit the entry http://my.schema.location: change Key Type to Namespace Name and set the Key to http://www.example.org/GolfCountryClub
  11. Go back to the XML file and delete xsi:schemaLocation="http://www.example.org/GolfCountryClub http://my.schema.location ", and save
  12. Right click on XMLExamples/GolfCountryClub/GolfCountryClub.xml and select Validate
  13. Verify there is one error complaining the value of NumberOfHoles

[edit] Export the custom XML Catalog

  1. Use the same workspace as the above step
  2. Click File -> Export... -> XML -> XML Catalog, and export it to XMLExamples/catalog.xml
  3. Verify that catalog.xml looks like:
<?xml version="1.0" encoding="UTF-8"?><catalog xmlns="urn:oasis:names:tc:entity:xmlns:xml:catalog">
  <uri name="http://www.example.org/GolfCountryClub" uri="platform:/resource/XMLExamples1/GolfCountryClub/GolfCountryClub.xsd"/>
</catalog>

[edit] Import the custom XML Catalog

  1. Go to Window -> Preferences -> XML -> XML Catalog, and delete the custom entry
  2. Import XMLExamples/catalog.xml using File -> Import... -> XML -> Catalog
  3. Go to Window -> Preferences -> XML -> XML Catalog, and verify that you see a custom entry named http://www.example.org/GolfCountryClub

[edit] Generators

  1. Import the XML Examples: New -> Example ... -> Editing and validating XML files
  2. Right click on XMLExamples/GolfCountryClub/GolfCountryClub.xsd and select Generate -> XML File...
  3. Accept the defaults and generate a new XML file
  4. Verify that the generated file looks like the following:
<?xml version="1.0" encoding="UTF-8"?>
<tns:GolfClub xmlns:tns="http://www.example.org/GolfCountryClub" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance" xsi:schemaLocation="http://www.example.org/GolfCountryClub GolfCountryClub.xsd ">
 <ManufacturerName>ManufacturerName</ManufacturerName>
 <Quantity>1</Quantity>
 <ClubKind>Driver</ClubKind>
 <Loft>Loft</Loft>
 <Shaft>Regular</Shaft>
</tns:GolfClub>

[edit] Preferences

XSD preferences are found in the menubar Window -> Preferences -> XML -> XML Schema Files


[edit] Qualify XSD constructs

  1. Go to Window -> Preferences -> XML -> XML Schema Files
  2. Check the Qualify XSD constructs preference
  3. Modify the prefix and the target namespace
  4. Ensure that the prefix and target namespace is used by the new schema wizard: File -> New -> Others... -> XML -> XML Schema


[edit] Honour all schema locations

Test a schema that imports two other schemas with the same namespace and different locations.

  1. Import the XML Examples: New -> Example ... -> Editing and validating XML files
  2. Download File:Honourallschemaloc.zip and unzip the files to XMLExamples
  3. Go to Window -> Preferences -> XML -> XML Schema Files -> Validation (Note: In WTP 3.0.5, it's Window -> Preferences -> XML -> XML Schema Files), uncheck "Honour all schema locations"
  4. Right click C.xsd and select Validate.
  5. Verify that an error src-resolve.
  6. Go to Window -> Preferences -> XML -> XML Schema Files -> Validation (Note: In WTP 3.0.5, it's Window -> Preferences -> XML -> XML Schema Files), check "Honour all schema locations"
  7. Validate C.xsd again. Verify that the error message should disappear.

[edit] Modify full schema conformance

  1. Import the XML Examples: New -> Example ... -> Editing and validating XML files
  2. Go to Window -> Preferences -> XML -> XML Schema Files, verify by default the preference "Check full XML Schema conformance" is enabled
  3. Create a new schema file like below:

FullConformance.xsd

<?xml version="1.0" encoding="UTF-8"?>
<schema xmlns="http://www.w3.org/2001/XMLSchema" targetNamespace="http://www.example.org/FullConformance"
	xmlns:tns="http://www.example.org/FullConformance" elementFormDefault="qualified">
 
	<element name="Name"></element>
 
	<complexType name="NewComplexType">
		<sequence>
			<element minOccurs="0" maxOccurs="1" ref="tns:Name"></element>
			<any></any>
		</sequence>
 
	</complexType>
</schema>
  1. Validate this file and verify that an error is displayed (prefixed by cos-nonambig)
  2. Go back to the preference and uncheck the preference Check full XML Schema conformance
  3. Validate the file and verify that error disappears.

[edit] Remove unused imports (New to 3.0.1)

  1. Import the XML Examples: New -> Example ... -> Editing and validating XML files
  2. Go to Window -> Preferences -> XML -> XML Schema Files -> Editor (Note: In WTP 3.0.5, it's Window -> Preferences -> XML -> XML Schema Files), uncheck, if needed, Automatically remove unused XSD imports and XML Namespace entries
  3. Open XMLExamples/GolfCountryClub/GolfCountryClub.xsd
  4. Switch to source view, add <import schemaLocation="../PhoneBanking/PhoneBanking.xsd" namespace="http://www.example.com/PhoneBanking"></import> as a child to the top level element <schema>
  5. Save and verify that the import is persisted
  6. Go to Window -> Preferences -> XML -> XML Schema Files -> Editor (Note: In WTP 3.0.5, it's Window -> Preferences -> XML -> XML Schema Files, check Automatically remove unused XSD imports and XML Namespace entries
  7. Add a white space after the </import> tag and save
  8. Verify that the import is removed

[edit] Adhoc Tests

Please go to Full XSD Function Test Scenarios and randomly pick some tests that are not in neither the core tests nor the secondary rotating tests.

[edit] Links