Skip to main content
Jump to: navigation, search

Difference between revisions of "Dawn Codegen"

(Dawn Codegen)
(Dawn Codegen)
Line 1: Line 1:
 
=Dawn Codegen=
 
=Dawn Codegen=
  
 +
We will examine the Dawn Codegen by using the Acore example from the Dawn SDK. In the beginning we need to get all necessary model files. Open the Plug-ins View (Window-->Show View-->Others) as shown in the picture below.
 +
 +
[[Image:Dawn_openpluginsView.png]]
 +
 +
Now select the plug-in '''org.eclipse.emf.cdo.dawn.examples.acore''' and import it as soure plug-in
 +
 +
[[Image:Dawn_PluginsView2.png]]
 +
 +
 +
<!--**************************************************
 
Check out the examples project
 
Check out the examples project
  
Line 20: Line 30:
  
 
[[Image:Cvsperspective3.png]]
 
[[Image:Cvsperspective3.png]]
 +
 +
**************************************************-->
 +
  
 
Now we will generate the code as you would do it for a normal project. This means the model code, the edit plug-in and GMF diagram plug-in.
 
Now we will generate the code as you would do it for a normal project. This means the model code, the edit plug-in and GMF diagram plug-in.

Revision as of 05:07, 17 September 2010

Dawn Codegen

We will examine the Dawn Codegen by using the Acore example from the Dawn SDK. In the beginning we need to get all necessary model files. Open the Plug-ins View (Window-->Show View-->Others) as shown in the picture below.

Dawn openpluginsView.png

Now select the plug-in org.eclipse.emf.cdo.dawn.examples.acore and import it as soure plug-in

Dawn PluginsView2.png



Now we will generate the code as you would do it for a normal project. This means the model code, the edit plug-in and GMF diagram plug-in.


GenerateModelCode.png

GenerateDiagramCode.png

Now your workspace contains the plug-ins: the one containing the model code, the edit plug-in and the diagram plug-in. Now right click the the gmf gen model an examine the context menu. You will see an additional entry called "Generate Dawn Genmodel"

Dawncodegen1.png

Running this will create a new file called acore.dawngenmodel. This model contains specific information for the Dawn generator.

Dawngenmodel.png


For example it allows to configure the names of the extension classes generated by dawn.

Dawngenmodel2.png

In a final step now right click the Dawn genmodel and choose "Generate Dawn GMF Fragment" from the context menu.

Dawncodegen2.png

Now a fragment will be created containing all the specific extensions for your diagram.

Dawnfinish.png

Back to the top