Skip to main content
Jump to: navigation, search

Dali

Revision as of 19:00, 6 April 2006 by Nhauge (Talk | contribs)

Dali EJB Object Relational Mapping Project

Welcome to the Dali project wiki home. These pages will be used to document our evolving project plans, and future integration into the WTP.

Milestone Plan

(Subject to change)

Milestone 1 - Iteration 1: Feb 10, 2006 - Complete

Iteration Goals:

  • Support broad array of annotations, including id, basic, and association mappings
  • Support Embeddeds, MappedSuperclass,
  • Integrated DB support via WTP's wst.rdb component
  • DDL Generation (postponed to Milestone 2)
  • Problems support for invalid mappings
  • Compliant with EJB3 Persistence Spec - Proposed Final Draft (with exception of a name change for GeneratorType to GenerationType; this will be fixed in an early M1I2 build)

Target Compatibility: Eclipse 3.1.2, WTP 1.0

Milestone 1 - Iteration 2: March 10, 2006

Iteration Goals:

  • Entity Generation from Tables (Phase 1)
  • DDL Generation from Entities
  • Management of Persistence XML (Moved to Milestone 2)
  • Enhanced Problem reporting

Target Compatibility: Eclipse 3.1.2, WTP1.0.1

Milestone 2: April 14, 2006

Milestone Goals:

  • Entity Generation from Tables (Phase 2)
  • Support for IdClass, EmbeddedID
  • Support multiple JoinColumns for association mappings

Target Compatibility: Eclipse 3.2M6, WTP1.5M6

Milestone 3: May 12, 2006

Milestone Goals:

  • Support for Inheritance
  • Callbacks support
  • Generator Library
  • Text based support for query entry
  • Annotation Value completion (Dependency on core APT support)
  • Enhanced outline view (quick view of entity config)(may be moved to 1.0)
  • Integration with Java refactoring (may be moved to 1.0)
    • Quick fixes
    • Text markers

Target Compatibility: Eclipse 3.2RC3, WTP1.5RC3

Milestone 4: May 26, 2006

Target Compatibility: Eclipse 3.2RC4, WTP1.5RC4

Milestone 5: June 16, 2006

Target Compatibility: Eclipse 3.2RC5, WTP1.5RC5

Release 0.5: June 28, 2006

Target Compatibility: Eclipse 3.2, WTP1.5

Back to the top