Difference between revisions of "DTP PMC Meeting, August 12, 2008"

From Eclipsepedia

Jump to: navigation, search
Line 14: Line 14:
 
**Second issue is that two builds - M1 and M2 were done over the weekend, but only M2 broke with this 3.4 API usage. Have sent an e-mail to Xiaoying to figure out why the M1 build didn't break.  
 
**Second issue is that two builds - M1 and M2 were done over the weekend, but only M2 broke with this 3.4 API usage. Have sent an e-mail to Xiaoying to figure out why the M1 build didn't break.  
 
**Larry also mentioned that he's found a possible bug in DTP related to the change we made to driver definition IDs, but he can't reproduce it in DTP, just with the IBM code. He's still investigating. This may force another respin of 1.6.1 M1
 
**Larry also mentioned that he's found a possible bug in DTP related to the change we made to driver definition IDs, but he can't reproduce it in DTP, just with the IBM code. He's still investigating. This may force another respin of 1.6.1 M1
 +
*DTP 1.6.1 M1 Updates
 +
**Larry found a fix for the IMarker breakage that works in 3.3 and 3.4 [https://bugs.eclipse.org/bugs/show_bug.cgi?id=243518[here]]
 +
**Larry found a fix for the Driver ID issue he found [https://bugs.eclipse.org/bugs/show_bug.cgi?id=243829[here]]
 +
*Questions
 +
**Do we approve these two bugs and say that this is the end of M1? We can't keep extending this indefinitely
 +
**Ask for one final M1 build from Xiaoying and call it good
 
*Open discussion
 
*Open discussion
  

Revision as of 12:17, 12 August 2008

Back to DTP PMC Meeting Page

Contents

Attendees

  • Brian Fitzpatrick
  • Linda Chan
  • Sheila Sholars

Regrets

  • John Graham

Agenda

  • DTP 1.6.1 M1 issues
    • At the Connectivity Team meeting, we discussed 1.6.1 M1 build and the IMarker breakage that caused the 1.6.1 M2 build to break. Larry has pulled that fix out of the M2 build, but wants us to keep it in the M1 build for now, as the product they are using M1 for is 3.4-based.
    • We (PMC) need to discuss what to do in this case. I believe we need a new build that is 3.3-based, since that's what we're supporting in Ganymede (lowest common denominator). But how we support this with IBM's request is a bit of a quandary.
    • Second issue is that two builds - M1 and M2 were done over the weekend, but only M2 broke with this 3.4 API usage. Have sent an e-mail to Xiaoying to figure out why the M1 build didn't break.
    • Larry also mentioned that he's found a possible bug in DTP related to the change we made to driver definition IDs, but he can't reproduce it in DTP, just with the IBM code. He's still investigating. This may force another respin of 1.6.1 M1
  • DTP 1.6.1 M1 Updates
    • Larry found a fix for the IMarker breakage that works in 3.3 and 3.4 [here]
    • Larry found a fix for the Driver ID issue he found [here]
  • Questions
    • Do we approve these two bugs and say that this is the end of M1? We can't keep extending this indefinitely
    • Ask for one final M1 build from Xiaoying and call it good
  • Open discussion

Minutes

Action Items

Tabled for Later Discussion