Difference between revisions of "DTP Ganymede Development Environment"

From Eclipsepedia

Jump to: navigation, search
 
(3 intermediate revisions by one user not shown)
Line 1: Line 1:
 
{{Back To|name=DTP Main Page|href=Data Tools Platform Project}}
 
{{Back To|name=DTP Main Page|href=Data Tools Platform Project}}
==Status==
 
 
'''[8/17/07]:''' This document is a '''draft''' and has not been reviewed/approved by the DTP PMC. It '''should not''' be taken as the offical position of DTP until reviewed and approved.
 
  
 
==Introduction==
 
==Introduction==
As described in the [[DTP Ganymede Build Environment | DTP Ganymede build documentation]], we are building against Eclipse 3.3.x (latest x, with associated GEF version and EMF 3.2.2) and a Sun 1.4 VM. The primary ''test'' environment is the latest M/RC for Eclipse 3.4 (with associated EMF and GEF versions) and a Sun 1.5 VM. We are doing this in an attempt to make DTP Ganymede available on both Eclipse 3.3.x/3.4 and 1.4.2+ VMs. In order for this to work, all DTP committers '''must''' be developing against a Eclipse 3.3.x target platform with a 1.4.2 VM. Doing otherwise runs the very real risk (as was demonstrated by a number of build breakages during DTP 1.5) that Eclipse 3.4 features will be used, hence invalidating the code in the build environment. Given the past confusion in this area, this page is designed to explain how to achieve the required configuration, regardless of your preferred Eclipse development version.
+
As described in the [[DTP Ganymede Build Environment | DTP Ganymede build documentation]], we are building against Eclipse 3.3.x (latest x, with associated GEF version and EMF 3.2.2) and a Sun 1.4.2 VM. The primary ''test'' environment is the latest M/RC for Eclipse 3.4 (with associated EMF and GEF versions) and a Sun 1.5 VM. We are doing this in an attempt to make DTP Ganymede available on both Eclipse 3.3.x/3.4 and 1.4.2+ VMs. In order for this to work, all DTP committers '''must''' be developing against a Eclipse 3.3.x target platform with a 1.4.2 VM. Doing otherwise runs the very real risk (as was demonstrated by a number of build breakages during DTP 1.5) that Eclipse 3.4 features will be used, hence invalidating the code in the build environment. Given the past confusion in this area, this page is designed to explain how to achieve the required configuration, regardless of your preferred Eclipse development version.
 
==DTP Ganymede Development Environment==
 
==DTP Ganymede Development Environment==
 
You can develop DTP Ganymede using Eclipse 3.3.x or 3.4 (perhaps other versions too, if you wish), but you must be sure to set the proper ''target platform''. The target platform configuration is located in Window->Preferences...->Plug-in Development->Target Platform and looks like:
 
You can develop DTP Ganymede using Eclipse 3.3.x or 3.4 (perhaps other versions too, if you wish), but you must be sure to set the proper ''target platform''. The target platform configuration is located in Window->Preferences...->Plug-in Development->Target Platform and looks like:
Line 29: Line 26:
 
* If you additionally create an Eclipse 3.3 location, but using EMF 2.3 (instead of 2.4), you can build/test in Eclipse 3.3 using a 1.5 VM.
 
* If you additionally create an Eclipse 3.3 location, but using EMF 2.3 (instead of 2.4), you can build/test in Eclipse 3.3 using a 1.5 VM.
  
The main point is, however, that DTP Ganymede code '''must''' be developed using a Eclipse 3.3.x and 1.5 VM target platform.
+
Also, you'll want to be sure that the default compiler level is set to a 1.4 VM:
 +
 
 +
[[Image:Java_compiler_setting.JPG]]
 +
 
 +
The main point is, however, that DTP Ganymede code '''must''' be developed using a Eclipse 3.3.x and 1.4.2 VM target platform.
  
 
[[Category:Data Tools Platform]]
 
[[Category:Data Tools Platform]]

Latest revision as of 12:19, 1 November 2007

Back to DTP Main Page


[edit] Introduction

As described in the DTP Ganymede build documentation, we are building against Eclipse 3.3.x (latest x, with associated GEF version and EMF 3.2.2) and a Sun 1.4.2 VM. The primary test environment is the latest M/RC for Eclipse 3.4 (with associated EMF and GEF versions) and a Sun 1.5 VM. We are doing this in an attempt to make DTP Ganymede available on both Eclipse 3.3.x/3.4 and 1.4.2+ VMs. In order for this to work, all DTP committers must be developing against a Eclipse 3.3.x target platform with a 1.4.2 VM. Doing otherwise runs the very real risk (as was demonstrated by a number of build breakages during DTP 1.5) that Eclipse 3.4 features will be used, hence invalidating the code in the build environment. Given the past confusion in this area, this page is designed to explain how to achieve the required configuration, regardless of your preferred Eclipse development version.

[edit] DTP Ganymede Development Environment

You can develop DTP Ganymede using Eclipse 3.3.x or 3.4 (perhaps other versions too, if you wish), but you must be sure to set the proper target platform. The target platform configuration is located in Window->Preferences...->Plug-in Development->Target Platform and looks like:

TargetplatformGanymede1.JPG

To use this for developing DTP Ganymede, you should have:

  • An Eclipse 3.3.x (latest x, with associated EMF and GEF versions) location
  • An Eclipse 3.4, latest M or RC (with associated GEF version and EMF 2.2.2) location
  • Sun Java 1.4.2 VM installed

You must make sure that the target platform is set correctly. In the configuration dialog shown above, you can Browse... to the necessary folder. For standard DTP Ganymede development, this should be the folder containing Eclipse 3.3.x. Select the folder, and verify that all the expected plug-ins appear in the dialog list. If you are developing in Eclipse 3.3.x, then the default selection to your development environment will be fine.

Next, you need to make sure that the correct VM version is being used. Check the second tab on the Target Platform dialog:

TargetplatformGanymede2.JPG

If the correct VM version does not appear, selected it from the drop-down list. If the required version does not appear in the drop-down list, then you should add the install location using the Window->Preferences...->Java->Installed JREs page. Once the configuration is set correctly, click "OK" to accept any changes. Regardless of the version of Eclipse that you are running, plug-ins developed within it will be built as described above. The advantage that the target platform mechanism gives over, for example, restricting yourself to developing only in the required environment is that you can easily switch target platforms to build/test against different Eclipse/VM combinations. For example, if you have the two Eclipse locations mentioned in the above list, then you can change the target platform for a variety of interesting configurations:

  • Eclipse 3.4 and a 1.5 VM: Run a "sanity" build to make sure there is no breakage when using 3.4.
  • If you additionally create an Eclipse 3.3 location, but using EMF 2.3 (instead of 2.4), you can build/test in Eclipse 3.3 using a 1.5 VM.

Also, you'll want to be sure that the default compiler level is set to a 1.4 VM:

Java compiler setting.JPG

The main point is, however, that DTP Ganymede code must be developed using a Eclipse 3.3.x and 1.4.2 VM target platform.