Jump to: navigation, search

DTP Development Environment

Revision as of 00:20, 4 February 2012 by Lchan.actuate.com (Talk | contribs)

Back to DTP Main Page


Introduction

The DTP project is designed to work on multiple Eclipse versions. The official DTP build is done using Eclipse 3.6.2 and Java 5, and this is the minimum supported platform version. DTP is tested on the minimum platform version and on the latest platform version (which is currently Eclipse 3.7.2 and Java 6.) DTP committers must be developing against the minimum platform version in order to avoid build breakages.

Starting in DTP 1.10 (Juno release), a DTP bundle may specify its required use of Java 6 compiler, if applicable, by specifying the following BREE setting in the bundle manifest.mf :

  Bundle-RequiredExecutionEnvironment: JavaSE-1.6

The BREE entry is required by Eclipse simultaneous release in all bundles with Java code. It would trigger the DTP build task to use the corresponding version of JDK to compile the bundle.

DTP Development Environment

You can develop DTP using Eclipse 3.4.2 or later, but be sure to set your target platform to match the minimum platform. The target platform configuration is located in Window->Preferences...->Plug-in Development->Target Platform and looks like:

TargetplatformGanymede1.JPG

To use this for developing DTP Ganymede, you should have:

  • An Eclipse 3.4.2 (with associated EMF and GEF versions) location
  • An Eclipse 3.6 with associated EMF and GEF versions) location
  • Java 5 (JRE/JDK 1.5) VM installed

You must make sure that the target platform is set correctly. In the configuration dialog shown above, you can Browse... to the necessary folder. For standard DTP development, this should be the folder containing Eclipse 3.4.2. Select the folder, and verify that all the expected plug-ins appear in the dialog list.

Next, you need to make sure that the correct VM version is being used. Check the second tab on the Target Platform dialog:

TargetplatformGanymede2.JPG

If the correct VM version does not appear, selected it from the drop-down list. If the required version does not appear in the drop-down list, then you should add the install location using the Window->Preferences...->Java->Installed JREs page. Once the configuration is set correctly, click "OK" to accept any changes. Regardless of the version of Eclipse that you are running, plug-ins developed within it will be built as described above. The advantage that the target platform mechanism gives over, for example, restricting yourself to developing only in the required environment is that you can easily switch target platforms to build/test against different Eclipse/VM combinations.

Also, you'll want to be sure that the default compiler level is set to a 1.5 VM:

Java compiler setting.JPG