Jump to: navigation, search

Difference between revisions of "DLTK Installation"

Line 3: Line 3:
 
== Requirements ==
 
== Requirements ==
  
* [[Dynamic Languages Toolkit]] (DLTK 0.8) requires [http://www.eclipse.org/platform Eclipse Platform] 3.2
+
[[Dynamic Languages Toolkit]] 0.9 and later require [http://www.eclipse.org/platform Eclipse Platform] 3.3 or later. Optional DLTK components like [[Mylyn]] integration component or remote development with [[DSDP TM]] component may enforce additional requirements. Please check requirements section on download pages.
* [[Dynamic Languages Toolkit]] (DLTK 0.9) requires [http://www.eclipse.org/platform Eclipse Platform] 3.3
+
  
 
==Installing DLTK==
 
==Installing DLTK==
  
===Release Builds===
+
DLTK 0.9 is a part of [http://www.eclipse.org/europa/ Eclipse Europa] annual release. DLTK 1.0 is going to be a part of [http://www.eclipse.org/ganymede/ Ganymede Release Train], so DLTK may be installed with simultaneous release installation process.
  
You may download DLTK 0.9 from the [http://www.eclipse.org/dltk/downloads.php DLTK Downloads page], or using Eclipse Update Manager with [http://download.eclipse.org/technology/dltk/updates Dynamic Languages Toolkit Update Site].
+
You may download DLTK from the [http://www.eclipse.org/dltk/downloads.php DLTK Downloads page], or use Eclipse Update Manager with Dynamic Languages Toolkit Update Site:[http://download.eclipse.org/technology/dltk/updates] (Releases only). If you're on bleeding edge, integration and stable builds of DLTK 1.0 avaiable with Development Update Site: [http://download.eclipse.org/technology/dltk/updates-dev/1.0/site.xml]
 
+
===Integration and Stable Builds===
+
 
+
Ongoing builds available at following update sites:
+
 
+
* '''DLTK 0.9 (Eclipse 3.3) Integration and Stable builds''' - [http://download.eclipse.org/technology/dltk/updates-dev/0.9/site.xml http://download.eclipse.org/technology/dltk/updates-dev/0.9/]
+
 
+
Or may be dowloaded from [http://download.eclipse.org/technology/dltk/downloads/ this page].
+
  
 
[[Category:DLTK]]
 
[[Category:DLTK]]

Revision as of 04:38, 7 May 2008

Incubation Phase

Requirements

Dynamic Languages Toolkit 0.9 and later require Eclipse Platform 3.3 or later. Optional DLTK components like Mylyn integration component or remote development with DSDP TM component may enforce additional requirements. Please check requirements section on download pages.

Installing DLTK

DLTK 0.9 is a part of Eclipse Europa annual release. DLTK 1.0 is going to be a part of Ganymede Release Train, so DLTK may be installed with simultaneous release installation process.

You may download DLTK from the DLTK Downloads page, or use Eclipse Update Manager with Dynamic Languages Toolkit Update Site:[1] (Releases only). If you're on bleeding edge, integration and stable builds of DLTK 1.0 avaiable with Development Update Site: [2]