Jump to: navigation, search

Difference between revisions of "DLTK Installation"

m (Requirements: update for 2.0)
 
(9 intermediate revisions by 2 users not shown)
Line 3: Line 3:
 
== Requirements ==
 
== Requirements ==
  
* [[Dynamic Languages Toolkit]] (DLTK 0.8) requires [http://www.eclipse.org/platform Eclipse Platform] 3.2
+
[[DLTK|Dynamic Languages Toolkit]] 2.0 requires [http://www.eclipse.org/platform Eclipse Platform] 3.5 or later. Optional DLTK components like [http://www.eclipse.org/mylyn Mylyn] integration or remote development with [http://www.eclipse.org/dsdp/tm DSDP TM] component may enforce additional requirements. Please check requirements section on download pages.
* [[Dynamic Languages Toolkit]] (DLTK 0.9) requires [http://www.eclipse.org/platform Eclipse Platform] 3.3
+
  
 
==Installing DLTK==
 
==Installing DLTK==
  
===Release Builds===
+
DLTK 1.0 was a part of [http://www.eclipse.org/galileo/ Eclipse Galileo] annual release. Latest DLTK 2.0 is a part of [http://www.eclipse.org/helios/ Eclipse Helios].
  
You may download DLTK 0.9 from the [http://www.eclipse.org/dltk/downloads.php DLTK Downloads page], or using Eclipse Update Manager with [http://download.eclipse.org/technology/dltk/updates Dynamic Languages Toolkit Update Site].
+
DLTK can be downloaded from the [http://download.eclipse.org/technology/dltk/downloads/ DLTK Downloads page], or with Eclipse Update Manager using Dynamic Languages Toolkit Update Site: [http://download.eclipse.org/technology/dltk/updates http://download.eclipse.org/technology/dltk/updates] ('''Releases only''').  
  
===Integration and Stable Builds===
+
[[Category:DLTK]]
 
+
Ongoing builds available at following update sites:
+
 
+
* '''DLTK 0.9 (Eclipse 3.3) Integration and Stable builds''' - [http://download.eclipse.org/technology/dltk/updates-dev/0.9/site.xml http://download.eclipse.org/technology/dltk/updates-dev/0.9/]
+
 
+
Or may be dowloaded from [http://download.eclipse.org/technology/dltk/downloads/ this page].
+

Latest revision as of 17:05, 14 September 2010

Incubation Phase

Requirements

Dynamic Languages Toolkit 2.0 requires Eclipse Platform 3.5 or later. Optional DLTK components like Mylyn integration or remote development with DSDP TM component may enforce additional requirements. Please check requirements section on download pages.

Installing DLTK

DLTK 1.0 was a part of Eclipse Galileo annual release. Latest DLTK 2.0 is a part of Eclipse Helios.

DLTK can be downloaded from the DLTK Downloads page, or with Eclipse Update Manager using Dynamic Languages Toolkit Update Site: http://download.eclipse.org/technology/dltk/updates (Releases only).