Difference between revisions of "DLTK Installation"

From Eclipsepedia

Jump to: navigation, search
(Installing DLTK from an Update Site)
m (Requirements: update for 2.0)
 
(17 intermediate revisions by 3 users not shown)
Line 1: Line 1:
 +
{{incubation}}
 +
 
== Requirements ==
 
== Requirements ==
  
* [[Dynamic Languages Toolkit]] (DLTK 0.x) requires [http://www.eclipse.org/platform Eclipse Platform] 3.2
+
[[DLTK|Dynamic Languages Toolkit]] 2.0 requires [http://www.eclipse.org/platform Eclipse Platform] 3.5 or later. Optional DLTK components like [http://www.eclipse.org/mylyn Mylyn] integration or remote development with [http://www.eclipse.org/dsdp/tm DSDP TM] component may enforce additional requirements. Please check requirements section on download pages.
* [[Dynamic Languages Toolkit]] (DLTK 1.0) requires [http://www.eclipse.org/platform Eclipse Platform] 3.3
+
  
==Installing DLTK from an Update Site==
+
==Installing DLTK==
  
You can install DLTK from your Eclipse workbench using the following update sites:
+
DLTK 1.0 was a part of [http://www.eclipse.org/galileo/ Eclipse Galileo] annual release. Latest DLTK 2.0 is a part of [http://www.eclipse.org/helios/ Eclipse Helios].
  
* '''DLTK 0.8 Integration and Stable builds (TCL only)''' - [http://download.eclipse.org/technology/dltk/updates/1.0/site-interim.xml http://download.eclipse.org/technology/dltk/updates/0.8/site-interim.xml]
+
DLTK can be downloaded from the [http://download.eclipse.org/technology/dltk/downloads/ DLTK Downloads page], or with Eclipse Update Manager using Dynamic Languages Toolkit Update Site: [http://download.eclipse.org/technology/dltk/updates http://download.eclipse.org/technology/dltk/updates] ('''Releases only''').
  
* '''DLTK 1.0 Integration and Stable builds''' - [http://download.eclipse.org/technology/dltk/updates/1.0/site-interim.xml http://download.eclipse.org/technology/dltk/updates/1.0/site-interim.xml]
+
[[Category:DLTK]]

Latest revision as of 17:05, 14 September 2010

Incubation Phase

[edit] Requirements

Dynamic Languages Toolkit 2.0 requires Eclipse Platform 3.5 or later. Optional DLTK components like Mylyn integration or remote development with DSDP TM component may enforce additional requirements. Please check requirements section on download pages.

[edit] Installing DLTK

DLTK 1.0 was a part of Eclipse Galileo annual release. Latest DLTK 2.0 is a part of Eclipse Helios.

DLTK can be downloaded from the DLTK Downloads page, or with Eclipse Update Manager using Dynamic Languages Toolkit Update Site: http://download.eclipse.org/technology/dltk/updates (Releases only).