Skip to main content
Jump to: navigation, search

Difference between revisions of "Corona Project Container Explorer"

 
(Importing project sources)
 
(6 intermediate revisions by 2 users not shown)
Line 7: Line 7:
 
</table>
 
</table>
 
----
 
----
''Project Container Explorer'' (or ''PCX'' in short) is the central view of Corona. It is the same for Corona as ''Package Explorer'' for Java development. It contains a list of all project containers defined at a server. With PCX you can not only view them but also open, import sources.
+
''Project Container Explorer'' (or ''PCX'' in short) is the central view of Corona. It is the same for Corona as ''Package Explorer'' for Java development. It contains a list of all project containers defined on the Corona Collaboration Server. With PCX you can not only view Project Containers but also open, and import Eclipse Projects.
  
 
== Opening the view ==
 
== Opening the view ==
 
To open the view do fallowing:
 
To open the view do fallowing:
 
# Select from menu: '''Window''' > '''Show view''' > '''Other'''.
 
# Select from menu: '''Window''' > '''Show view''' > '''Other'''.
# At the window that appear find '''Corona''', expand it, select '''Project Container Explorer''' and press '''OK'''.
+
# In the Show View Window that appears find '''Corona''', expand it, select '''Project Container Explorer''' and press '''OK'''.
 
# The Project Container Explorer should appear. It usually is undocked - dock it to one of vertical side bars.
 
# The Project Container Explorer should appear. It usually is undocked - dock it to one of vertical side bars.
  
Line 18: Line 18:
  
 
== Using the view ==
 
== Using the view ==
The opened PCX contains list of all project containers defined at a server. This is a flat list with grayed icons, which indicates the project container is closed. When a project container is opened, the icon becomes colorful and the node can be expanded. The sub-nodes of the project container are always some resources associated with the project, like sources, bugzilla, wiki page, etc.
+
The opened PCX contains a list of all project containers defined on a Collaboration Server. This list contains grayed icons, which indicate whether a Project Container is opened or closed. When a project container is opened, the icon becomes colorful and the Project Container Node can be expanded. The sub-nodes of the project container are resources associated with the project, like Eclipse Projects, Bugzilla Links, Wiki Page Links, etc.
  
  
 
=== Opening a Project Container ===
 
=== Opening a Project Container ===
The first operation you need to do with PCX i opening a project container.  
+
The first use of the PCX is opening a project container.  
 
# Find a project container you are interested in.  
 
# Find a project container you are interested in.  
# Right-click at the project container you are interested in.
+
# Open project container by:
# Select '''Open project container'''
+
#* Double click the project container.
 +
#* Pop-up menu:
 +
#*# Right-click at the project container you are interested in.
 +
#*# Select '''Open project container'''
  
The open operation has some implications. The server is notified that you have opened the project container. There is sent an event with this information. If you are a team member, your status will be changed to ''online'' in others workbenches.
+
 
 +
The open operation has some implications. The server is notified that you have opened the project container. A Collaboration Event is sent with this information. If you are a team member, your status will be changed to ''online'' in others team members Eclipse Workbenches.
  
 
The action opens also a new view: [[Corona Project Container View|Project Container View]], which displays all information about the opened project container.
 
The action opens also a new view: [[Corona Project Container View|Project Container View]], which displays all information about the opened project container.
  
'''BUG workaround''': Due to a [https://bugs.eclipse.org/bugs/show_bug.cgi?id=159849 bug], it happens that even though you selected an the ''open project container'' operation, the project container icon is still in gray and the node cannot be expanded. You need to use '''refresh''' action at the top of PCX view, displayed with [[Image:refresh.gif]] image.
+
'''BUG workaround''': Due to a [http://bugs.eclipse.org/bugs/show_bug.cgi?id=159849 bug], even though you selected an the ''open project container'' operation, the project container icon is still in gray and the node cannot be expanded. You need to manually '''refresh''' the PCX view, using the button displayed with [[Image:refresh.gif]] image at the top of the view.
  
 
[[Image:Corona_PCX_Open_PC.png]]
 
[[Image:Corona_PCX_Open_PC.png]]
 
  
 
=== Importing project sources ===
 
=== Importing project sources ===
One of the most important features of PCX is the ability to import project sources into your workbench. Each project container may contain several repositories with sources, so you can download them one by one or all with a single click.
+
One of the most important features of PCX is the ability to import Eclipse Projects into your workbench. Each project container may contain many Eclipse Project located several different repositories. You can import them one by one or all with a single click.
  
 
To import all sources:
 
To import all sources:
Line 47: Line 50:
 
# Select '''Import''' from pop-up menu.
 
# Select '''Import''' from pop-up menu.
  
Note: You might be asked for your login and password to the CVS repository.
+
Note: You might be prompted for your userid and password to the CVS repository.
  
 
Note: There is no way of overriding repository access method or server address defined in the project container. For example, if CVS repository is defined with ''extssh'' there is no way to change it to ''pserver''.
 
Note: There is no way of overriding repository access method or server address defined in the project container. For example, if CVS repository is defined with ''extssh'' there is no way to change it to ''pserver''.
  
 
[[Image:Corona_PCX_import_all.png]]
 
[[Image:Corona_PCX_import_all.png]]
 
  
 
=== Navigation through project resources ===
 
=== Navigation through project resources ===
 
As project container sub-nodes represent some resources associated with the project, you may want to navigate to see them. A double click on the repository will make the best effort to display content of the repository. So, if you double click on imported CVS sources, you will be switched to the corresponding workbench project in ''Package Explorer''. In other cases you will be switched to a [[Corona Project Container View|Project Container View]] tab which displays content of the resource.
 
As project container sub-nodes represent some resources associated with the project, you may want to navigate to see them. A double click on the repository will make the best effort to display content of the repository. So, if you double click on imported CVS sources, you will be switched to the corresponding workbench project in ''Package Explorer''. In other cases you will be switched to a [[Corona Project Container View|Project Container View]] tab which displays content of the resource.
 +
 +
== See also ==
 +
# [[Corona Project Container View|Project Container View]]

Latest revision as of 17:33, 2 November 2006

Corona Home Wiki Home User Guide

Project Container Explorer (or PCX in short) is the central view of Corona. It is the same for Corona as Package Explorer for Java development. It contains a list of all project containers defined on the Corona Collaboration Server. With PCX you can not only view Project Containers but also open, and import Eclipse Projects.

Opening the view

To open the view do fallowing:

  1. Select from menu: Window > Show view > Other.
  2. In the Show View Window that appears find Corona, expand it, select Project Container Explorer and press OK.
  3. The Project Container Explorer should appear. It usually is undocked - dock it to one of vertical side bars.

Eventlist open view1.png Corona Open PCX.png

Using the view

The opened PCX contains a list of all project containers defined on a Collaboration Server. This list contains grayed icons, which indicate whether a Project Container is opened or closed. When a project container is opened, the icon becomes colorful and the Project Container Node can be expanded. The sub-nodes of the project container are resources associated with the project, like Eclipse Projects, Bugzilla Links, Wiki Page Links, etc.


Opening a Project Container

The first use of the PCX is opening a project container.

  1. Find a project container you are interested in.
  2. Open project container by:
    • Double click the project container.
    • Pop-up menu:
      1. Right-click at the project container you are interested in.
      2. Select Open project container


The open operation has some implications. The server is notified that you have opened the project container. A Collaboration Event is sent with this information. If you are a team member, your status will be changed to online in others team members Eclipse Workbenches.

The action opens also a new view: Project Container View, which displays all information about the opened project container.

BUG workaround: Due to a bug, even though you selected an the open project container operation, the project container icon is still in gray and the node cannot be expanded. You need to manually refresh the PCX view, using the button displayed with Refresh.gif image at the top of the view.

Corona PCX Open PC.png

Importing project sources

One of the most important features of PCX is the ability to import Eclipse Projects into your workbench. Each project container may contain many Eclipse Project located several different repositories. You can import them one by one or all with a single click.

To import all sources:

  1. Right-click on the project container.
  2. Select Import all from pop-up menu.

To import a single source repository:

  1. Right-click on a repository with sources you want to import.
  2. Select Import from pop-up menu.

Note: You might be prompted for your userid and password to the CVS repository.

Note: There is no way of overriding repository access method or server address defined in the project container. For example, if CVS repository is defined with extssh there is no way to change it to pserver.

Corona PCX import all.png

Navigation through project resources

As project container sub-nodes represent some resources associated with the project, you may want to navigate to see them. A double click on the repository will make the best effort to display content of the repository. So, if you double click on imported CVS sources, you will be switched to the corresponding workbench project in Package Explorer. In other cases you will be switched to a Project Container View tab which displays content of the resource.

See also

  1. Project Container View

Back to the top